0 Replies Latest reply on May 18, 2011 5:38 AM by redbaron51

    DLP Agent Uninstall or Install (via ePO task)

    redbaron51

      Hi all,

       

      I have been testing DLP agent 9.1.0.522 - basically deploying through ZENWorks as a package rather than via ePO task.

       

      I have tried to setup an ePO task to uninstall DLP agent using the /forcerestart switch from the commandline field. It seems to kind of work, I mean, it does uninstall DLP Agent but at the end I get a McAfee Agent Updater pop up window asking for the computer to restart to finish the process. If I do nothing and wait few minutes the machine reboots itself. Upon booting up, I log back in to the machine, but it briefly displays the same pop up window and restarts itself. That means 2 reboots.

       

      I was wondering how other people are uninstalling DLP agent and the behaviour of the uninstall process.

       

      EDIT: I have just tried a task to install the DLP Agent with /forcerestart. It installs the agent but displays the same pop up window - Restart Required - 10 minutes passed an nothing happens. Interesting that McScript_InUse.exe is listed/hanging on taskmanager but 0% CPU

       

      It would be helpful if someone from McAfee could clarify how to successfully force a reboot to complete installation and/or uninstallation processes.