8 Replies Latest reply on Sep 3, 2012 3:45 PM by Peacekeeper

    IDispatch problem

      For weeks now I have been having issues.  Three days on the phone and chat with tech support. I had a different message then, error code 484570-654991592 and tech support told me they had no such error, then, uninstalled and reinstalled McAfee.  Sometimes, before I run a scan it says "failed IDispatch".  Sometimes the scan will go all the way through and after it is done it says "cannot find IDispatch" and no report. or it will not even tell me the files that were scanned.  It says "zero". I'm afraid I am not protected.

        • 1. Re: IDispatch problem
          Peacekeeper

          Ok we know the cause you use registry cleaners correct!!

           

          We/mcafee rather is testing varuious cleaners and some remove more than they should . Does your cleaner have a backup option like glary utilities.

           

          Have a read here

          https://community.mcafee.com/message/182024#182024

           

          there is another longer thread same cause

          There is a fix for it that I need to get permission to release to you. We need to know if you use registry cleaners and what 1. Also what operating system.

          • 2. Re: IDispatch problem

            I would have responded soon but I was in a tornado.  ANYWAY,  I did use SafetyOne, which is no longer available but I told the tech that first helped me that I did and before I did the final clean(whatever it is called, I have little knowledge of pc talk) I told him that there was many mcafee registries that said they were corrupt according to the SafetyOne scan.  The problem happened before I did SafetyOne.  The tech just had me uninstall and reinstall and the problem is getting worse.  I don't even know if my Mcafee is working because when I run a scan it keeps stopping on its own.  My operating system is windows 7.  Please help!

            • 3. Re: IDispatch problem
              Peacekeeper

              Ok try running this idispatch

               

              Backup registry close it and run the registry fix.

               

              Hmm are you still getting the idispatch popup? if not Maybe better to repeat uniinstall reinstall via HERE

               

               

              Use Australian site it will guarantee you will get the 2011 version

               

               

               

              Message was edited by: Ex_Brit on 03/09/12 12:19:11 EDT PM
              • 4. Re: IDispatch problem

                I have this problem and googled it and then i had to register with this site just so I could moan, I am sick of these PC boffins saying use this an download this to fix the problem or reinstall or uninstall , since I pay Mcafee to keep my computer clean why cannot they solve the problem as it seems to effect a lot of people using Mcafee. I get scan complete No Issues yet the little box says failed To Creat Idispatch, I am 70yrs of age now and not computer literate but to me it seems Mcfee created this problem not CCCleaner or regicure so why do they not fixit and why am i being asked to get or try Gary Utilities ARE THEY FREE???.

                By the way I am not using Regicure so i do not wish to be told its them that has corrupted my registry.

                And what the hell is System Mechanic doing or is it Iola Systems and also Avanced Systems Care4  I am not sure I use them as well to keep my machine clean

                And how is it when I do a complete Scan with Mcafee (paid for) I get No Issues then I do a complete scan with SUPERantiSpyware (FREE) and it finds issues.

                I think there is no real problem and these little error boxes are slipped in to frighten us into buying more clean machine software reckomended by geeks who get back handers from the the software companies they reckomend.

                I went into my hard drives registry  with a toothbrush some cotton buds and a bowl of warm water infused with a few drops of Fairy Liquid (I STRONGLY  reckomend you use Fairy Liquid they drop me a few bob) and I scrubed about for about ten minutes and let it all dry out I then switched back on and run a scan and the error message has gone.

                Please consult your Computer Manufacturer before using these methods

                • 5. Re: IDispatch problem
                  Peacekeeper

                  The registry patch above should fix the issue it is caused by registry cleaners they delete registry info that Mcafee uses.

                   

                  Not a mcafee cause but badly programed cleaners. Issue is easily fixed. What are you using any cleaners or tools? If nothing then we need to look further.

                   

                  Ok you tongue in cheek  said you cleaned the disk by washing it  what did you actually do?

                  • 6. Re: IDispatch problem

                    I have been getting a “Failed to create IDispatch” errormessage whenever I used McAfee Plus scan and contacted the McAfee (a Dellcompany) chat technician who said the problem was caused by “Systems Mechanic”program which a Dell technician recently sold to me due to another problem withmy recently purchased Dell laptop.

                    My question is why Dell can’t solve the problem between twoof it programs.

                    I will be going to Norton once my one year McAfeesubscription runs out.

                    • 7. Re: IDispatch problem
                      Hayton

                      If you've been using a registry cleaner and it's messed up the registry don't blame McAfee. We, and Microsoft's MVPs on their forums, know only too well that registry  cleaners often take out things that should not have been touched.

                       

                      There is (or was) a fix for this. Did you read the previous messages and get the registry fix?

                      • 8. Re: IDispatch problem
                        Peacekeeper

                        In other words read post 3 by yours truely. Click on the idispatch link and follow the FAQ steps.