5 Replies Latest reply on Apr 16, 2011 12:35 PM by mihaig

    mskdetct.dat write error

      I have unistalled McAfee suite and the programs and folders are gone. However, everytime I boot my PC I get the massage "Unable to write to C:\...\SpemKiller\mskdetct.dat". How can I get rid of the message?

        • 1. Re: mskdetct.dat write error
          k3tg

          Did you use the MCPR removal tool found at the top of this page under Useful Links? It is possible there still may be some remnants left over that failed to completely remove via the normal uninstall.

          • 2. Re: mskdetct.dat write error

            I tried your advice. Downloaded the MCPR tool. When I launched it, it copied some files and then showed the progress bar at 0% with the messages "CLEANUP FAILED" and "Cleanup is already running". The View Log button is disabled.

            • 3. Re: mskdetct.dat write error

              I did a file search and found in c:\Program Files\McAfee\SpeamKiller several files including mskdetct.exe. In Add Remove Programs it does not show any McAfee programs.

              I noticed that after the initiation of MCPR.exe mskdetct.exe is launched and continues to run even after closing the progress window. I killed mskdetct.exe and tried the MCPR tool again. Same error CLEANUP FAILED.

              • 4. Re: mskdetct.dat write error
                Peacekeeper

                Try running it in safe mode.

                To do this, tap F8 repeatedly while booting up. You'll get a boot screen with choices. Pick Safe Mode. Your PC will boot in a low resolution state as most processes won't be running. Go to "MyComputer" (XP) or "Computer" (Vista

                • 5. Re: mskdetct.dat write error

                  Thank you - it worked.

                   

                  Here are the details:

                   

                  - started computer in Safe Mode by pressing F8 during boot

                  - logged in

                  - started mcpr.exe

                  - program started successfully, but warned that not all files or components will be removed due to insuficient priviledges

                  - after it ran about 30% (by looking at the progress bar) I received again the message "Unable to write to C:\...\SpemKiller\mskdetct.dat"

                  - pressed OK, but MCPR was blocked - no more progress

                  - I opened task manager and noticed that mskdetct.exe was running at the same time with the cleanup program and the 2 UI processes for the open mcpr progress windows.

                  - killed mcpdetct.exe and the cleanup continued till the end

                  - asked for reboot

                  - after reboot the error message was gone.

                   

                  Note: mcpr takes a long time to run - 10 minutes or more, so be patient.