7 Replies Latest reply on Apr 8, 2011 7:53 PM by xbob

    where to start?

      I'm an end user at a school district in San Antonio. Going to describe an issue and am asking for guidance on how to proceed.

       

      Have a district issued laptop x two years, no issues until last Thurs. Started laptop, logged into district network, checked district email, no issues. Printed pdf, got popup message that file printed. Started word, left x 1 minute to check printer for pdf - not there and no status light like it was pending. Returned to laptop, checked print queue, no documents pending or in history.

       

      Then noticed that Word had not started, so I figured, typical Windows issues, I'll reboot. Went to Start, Shutdown, Reboot, machine began reboot. Goes through an HP splash screen to a screen that reads "Starting Safeboot 5.0" (that is all normal) but then I get an error message "Safeboot Error, Error 0xe0050001, Safeboot is not installed" and an OK button. Clicking the button or pressing enter loops meback through the HP splash screen, Starting Safeboot and the error message.

       

      IT helpdesk will only replace hard drive, not attempt any data recovery. I made a full backup in Dec but have three months of valuable work I need recovered (please save the backup editorials,I have been flogging myself since this occurred.)

       

      Here is where I need help. The machine is a Compac 6910p running XP. It was sold to us by HP. When is would startup normally, I would get an HP screen to log in, and then it would go to a plain (DOS type) screen reading Safeboot 5.0 is starting, and then it would go to Windows and then my Novell login. Now of course I am in this loop.

       

      I have a .dat file that has the HP credentials for this laptop. I do not have the .sdb or any other files for Safeboot recovery (yet), nor do I have BartPE or the McAfee safeboot recovery disk (that's not the right name but that's what it is).

       

      Do you think this is a Safeboot error or an HP disk encryption error? I'm trying to figure out what tool to use to attempt to recover my data.

       

      IT is not being very helpful and they just want to replace the drive and not attempt any data recovery.

       

      help!

       

      thanks,

       

      Bob

        • 1. Re: where to start?

          Some more info: The HP login screen that normally appears reads "Drive encryption for HP Protect tools" but at the bottom of the screen it says something about using Safeboot technology, and the screen just after this one says Sarting Safeboot 5.0.

           

          So, I'm trying to figure out do I go through McAfee for Safeboot, or HP for Protect Tools?

           

          Bob

          • 2. Re: where to start?

            Sounds like you caught a root kit virus unfortunately.

             

            You most certainly have "Drive Encryption for HP ProtectTools" - make sure you tell HP that, not "SafeBoot" - HP don't understand "SafeBoot" and will divert you to McAfee, where you most certainly can't get help for HP's product.

             

            If you have the .dat file on the USB key that's excellent - there is almost zero chance of you loosing your data as long as it's ther right DAT file for your activation. All you need now is to get a SafeTech bootable image (CD, Floppy etc) from HP and you can remove the encryption from the machine.

             

            The root kit virus will get nuked at the same time, but I expect it will put itself back once you boot into Windows again, so you should copy your data off and then have your drive replaced.

            • 3. Re: where to start?

              So, I was able to get the SafeTech .iso and make the bootableimage. Also have the HP DAT file. The hard drive with the issue was replaced, so I bought a SATA drive enclosure and installed that drive in the enclosure and hooked it up to the original laptop via USB 2.0.

               

              The computer sees the old drive, but reports it as unformatted and asks if I want to format (did not).

               

              Rebooted into SafeTech, was able to start Safetech, got the codeof the day entered, and it accepted the HP DAT code, so I have the Authorized messages at the bottomof the SafeTech screen.

               

              I'm able to mount the old drive in SafeTech, but when I try to remove the encryption, I get an error message that SafeBootis not installed (the same error message I got orignially.)

               

              I've looked over the SafeTech manual, but wanted to ask about how to best proceed. Should I do the INT 13 reset first and then see what happens, or do I need to physically reinstall the drive in the laptop and do it from there? Just not sure what to do in order to have a chance at recovering my files.

               

              thanks,

               

              Bob

              • 4. Re: where to start?

                you need to be talking to HP Bob - you are not using a McAfee product!

                 

                But no, DONT reset the int13 - that won't help you at all, and yes, it's quite correct that SafeBoot is not installed - it never was, plus the root kit removed the Drive Encryption for HP ProtectTools MBR.

                 

                The best chance of recovering your files lies with getting support from HP for their product. Failing that, assuming the drive is fully encrypted, just read the partition table in Disk Information, test decrypt the partition boot sector in the workspace to make sure your .dat file is indeed correct, confirm the end of the partiton is again correct in the same way, and then force decrypt the sector range. Remember to pick the right drive in SafeTech though - I doubt it will see your slaved USB device, you're probably going to have to reinstall it properly for this to work. 

                 

                remember though, this is not a McAfee product - you need to talk to HP for support.

                 

                Message was edited by: SafeBoot on 4/8/11 12:24:56 PM EDT
                • 5. Re: where to start?

                  Yes, but they have been remarkably unhelpful, and so far their only "solution" has been to refer me to you guys. At least with you guys I can get some ideas concerning how to proceed. Their rationale is that HP ProtectTools is based on SafeBoot technology, and since the error message is reading "Can't find SafeBoot.exe" it is a SafeBoot (not HP ProtectTools) issue.

                   

                  Pretty frustrating from an end users perspective, but that's life. I appreciate your time and comments so far - this is not my area of expertise.

                   

                  Thanks for your time. I plan to look at it some more over the weekend.

                   

                  Bob

                  • 6. Re: where to start?

                    Are you sure HP understand that you are a Drive Encryption for HP Protectools user? Ignore what the error message says - if you mention "SafeBoot" to HP's base level support team they will automatically think you are a proper SafeBoot user - ie you spent tens of thousands of dollars on an enterprise class encryption solution.

                     

                    That's not the case here - you are using HP's consumer version.

                    • 7. Re: where to start?

                      I tried every way I could to convince them, but they could not get past the SafeBoot error message...I guess I will go back and see if I can get it elevated in status.