9 Replies Latest reply on Oct 31, 2011 10:50 PM by Director

    ePO 4.5 Patch 3 to Patch 4 Install Error

    JayMan

      Hi All,

       

      Just wondering if anyone has had problems installing Patch4 onto their installations?

       

      Info in EPO450-Error.ini is:

      [ErrorLog]
      ErrorString=FAILURE: In LaunchAppAndWait while trying to run the following program:
      "C:\PROGRA~1\McAfee\EPOLIC~1\jre\bin\java.exe"

      Return code: 1
      Error Message: Incorrect function.

      ActionName=Prod_InstallEpoCore
      Task=Checking in epo

       

      I've got a support ticket open for this issue, however its slow to produce any real results.

       

      Have run through the items here https://kc.mcafee.com/corporate/index?page=content&id=KB60569&actp=search&search id=1253086440611 but doesn't seem to have helped. (I haven't uninstalled KB956572, as we are running an enlish installation which the KB article isn't referring to).

       

      Hopefully someone else has faced this issue with the P4 install & can point me in the right direction.

       

      Cheers!

        • 1. Re: ePO 4.5 Patch 3 to Patch 4 Install Error
          rackroyd

          java.exe is invoked numerous times during install, so context is important.

          Support should be asking you to run the install in full debug mode, so it can be paused at the point of failure.

          Then the full java command (which will be several lines long) can be cut from the msi log and executed in a cmd shell.

          This should provide a contextual error for the java command that is failing.

          It takes a bit of jiggery-pokery to get this right, so this may be done via a remote connection after escalation to a higher support tier.

           

          Unfortunately java.exe writes it's error messages in a way we cannot trap in the msi log, so we don't get the full error message by default.

           

          I'm afraid that these install issues can be slow, so please persevere with support - it will be worth it in the end.

           

          Thanks,

           

          Rob.

          1 of 1 people found this helpful
          • 2. Re: ePO 4.5 Patch 3 to Patch 4 Install Error
            metalhead

            Does the password of your used epo console user and db user contain any special characters ?

             

            Nachricht geändert durch metalhead on 31.03.11 15:20:19 MESZ
            • 3. Re: ePO 4.5 Patch 3 to Patch 4 Install Error
              JayMan

              The DB connection doesn't contain any special characters, nor does my account password.

               

              I'm awaiting another remote support session with my Tier 1 support person.

              I noticed yesterday afternoon that agents are no longer able to communicate since the latest batch of failed installations, so hopefully we can get that addressed at the least.

               

              The ports are open & listening on the ePO server side, I can open a telnet connection to those ports, however the agents all fail to actually connect. Seems like the ePO is refusing the connections.

               

              Fingers Crossed!

              • 4. Re: ePO 4.5 Patch 3 to Patch 4 Install Error
                hem

                Can we have patch-install and patch-roll back  log file for our review?

                 

                Additonally can we  have SR# for our review?

                • 5. Re: ePO 4.5 Patch 3 to Patch 4 Install Error

                  I have exactly the same problem. I already opened a support call (I'm waiting the reply).

                   

                  Did they understood and fixed the problem? What does it was?

                  • 6. Re: ePO 4.5 Patch 3 to Patch 4 Install Error
                    Troja

                    Hi all,

                    i had the same problem with this at a customer. We also opened a case but McAfee was not able to help us.

                     

                    The problem is a mix of the java applets. If you are installing a patch or a extension the java applications are installed in a specific language. We had a mix of German and Englisch. Installing Patch 3 was not able any more.

                     

                    This settings are used to define the language of you EPO Server installation

                    - System Language of you EPO Server System

                    - Regional Settings -> Location

                    - Unicode Settings are ignored

                    - The language of your database server (Collation should be latin 1

                     

                    When installing extensions the default language of internet explorer is used.

                     

                    You should also check the jave language in the registry

                    [HKEY_LOCAL_MACHINE/SOFTWARE/ApacheSoftware Foundation/Procrun 2.0/MCAFEETOMCATESRV200/Parameters/Java];

                    The values for Duser.country and Duser.variant should point to "en (ISO639)" (if you are using an english installation)

                     

                    Additional you can modify the setup.ini file in your epo 4.5 Patch 4 source

                    EnableLangDlg=Y

                    After changing this value you are prompted to select a language.

                     

                    I was not able to install Patch 3. We installed a fresh EPO Server, imported the ROOT CA, all keys for Tomcat and Apache. Regenerated the keys for Apache. Imported the Policies. After this, all was fine. It was much work but all clients from 130 locations connected to EPO again. We tried to solve the problem with McAfee Support. But after about three weeks we installed EPO new.

                     

                    I don´t know why McAfee uses such a stupid installation.

                     

                    cheers,

                    Thorsten

                    • 7. Re: ePO 4.5 Patch 3 to Patch 4 Install Error
                      Troja

                      As seen above, there is an McAfee KB for nor supported password characters

                       

                      Supported user name and password formats for ePO 4.5

                       

                                                     
                      Corporate KnowledgeBase ID:  KB66286
                      Last Modified:  February 08, 2011

                       

                       

                      Environment

                      For details of all supported operating systems, see KB51109.

                       

                      Summary

                      The following are supported Administrator and SQL database user name and password formats for ePO 4.5.

                       

                      For ePO 4.5 Administrator user names and passwords, the following are acceptable:

                      • All printable characters in the ISO8859-1 character set, with the following exceptions (for both user names and passwords, except as noted):
                           
                           
                        • No leading spaces, trailing spaces, or passwords which contain only spaces
                        • No double quotes (")
                        • No leading backslashes (\)
                        • User names cannot contain a colon (:)
                        • User names cannot contain a semi-colon (;)
                           

                       

                      For ePO 4.5 SQL user names and passwords, the following are acceptable:

                      • All printable characters in the ISO8859-1 character set, with the following exceptions (for both user names and passwords, except as noted):
                           
                           
                        • No leading space, trailing spaces, or passwords which contain only spaces
                        • No double quotes (")
                        • No single quotes (')
                        • No backslashes (\)
                        • User names cannot contain a colon (:)
                        • User names cannot contain a semi-colon (;)
                           
                      • Password size restriction
                           
                           
                        • Passwords must not exceed 127 bytes in length
                           

                       

                       

                       

                       

                      • 8. Re: ePO 4.5 Patch 3 to Patch 4 Install Error
                        JayMan

                        So far I am yet to get Patch4 to install successfully.

                        To get our agents to comminicate to the ePO again we had to peform a recovery of our DB & ePO server.

                         

                        Due to other commitments we are staying at Patch 3 for the next week or so, then hopefully I will have a remote session with Tier 2 support to try the installation again.

                         

                        Will definately have a look at what you have suggested Troja.

                        • 9. Re: ePO 4.5 Patch 3 to Patch 4 Install Error
                          Director

                          I have the exact same issue. Note that I did not encounter this error when previously upgrading from 4.5 Patch 1 to Patch 2 or from Patch 2 to Patch 3, so I don't think this is the password issue mentioned in this thread. Has anyone gotten a sensible response from McAfee Support about this yet?