4 Replies Latest reply on Mar 22, 2011 7:37 AM by noah

    FTP Distributed repository on Novell Netware.

      We are running Novell Netware 6.5, EPO server 4.5 patched to the latest version, VSE 8.7/8.8 (upgrading all to 8.8 as soon as possible) and I'm haivng a bit of trouble with FTP distributed repositories to Novell Netware 6.5 servers. I created a new Netware account called McAfeeReplication at the root of the tree, created the repository folder on the netware server, and gave the netware account full rights to the folder. In the EPO server I created a distributed repository. For download credentials I used .mcafeereplication.[treename] ( where treename is the name of our tree) and when I hit test credentials it passes. For replication credentials if I use the same account, which has full permissions, the test fails. I'm not sure why the test fails as the account has full permissions to the directory I created. When I look at the log it shows it using the account and trying to create the test.ini file but failing to do so.

       

      If I use my account ( [myname].department.building.[treename] ), which also has full permissions to the server, the test passes. I tried replicating to a local Netware server and a remote Netware server. On both Netware servers the EPO server says the replication completed without error, but when I got to look at the location I specified there are no files. If I click on the link that shows packages on the distributed repository it says there are no files there, so I'm looking in the correct spot.  On the remote server, replication it took about 30 minutes, so I know it at least was trying to upload the files. In the log that shows the EPO server performing the test it claims that it is able to write the test.ini file and then delete it in the directory I specified.

       

      As a test I tried replicating to one of our Linux servers and it works fine. I'm able to use the same credentials for download and replication and when I go to the repository directory the files are there. We also have numerous scanners that scan to the Netware servers using FTP so I'm fairly sure FTP is running correctly. If I go to the directories on the Netware server using an FTP client I'm able to create and delete files with the McAfeeReplication account without a problem.

       

      The only thing I can think of is that the server does not like the dots in the username; I did try using just the netware account username but it also failed though.

       

      Any ideas what I'm doing wrong?

       

      Thanks!

        • 1. Re: FTP Distributed repository on Novell Netware.

          Forgot to mention the EPO server is Windows Server 2003 with MSSQL something or other, can't remember the exact version right now.

           

          Message was edited by: noah on 3/21/11 8:06:44 PM CDT
          • 2. Re: FTP Distributed repository on Novell Netware.

            I've seen that problem before. The issue was something to do with the "Home" directory specified for the FTP user that dropped the files. A patch or NDS update or something similar broke that - causing exactly the issue you have. It could have been something to do with our gradual cut-over to SUSE and some pre-reqs required.

             

            Try using a manual FTP client and connect using the account. Note where you are dropped off!

             

            AS a workaround, there was a manual step to copy the files over. But long term, we migrated to FTP services on SUSE.

            1 of 1 people found this helpful
            • 3. Re: FTP Distributed repository on Novell Netware.

              It always starts in public, although I assumed that the server would go to the full directory I entered, since I'm going to ftp://servername/sys. I'll put a folder in public and see what happens. Thanks for the help.

              • 4. Re: FTP Distributed repository on Novell Netware.

                I figured it out, it is not working like I expect , but it is working.

                 

                As mjmurra pointed out about the default FTP drive I decided to create a new folder called servername/sys/public/eporeplication . I gave the replication account full right to it and still had the issue where the replication credentials were failing. I then gave full right to the public folder and it started working. I forced replication and the server was able to see the packages it placed on the server. I went to the above directory and was surprised to find it empty, even though the EPO server was seeing packages in it. I was confused, so I went up one level and found a brand new "sys" folder. I go into it and find an 'eporeplication" folder, and in that folder is the replication data.

                 

                I thought the FTP URL I was typing in was the full path to the folder I wanted, but that is not the case. The FTP path I typed in was taking the default FTP directory and then adding on the URL that I typed in.