9 Replies Latest reply on Apr 6, 2011 2:02 AM by virus-tester

    Client not upgraded to latest version

      Hello all

       

      We have recently (month ago) upgraded VirusScan Enterprise to version 8.7 but we have a lot of PC that still run 8.5 verison.

       

      Seams that these machines refuse to upgrade for some reason unknown to use. We tried to force update by chosing machines from query

      and using action and update but has no afect at all. DAT and scan engine er up to date but as I said VirusScan version is not.

       

      How does one go about and FORCE VirusScan version upgrade on these machines?

       

      Thanks

      A.B

        • 1. Re: Client not upgraded to latest version
          JoeBidgood

          The first thing to do is to identify why it is failing... are there any errors in the agent log? If you manually try and install 8.7 on one of these machines, do you get any error messages?

           

          Regards -

           

          Joe

          • 2. Re: Client not upgraded to latest version

            Thanks Joe for taking the time to answer.

             

            I forgot to mention (my bad) that I DID try to manually install by coping FramePkg.exe to machine and run installation remote (psexec) like so: FramePkg.exe /install=agent /forceinstall /s After that I run CmdAgent.exe /C /P /E to generate new info and contact epo but nothing has changed on that machine at all. This Machine is not rebooted after this since user is still using it.

             

            New log doesn't show anything unusual, so kinda stuck here.

            • 3. Re: Client not upgraded to latest version
              JoeBidgood

              Okay, doing this will install the agent on the machine - is it communicating with ePO correctly? (You can check to see if it's visibile in the ePO system tree, and check that the "last communication" property is correct.)

               

              Assuming it is communicating, then - pardon the question - but do you have a product deployment task configured for this machine? ePO won't automatically upgrade VSE on client machines - you need to configure a task to do this. (Note that in ePO terminology  "update" has a very specific meaning - it means to update content, like DATs and engines, but not to upgrade point products, which is done by deployment. This may be why the update now task you ran didn't do what you expected it to )

               

              Regards -

               

              Joe

              • 4. Re: Client not upgraded to latest version

                ePO has been installed and configured  before I took over so I will try to answer you to the best of my knowlage.

                 

                I can see a deployment task in system tree called 8.7 deployment and in that task no spec machine is mentioned at all, from what I can tell and see it says "send this task to all computers" so I guess this means all clients/domain that contacted sPO should in get this upgrade/update.

                 

                But thing that pusles me is that in nest TAB called configuration and under Products and components I can see both 8.7 and 8.5 version.Does thi s mean push both versions ?

                 

                So to summarize this :

                 

                Status:Enabled
                Options:
                Stop the task if it runs for 0 hour(s) and 40 minute(s)
                Start date:1/12/09 12:00 PM
                End date:No end date
                Type:At system startup

                 

                Hope this give more details that can lead me/us to solution.

                 

                Thanks

                • 5. Re: Client not upgraded to latest version
                  akill

                  Try to install VSE Manually on one of theses machines!

                  • 6. Re: Client not upgraded to latest version
                    Attila Polinger

                    To me it sounds like there were two versions of Virusscan in the same deployment task, one would never normally do. Please remove the VirusScan 8.5 product line from there as that surely not needed. Hard to tell if that was or was not the cause of your issue, but is worth a try.

                     

                    Reschedule the deployment thereafter to a specific time, wake up a test client and monitor if it succeeds now or not. If not, please take a look at McScript.log on the test client and find the line invoking the deployment task. Should htere be no such line then the whole task failed to get incorprated into the agent's tasks, in this case review the agent log at the time the wakeup happened.

                     

                    Feel free to post any screenshots if you want us to look at beforehand or even after that).

                     

                    Attila

                    • 7. Re: Client not upgraded to latest version

                      Been looking through deployment policy and notices (as I said before) that both 8.5 and 8.7 are in the same task which raised flags but thanks to you guys I'm now more certain that 8.5 must be removed from there. Here is a screenshot of that task

                      client-task.jpg

                       

                      Gonna remove 8.5 and test as suggest.

                      • 8. Re: Client not upgraded to latest version
                        Attila Polinger

                        Here is another tip for your issue: if those "lot of PCs" are Windows 7, then chances are that your ePO system is in need of performing the actions in KB67347.

                         

                        Attila

                        • 9. Re: Client not upgraded to latest version

                          Came to conclution that a lot of machines that McAfee query reports regarding client version query are actually offline. One would think that query also checks for "online/ping" status before actually reporting but this is not the case.

                           

                          So what I did was:

                          1.Run mcaffee query

                          2. Confirm that reported machines are actually in use or online (with script ofcourse or it will take ages)

                          3. Push agents to ones that are online and in use.

                           

                          Thanks for input guys