6 Replies Latest reply: Jun 21, 2013 5:25 AM by Sudeep Garg RSS

    "On-access Scan: Not Working"

    stargazer

      I just got a MAC Pro (the new version) and it had McAfee Security installed. Ity worked fine until it recently is giving me the notification - Your computer is at risk, "On-access Scan: Not Working". The On-access Scan is 'on' and I just scanned the computer and it works fine. Why is the program telling me it at risk?

       

      It seems as the update does not work.. Help anyone?

       

      Message was edited by: stargazer on 3/18/11 7:34:39 AM CDT

       

      I reinstalled everything and a few days later (today) the same notice is back again. What is going on? Please, help anyone?

       

      Message was edited by: stargazer on 3/22/11 11:49:41 AM CDT
        • 1. Re: "On-access Scan: Not Working"
          daver

          We're experiencing the exact same thing with new Mac's being delivered.  Running updates fails as well.

           

          Logs are filling up with this:

           

          Apr  5 12:32:04 smi101 com.apple.kextd[10]: Can't load /usr/local/McAfee/AntiMalware/Extensions/Virex.kext - no code for running kernel's architecture.

          Apr  5 12:32:04 smi101 com.apple.kextd[10]: Failed to load /usr/local/McAfee/AntiMalware/Extensions/Virex.kext - (libkern/kext) requested architecture/executable not found.

          Apr  5 12:32:04 smi101 com.mcafee.virusscan.ssm.ScanManager[688]: /usr/local/McAfee/AntiMalware/Extensions/Virex.kext failed to load - (libkern/kext) requested architecture/executable not found; check the system/kernel logs for errors or try kextutil(8).

          Apr  5 12:32:04 smi101 kextloadlogger[689]: /usr/local/McAfee/AntiMalware/Extensions/Virex.kext

          Apr  5 12:32:04 smi101 com.apple.launchd[1] (com.mcafee.virusscan.ssm.ScanManager): Throttling respawn: Will start in 10 seconds

          Apr  5 12:32:14 smi101 com.apple.kextd[10]: Can't load /usr/local/McAfee/AntiMalware/Extensions/Virex.kext - no code for running kernel's architecture.

          Apr  5 12:32:14 smi101 com.apple.kextd[10]: Failed to load /usr/local/McAfee/AntiMalware/Extensions/Virex.kext - (libkern/kext) requested architecture/executable not found.

          Apr  5 12:32:14 smi101 com.mcafee.virusscan.ssm.ScanManager[693]: /usr/local/McAfee/AntiMalware/Extensions/Virex.kext failed to load - (libkern/kext) requested architecture/executable not found; check the system/kernel logs for errors or try kextutil(8).

          Apr  5 12:32:14 smi101 kextloadlogger[694]: /usr/local/McAfee/AntiMalware/Extensions/Virex.kext

          Apr  5 12:32:14 smi101 com.apple.launchd[1] (com.mcafee.virusscan.ssm.ScanManager): Throttling respawn: Will start in 10 seconds

           

          Message was edited by: daver on 4/5/11 11:42:12 AM CDT
          • 2. Re: "On-access Scan: Not Working"
            daver

            Apparently McAfee does not work on systems that boot 64bit Kernel and Extentions.

             

            By default, all new Mac's come booting this way by default.  So, in effect, any newly acquired mac will face this issue and will not work.  In order to make it work, you need to alter the mac to boot the 32bit Kernel and extentions.

             

            do that by following these directions:

             

            http://support.apple.com/kb/HT3773

             

            I'm not sure what side-effects this causes.  Hopefully McAfee will fix this issue.

            • 3. Re: "On-access Scan: Not Working"
              Sudeep Garg

              This is happening after the install of HF592722. If this HF is not installed, there is no problem in booting th Mac with 64-bit kext.

              Dont install this HF for now.

              We are working on releasing a HF for this soon.

               

              KB71613 will be updated once the HF is available.

               

              Regards,

              Sudeep

              • 4. Re: "On-access Scan: Not Working"

                KB71613 has the fix attached to it.

                 

                HTH

                • 5. Re: "On-access Scan: Not Working"
                  davidbrucesmith

                  I just downloaded the McAfee version (June 2013 : version 9.2), and I am seeing the same results.  I would be surprised if this issue were not addressed in the downloaded version more than two years later than the last message with the purported fix.  I am also on a Mac Pro running 10.6.8 Snow Leopard and seeing the same risk issue.

                   

                  Please let me know what I need to do in order to resolve this (i.e. how to get KB71613 or how to install it).

                   

                  Thank you

                  • 6. Re: "On-access Scan: Not Working"
                    Sudeep Garg

                    David,

                     

                    There was an issue reported on VSMac 9.2 recently which resembled the same as mentioned 2 yrs back but had a different cause.

                    You can download HF833397 which would likely fix the issue.

                     

                    ~Sudeep