5 Replies Latest reply on Mar 16, 2011 9:30 AM by anickel

    Transparent Bridge Mode mwg7.0

    anickel

      Can someone please explain how routing works with Trans. Bridge mode? We've set up a bridge port, but I'm trying to figure out if two physical ports will be need to route traffic or not. Typically you have a physicall port for incoming traffic, then a second port to go out to the wan....are two ports needed with trans bridge mode in mwg 7?

        • 1. Transparent Bridge Mode mwg7.0

          Hi anickel,

           

          you are absolutely correct. Two physical interfaces would be combined into one bridge.

          One simple example would be an uplink between two switches. today you have one cable going between the two. to put the mwg in transparent bridge mode in, you would unplug that cable and put one end into lets say eth0 on the mwg. then you plug a second cable into wth1 and the other end into the second switch. now, once the bridge is configured, all uplink traffic between the two switches will flow through the mwg.

          Now the scanning part comes in. while the traffic is being bridge through the mwg, it can check for ports on the packets and redirect them to the scanner (so for example port 80 traffic for web requests).

          the brdige option is a pure physical setup and routing has no stake in this. its all about the physical flow of packets.

           

          Hope this helps.

           

          cheers

          sven

          1 of 1 people found this helpful
          • 2. Transparent Bridge Mode mwg7.0
            anickel

            Thanks Schecka....that does help, but it's still a little foggy....  So I have eth0-eth3 and a bridged interface i created called ibr0. I believe eth0 and eth2  are being bridged to ibr0. Eth0 had an ip of 10.2.222.230 but according to McAfee docs IPv4 should be disabled for that interface. eth2 didn't have an ip, but was also bridged into ibr0 and had ipv4 disabled as well. eth3 is NOT bridged and has an IP of 10.2.222.240 and the bridge has an ip of 10.2.222.231. So i need to use eth0 as my connection from my lan, and eth2 as my connection out to the wan since those are the two that are currenlty bridged to ibr0....

             

            and if im understanding correctly, the upstream device will see traffic comming from 10.2.222.231 and that's it...is that correct?

            • 3. Transparent Bridge Mode mwg7.0
              asabban

              Hello,

               

              I think you do not necessarily need the eth3 device, but the ibr0 which contains eth0 and eth2 and the IP address configured on ibr0 should be suitable.

               

              You are right that outgoing requests will be made from this IP address, unless you activate "IP Spoofing". I would go without IP Spoofing first, I have seen this has caused some issues, so I always recommend to check the bridge is working as expected without IP spoofing.

               

              The Product Guide contains a step-by-step guide on page 34, in case you want to have a look for your reference.

               

              Best,

              Andre

              1 of 1 people found this helpful
              • 5. Re: Transparent Bridge Mode mwg7.0
                anickel

                After speaking with support a few times, I believe we finally got it working. However it appears that there's something funky with eth0. I can now ping the ibr0 interface in which i've bridged eth2 and eth3 to. However, as soon as I unplug the ethernet cable from eth0, ibr0 goes down. I'm assuming it has something to do with the fact of eth0 was the original interface i bridged to eth0. Not sure though...anyways, as long as I leave eth0 plugged in, everything works great! McAfee also gave me a document of the working setup they have in the Lab. I tried this exact setup in my lab and it worked perfectly.

                 

                Here's that doc.

                 

                Message was edited by: anickel on 3/16/11 9:30:44 AM CDT