3 Replies Latest reply: May 14, 2011 10:03 PM by forsakenroute RSS

    update/restart problem

      Hi, I recently updated mcafee manually. Everything seemed to work fine. Mcafee asked for a restart, so I did. Now.. If I right click on the mcafee system tray icon and try to open it, it prompts me telling me that updates were installed and to restart to complete it. I do.. and problem is still there. Mcafee keeps asking for a restart, but a restart wont fix it.  I can right click on the tray icon and update again... i can see it download, but never install. any suggestions would be great.


      McAfee AntiVirus Plus - Ver. 10.5.227

        • 1. Re: update/restart problem

          Hi rosselhoff,

          Computers that repeatedly prompt to be restarted after an update might contain an unrequired registry key. Removing this registry key will resolve the issue. Please follow this document to resovle  the issue.





          • 2. update/restart problem

            I ran the .bat like you suggested and got this in the cmd prompt.




            ERROR: Access is denied.

            Please restart the computer

            Press any key to continue . . .


            I restarted. Same problem.


            I have admin rights and ran it as administrator, no luck. Still have mcafee asking for update. It keeps telling me my computer is at risk with its pop-up in the lower right hand corner of the screen. I click "Check status" and it prompts me again for a restart.


            Can I modify the registry manually to remove the bad entry? I looked at what the .bat does and looks I could find  "HKLM\Software\McAfee\Volatile" /f and delete it myself....

            • 3. Re: update/restart problem

              I was expirencing the phenomenon with Mcafee Security Center version 10.5.  I'm running Windows Vista Basic on my LT with two user names.  Usually my primary user name is set to "Standard" in the event that I get an infection (that's the only part of the computer the virus will probably see).  However, in this case it was set to "Administrator" (which is what really boggles my mind).  The point is, both user names should have been able to update, restart and write to the registry.  But apparently, I switched to the original administrator user name, selected the restart option and then rebooted back to the same name.  I logged off and now the system has been up and running the internet for about 45 minutes on the standard user name with out that nagging restart reminder.


              If that changes, you'll be hearing from me.