2 Replies Latest reply on Mar 1, 2011 11:15 AM by MLOPEZ

    Issues when importing settings between different SWR versions.

      Hi all,

       

      Following a suggestion from another post in which I had serious performance issues I have upgraded to latest SWR version.

       

      I have just finished importing backup of the settings with the surprise that now I cannot log in into SWR web application. I followed the steps in the "Help" section and now I cannot either log with my old account or with the newly created first time account, so basically I'm locked out of SWR.

       

      The settings I imported where comming from SWR 5.0.1 (x86) and currently I am using SWR 5.1.1.01 (x64), do you know if there is any documented issue when importing between those two versions?

       

      Can I selectively import settings from one version to another? I would like that all report related settings imported (reports, queries, filters, etc.) but probably not the AD configuration settings.

       

      Regards,

      Mario

        • 1. Issues when importing settings between different SWR versions.
          sroering

          I'm told that 5.1.x has the capibilities to import a 5.0.1.x config, but I've never personally tried it.  The 5.1 software installer does not let you directly upgrade from 5.0.1.x or older because it (5.1.x) requires at least version 5.0.2.x.

           

          That being said, I know the config backup needs to go through several upgrade steps and it's not that uncommon for that process to take a while depending on how big the config file is, and hardware, etc.  There are also some strange timing problems that can occur where scheduled reports try to run while the DB is offline while loading old configurations.  Those can keep you locked out of the GUI.

           

          I really need to see the server.log to know for sure what is happening, but you could try stopping the MWR service (check the task manager to verify that java.exe owned by the SYSTEM account isn't running), then start the service again.  If you're still not able to login, it could be a sign that the backup.xml couldn't be loaded. The necessary information would be in the server.log from when you did the upgrade.

          1 of 1 people found this helpful
          • 2. Issues when importing settings between different SWR versions.

            It seems the first time I tried to import it crashed and settings where not completely imported. Or at least I assume this was what happened. I deleted DB, reinstalled applciation from scratch and re imported settings.

             

            Now the application works :-)

             

            Thanks for your support.

             

            Regards,

            Mario