4 Replies Latest reply on May 19, 2015 2:59 PM by Jon Scholten

    Web Gateway 7 Interface Teaming

      Hi everybody..

      I was wondering if the interface teaming is officially supported by McAfee on the WebGateways appliances.

      Basically I managed to get a virtual machine up and running Web Gateway 7.0.2.2.. quite simple and common.. then I loaded the kernel's bonding module, I configured the bond0 virtual interfance and ensalved the two phisicals interfaces eth0 eth1.

      Restarted the Webgateway core and this is the result.

      WebGateway.png

       

      Apprently the Web Gateway software is working fine unsing the Virtual IP and the interface round robing as well

       

      WebGateway2.png

       

      I did this test because I've been asked for it by a customer, I replyed that probably wouldn't be supported by McAfee and the conversation ended there.

      But I wanted to give it a try..

      However, is an interesting feature to get on a production appliance.. possibly officially supported.

       

      Eventually I'll try to use the load balanced interface to run a Virtual ip on a ProxyHA ... but probably this is pure testing maniacs stuff..

       

      WebGateway3.png

       

      Message was edited by: Valeinrete on 18/02/11 04:30:36 CST
        • 1. Web Gateway 7 Interface Teaming
          asabban

          Hello,

           

          basically I do not see any issues with using a bonding interface on MWG7. It is used in version 6.x but (still) missing in 7.x - I assue it will be there in the near future.

           

          Please understand that we have not tested the bonding interfaces on 7.x yet, especially together with the various proxy deployment modes. However if you find it working for your customer  I do not see any issues in doing so, but in case thre are issues and you file a ticket with Support we may find out that this is not yet working completely, and will have to turn it off. Also please keep in mind that updating or reimaging may damage your manual configuration, since this is nothing that is tested.

           

          However you will not lose the general support for this box, from a supports perspective we will of course assist you with any questions.

           

          Please let me know if statement is suitable for you. If you need further details, please let me know.

           

          Best,

          Andre

          1 of 1 people found this helpful
          • 2. Re: Web Gateway 7 Interface Teaming

            Thank you Asabban,

             

            From my lab & testing point of view, this is a great way to improove scalability, loadbalancing and performances and it does work very well ( the bounding kernel module on linux seems to be their natural born enviroment ), however from the customer point of view they MUST have official support from the vendor, in order to not overload or slowdown the core business, or sometimes just to have somebody to blame.. furthermore I'd say because they pay for the support as well!

             

            Anyway, this is a very interesting configuration!

             

            Thanks for your support and the offered effort...

             

            Message was edited by: Valeinrete on 27/02/11 15:27:37 CST
            • 3. Re: Web Gateway 7 Interface Teaming
              mcafee-com-user

              Hello,

               

              any news about this topic?

               

              We are currently running MWG 6.9 in Proxy HA mode, the network interfaces are configured using bonding to have maximum reliability.

               

              Coz we know support for MWG 6.9 ends 12/2013 we are now looking how to configure MWG 7.2.x.

               

              In the manual is no hint how to configure bonding. Is this feature already implemented?

               

              Thanks in advance.

               

              =====================================================

               

              Update: We tested with manual configured bonding, this works as long as the MWG system is restarted. After that the configuration is overwritten. How can this be solved?

               

              Now we disabled bonding again but in the GUI the interfaces are still shown, how can these unavailable interfaces be deleted?

               

              Thanks in advance for any help.

               

              on 26.09.12 16:02:27 MESZ
              • 4. Re: Web Gateway 7 Interface Teaming
                Jon Scholten

                Hi Everyone,

                 

                To anyone is using an unsupported Bonding configuration, before you upgrade to 7.5.2 (ETA end of May), read the information below!


                The upcoming Web Gateway 7.5.2 software release will introduce Network Interface Bonding as a supported feature.  Prior to this release, network interface bonding was not an officially supported configuration.  Upon upgrading to this and subsequent Web Gateway software versions, any prior network interface bonding configurations will cease functioning.  To avoid any negative impact to your Web Gateway environment, it is recommended that any prior network interface bonding configurations are removed prior to an upgrade to Web Gateway v7.5.2 or later.  After the upgrade is completed, please see the Network Interface Bonding section of the Web Gateway 7.5.2 product guide for configuration instructions.

                 

                Best Regards,

                Jon