8 Replies Latest reply on Mar 22, 2011 3:30 PM by tarliebear

    mfeagent.msi error

    dhanu

      while installing framepackage gives mfeagent.msi missing error.try to install from different size of mfeagent.msi but still not able to install framepackage. Any solution on this?

        • 1. mfeagent.msi error
          Hayton

          Moved from Home & Home Office Help section to Business section for attention.

          • 2. mfeagent.msi error
            JoeBidgood

            Please open a case with Support for this - there is a tool available that may help. Please see KB 70753 for more details.

             

            Thanks -

             

            Joe

            • 3. mfeagent.msi error

              Open up the registry and navigate to HKLM => software => classes => Installer => Products => and find the folder that references the "McAfee Agent" and delete that whole folder. Then re-install the agent as normal. What this is doing is telling Windows Installer that the McAfee Agent is no longer installed, and it will install normally now and overwrite all McAfee Agent files.

               

              I figured this out long before there was a KB article on it.

              • 4. mfeagent.msi error
                JoeBidgood

                This will work for a subset of these cases, but not for all of them, unfortunately

                By all means try it - but if the install still fails, the cleanup tool I mentioned earlier should solve things.

                 

                HTH -

                 

                Joe

                • 5. mfeagent.msi error
                  dhanu

                  Thanks for the solution,my problem is solved by removing the key in HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\McAfee Agent Key

                  • 6. mfeagent.msi error
                    risingflight

                    You will need to use regedit to find a key that you willeither need to change or delete.
                    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\ADE3EF6381C0ED8439B49D68 F2287A8A]

                     

                    The key ADE3EF6381C0ED8439B49D68F2287A8A might not be the same as in yourenvironment, but if you look down through the Products you will see a key withthe MFEAgent.msi in it. You will either need to change the path it's pointingto or go ahead and delete the key.

                     

                    To resolve all the issues, I deleted this key, killed all the McAfee processesand services then deleted all McAfee folders.

                     

                    Open windows explorer and delete the followingdirectories:

                    C:\Documents and Settings\All Users\ApplicationData\McAfee

                    C:\Documents and Settings\All Users\ApplicationData\Network Associates

                    C:\Program Files\Mcafee

                    C:\Program Files\Network Associates

                    C:\Windows\Temp\*any McAfee folders you see,and VSE850.exe if it’s there



                    Go to Start, Run, type regedit to open theregistry editor

                    Browse down to the following paths and deletethe following keys:

                    (Click on the folder then right click andchoose delete)

                    HKEY_LOCAL_MACHINE\SOFTWARE\McAfee

                    HKEY_LOCAL_MACHINE\SOFTWARE\Network Associates



                    Next, go toHKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root - change the

                    permissions on root to have full control.Delete any keys you see that start with

                    LEGACY_MC*

                    LEGACY_MFE*

                    LEGACY_NAI*

                    Change the permissions on Root back to non fullcontrol

                    Repeat this process for ControlSet002, 003,CurrentControlSet

                     

                    You should then be able to reinstall the agent and Virusscan successfully.

                    • 7. mfeagent.msi error
                      risingflight

                      hello i faced this issue earlier and i tried many things but failed , finally i found this article in mcafee knowledge base but i dont remember the

                      kb number, this will work 100 percent , i faced 4 to 5 pcs in my network with this error  i followed this procedure.

                      • 8. Re: mfeagent.msi error

                        orrrrrrrrr go to the Documents and Settings\All Users\Application Data\McAfee\Common Framework

                         

                        Highlight the file, MFEagent.msi and right click to menu and select "repair"

                         

                        untitled.bmp