4 Replies Latest reply on Feb 3, 2011 9:46 AM by JoeBidgood

    Agent GUID wont regenerate

      We are running ePO 4.5 and have deployed the McAfee agent to our images.  I was pretty sure the agent GUID was deleted prior to  SysPrep but I am finding almost half (900) of our machines have issues with checking into the ePO console.  I did some manual checking on 8 or so and found a duplicate GUID issue.  Now I know the fix for this is to delete the GUID and restart the service, but because VSE prevents the service from being stopped, I had to resort to rebooting the machines instead.  well all was said and done the night before and I came in to check hoping to see a huge gain in machines checking in.  to my surprise we only netted about ten more machines.

       

      So I did some more manual checking and found that the GUID was gone, but restarting the McAfee Framework Service (or the machine) wasn't generating a new GUID.  and now I'm at a loss.  my only other option would be to reinstall the agent across the board on these machines, but I have other modules installed (like HIPS, VSE, ABM, etc).

       

      Would this be the only way to fix this?  and would it mess up the other modules I have installed?  did I go about correcting my first problem (deleting the GUID across the board) the wrong way and may have caused my second problem (GUID not regenerating)?

       

      Thanks, J

        • 1. Re: Agent GUID wont regenerate

          Pushing out the Agent again to these machines will not break any of the products you have mentioned.

           

          As long as you have removed the Regkey AgentGUID under "HKEY_LOCAL_MACHINE\SOFTWARE\Network Associates\ePolicy Orchestrator\Agent" rather than modifying it to empty, then a reboot and restart of the service will fix the problem, so maybe you have another issue.

           

          Have you re-deployed the agent to a problem machine and this has worked?

           

          Regards,

           

          Ian

          • 2. Re: Agent GUID wont regenerate
            JoeBidgood

            Exactly how did you remove the guid on client machines? You have to remove the entire AgentGUID value from the registry, not just the value's data...

             

            HTH -

             

            Joe

            • 3. Re: Agent GUID wont regenerate

              The GUID was removed via reg delete CMD.  ex.

              reg delete "\\COMPUTERNAME\HKEY_LOCAL_MACHINE\SOFTWARE\Network Associates\ePolicy Orchestrator\Agent" /f

               

              Key was verified as deleted after logging onto the machine.  the wierd thing is, on the couple that i tested (one at a time).  everything worked out fine.  rebooted and the guid was regenerated.  i ran a batch file with the above cmd for 900 or so machines.  verified the guid was gone, then ran a batch file to reboot all those machines that night.  next day i did the check and you know the rest.

              • 4. Re: Agent GUID wont regenerate
                JoeBidgood

                Okay, that's a bit weird. Can we confirm that command? The one you posted will remove the entire HKEY_LOCAL_MACHINE\SOFTWARE\Network Associates\ePolicy Orchestrator\Agent key, not the agentguid value. If that's the case then the agentis pretty much dead as all its keys are gone

                 

                HTH -

                 

                Joe