1 2 Previous Next 10 Replies Latest reply on Jan 26, 2011 6:09 AM by Attila Polinger

    Change IP of a managed system via ePO

      Hi!

       

      I've a problem with a managed (and totally working) system that changed IP (we use prefixed address for our computers).

      In my ePO group, that system, has still the old IP and so ePO is not able to reach it.

       

      Is there a way to change the IP of a managed system without removing and adding it again?

       

      Thanks a lot for your help

       

      Michele Mura

      Italy

        • 1. Re: Change IP of a managed system via ePO
          Attila Polinger

          Hello,

           

          does not the managed system do ASCI so its IP address gets changed in ePO inventory?

          Is the managed system able to do ASCI at all (after IP adress change?)

           

          I do not think ePO is able to remotely make a client change its IP address this should not be an aim...

           

          Are you able to resolve the system's name from the ePO server (resulting in the new IP?) If so, you could invoke the remote system's agent log to see what's wrong with the connection.

           

          Attila

          1 of 1 people found this helpful
          • 2. Re: Change IP of a managed system via ePO

            Hi Attila!

             

            Thanks for your reply. Maybe my request was not so clear. I do not want to change the system IP address from ePO.

            That system has a different IP from the previous one so ePO "knows" that system with its old address.

             

            What I've to do to change the IP address ePO uses to interact with that manged system?

            Is there a way to change the system data (beyond the Set Description command from Action menu or the Tag functionality)

             

            I think I can remove that system from my group and then add it again with its new IP... but is there a more elegant way to accomplish this?

             

            Thanks a lot for your support

            mm

            • 3. Re: Change IP of a managed system via ePO

              Well..

               

              If I ping that system (using the box that appears in the right-upper corner of the standard dashboard - Quick System Search) through its hostname, ePO is able to reach it and a new window appears with one entry (that computer).

               

              But, if I try to ping that system using the command Ping in the Action menu, I get this message (in the right-bottom corner): "The device is unreachable"

               

              I don't want to change the IP of that system via ePO, I only want to "update" ePO and insert the new IP.

               

              Thanks again

              mm

              • 4. Re: Change IP of a managed system via ePO
                jstanley

                You could change the IP address associated with a specific system name via a SQL query; however, I think I have a better solution.

                 

                The ping button in ePO does in fact use the last recorded IP address for the client rather than doing a DNS lookup on the name. For example the ping from the ePO console will fail 100% of the time to unmanaged machines. While that is unfortunate the agent wakeup call does NOT simply use the IP address rather it WILL do a DNS lookup on the nodename (whatever name is recorded for that machine in the ePO system tree) so as long as that is resolving the correct IP then the wakeup call should be successful. Once the agent communicates back it should update its IP with whatever the current IP address is and the ping will then work.

                • 5. Re: Change IP of a managed system via ePO
                  Attila Polinger

                  What I just do not see here is why the agent would reply to a wakeup call when it - apparently - did not do ASCI. If it had, ePO would have updated the IP in its node record. So why is a wakeup call a cure here?

                   

                  Thank you.

                  • 6. Re: Change IP of a managed system via ePO

                    Hi!

                     

                    Thank you for your replies. I tried a Wakeup call to that system. The command was issued correctly and in server task log the entry is "completed" but the IP was not updated. I tried again the Ping command but the system is still unreachable.

                     

                    I've opened the database via SQL Server Manager but the database has more then 200 tables. The SQL UPDATE is fine for me, but which is the right one?

                     

                    Thank you again for the support.

                     

                    mm

                    • 7. Re: Change IP of a managed system via ePO
                      Attila Polinger

                      Michele,

                       

                      I would still advise that you start troubleshooting on the client side. First please check if the client seems able to contact the ePO server, if it is not, then it shows in the agent log. Do not fiddle with the database directly, it does not resolve issues that are present on client side.

                       

                      Attila

                      • 8. Re: Change IP of a managed system via ePO
                        jstanley

                        If the wakeup call is successful but the machine does not update its properties then we have an agent-to-server communication issue. Manually updating the IP address associated with the client via a SQL script will not resolve this problem. You need to review the agent log on the client to determine why the ASCI is failing. Without reviewing the log the only solution I could suggest would be to reinstall the agent.

                         

                        You could also be looking at a duplicate entry. Perhaps the machine is successfully communicating but not to the node you are looking at in ePO. You can run the duplicate machine query to spot duplicates.

                         

                         

                        Message was edited by: Jeremy Stanley on 1/25/11 9:16:50 AM CST
                        • 9. Re: Change IP of a managed system via ePO

                          Hi everybody!

                           

                          Today I had a little time to check the situation and get more info.

                           

                          In the tray notification area of that system, there's not the "M" red icon but the white shield with the red "V".

                          When I click on it, I don't get the standard pop menu with "Monitoraggio stato agente McAfee" (italian version) but other options.

                           

                          Where may I find the log? And how to re-install the Agent? Do I have to create a new "Product Deployment" task? But my ePO "knows" that system with its old IP...

                           

                          Argh!!

                           

                          Thanks for your big help

                          Michele

                          1 2 Previous Next