7 Replies Latest reply on Apr 19, 2011 11:31 AM by kalua

    Script error when trying to reinstall Mcafee

      Hi there,

       

      We have McAfee Saas Endpoint Protection 5.2 installed on two computers running W7. On one of them McAfee did not automatically update. I tried to do the "Update Now" on the icon on task bar but i got a script error. Also, i got 2 security messages on the "action center" saying that McAfee Total Protection for samll businees must be updated manually which i've already tried and failed.

       

      The script error is:

      An error has ocurred in the script of this page

      Line: 786

      Char: 35

      Error:  Object Expected

      Code: 0

      URL: http://vs.mcafeeasap.com/MC/VS52/InstallCore.aspx.......

       

      Do you want to keep running the script on this page? Y/N

       

      We decided to uninstall McAfee and reinstall it. I installed it by downloading an unsinstaller (mvsuninst.exe) but i could not reinstall it cause no matter what method i used (vssetup.exe. URL, etc), the installing process always gets interrupted by the script error window.

       

      I would really appreciate any help on this regard since it's pretty frustrating.

       

      Thank you!

       

      Atmos

        • 1. Re: Script error when trying to reinstall Mcafee
          Pritish

          Hi,

           

          I have read your post.

           

          Please check the Internet explrer settings

          Re-register the Internet explorer script files.

           

          Then please proceed with the below steps.

           

          Click "START" and then "RUN"
          Type "CMD" and hit enter.
          Type the following commands one by one and press enter to register the script dll files.

           

          Regsvr32 jscript.dll
          Regsvr32 vbscript.dll
          Regsvr32 scrrun.dll

           

          Then after the above steps please run a Windows update from the Internet explorer-->Tools-->Windows Update. If you see any critical updates please update the computer.

           

          Regards

          Pritish P.

          • 2. Re: Script error when trying to reinstall Mcafee

            Thank you for your help but i tried that before and it did not work. Then, i found a post where they suggest to "right click" on CMD to run as administrator. It worked for registering the dll files. I restarted the computer and tried to re-install mcafee SaaS Endpoint Protection from my account by clicking on the reinstall protection button.  I still get the same scrip error. Pretty anoying! thanks anyway!

            • 3. Re: Script error when trying to reinstall Mcafee

              I'm seeing the exact same behaviour on one of my machines running Vista Business. I also uninstalled and am now unable to reinstall. Registering those DLLs also did not help me. Anyone else with suggestions?

              • 4. Re: Script error when trying to reinstall Mcafee

                Hey Brett,

                 

                I contacted the McAfee Support Center by email and they sent me this (see below). I haven't tried it yet but i thought to pass it on to you since you have the same issue i do.

                Hope it works!

                 

                Note: If you are not confident in performing the below steps with the registry please call our technical support to fix this issue.

                 

                McAfee Gold Technical support : 1-800-937-2237

                 

                To delete the registry,

                 

                1.Start--> Run --> Type regedit ( Hit enter) 2.click on file --> select export --> save the registry backup file.

                3.Then you will see HKEY-LOCALMACHINE ->software->delete McAfee 4. Then you will see HKEY-CURRENT USER ->software->delete McAfee 5. Press F3 key and a search box will appear.

                6. Type McAfee and search in registries and delete the value.

                7.press F3 once again to search for the next McAfee value in the registry and delete it. Do the same untill the last registry is deleted.

                 

                If you are unable to delete any registry key please follow given steps.

                 

                press Ctrl + Shift + Esc. Go to Processes tab and check the User Name column.

                You should see SYSTEM, LOCAL SERVICE, NETWORK SERVICE and your user name.

                End the McAfee Process

                Run Registry Editor by typing regedit at Run.

                Right click on the key that you want to take full control of and select Permissions Click the Advanced button Go on the Owner tab. Select the user name that the current system is logged on, check “Replace owner on subcontainers and objects” and click OK.

                Now you should be back at the Permissions window again. Select the group that the currently logged on user belong to and check Full Control for Allow. Click OK.

                After doing all the above mentioned steps . Delete the Mcafee Registry value . Restart is required and proceed with normal installation

                 

                Steps for Uninstallation :

                 

                1. Log on to the security center from www.mcafeeasap.com 2. Click on the tab utilities-> select the sub tab Migration & Optimization.

                3. Under the Cleanup Utility --> select the download option.

                4. Download and save it to the desktop and run this exe to uninstall.

                 

                Now please restart your computer and try the installation.

                • 5. Re: Script error when trying to reinstall Mcafee

                  Hey Atmos,

                   

                  Thanks for passing those on. I followed through those instructions and I'm still seeing the same behaviour unfortunately.

                   

                  I've started a case with Mcafee as well, if they provide me with anything useful I'll be sure to post!

                  • 6. Re: Script error when trying to reinstall Mcafee
                    Pritish

                    Hi,

                     

                    I have read your post.

                     

                    Please be informed that McAfee has released the new upgraded v5.2.1 of the McAfee SaaS endpoint protection.

                     

                    This version completely resolves the issues like High CPU usage and Upddlg.exe and sceipt errors that were occuring due to the McAfee Virus Scan software.

                     

                    This new version is being rolled out region wise. If you want the upgrade immediately then please uninstall and reinstall the software.

                     

                     

                     

                    Regards

                    Pritish P.

                    • 7. Re: Script error when trying to reinstall Mcafee

                      Hello, Atmos.

                       

                      I was experiencing the same issues installing McAfee SaaS on a client where I had uninstalled it due to the scripting error you describe.  I tried the solutions proposed in these and other forums to no avail.  Finally I decided to strike out on my own.  I am running Windows XP Service Pack 3 and Internet Explorer 8.

                       

                      The update or installation is being driven by Internet Explorer.  I opened Internet Options and navigated to the Advanced tab.  From that tab I chose the Reset button under Reset Internet Explorer Settings.  From the Reset Internet Explorer Settings window I chose Reset.  I was prompted to restart Internet Explorer.

                       

                      I restarted Internet Explorer and then logged in to http://mcafeeasap.com and successfully installed the software.  I had previously failed to install it at least 4 times.  It was great to actually get it working.  Of course the user lost all the settings that they had configured.  Not a big deal for me.

                       

                      Hope this helps.

                       

                      Best regards,

                       

                      Mike