3 Replies Latest reply on Feb 10, 2011 10:01 AM by thechad

    MVM 7.0 SDK API

      Hello all,

       

      Just wondering if anybody else has experience with the SDK? I'm trying to deploy the C++ and Java SOAP clients, and have run into some roadblocks.

       

      Chad

        • 1. Re: MVM 7.0 SDK API

          More specifically:

           

          I went throught the Java build guide, and when trying to run the CreateScan example, I get the following error:

           

          ---------------------------------------

          User login failed!
          AxisFault
          faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
          faultSubcode:
          faultString: java.lang.RuntimeException: java.io.IOException: failed to decrypt safe contents entry: javax.crypto.BadPaddingException: Given final block not properly padded
          faultActor:
          faultNode:
          faultDetail:
                  {http://xml.apache.org/axis/}stackTrace:java.lang.RuntimeException: java.io.IOException: failed to decrypt safe contents entry: javax.crypto.BadPaddingE
          xception: Given final block not properly padded at com.mcafee.mvm.openapi.ssl.FSSecureSocketContextFactory.newSSLContext
          (FSSecureSocketContextFactory.java:112) at com.mcafee.mvm.openapi.ssl.FSSecureSocketFactory.create(FSSecureSocketFactory.j ava:51)

          ----------------------------

           

          I was thinking it was because we upgraded from 6.8 to 7.0, and the password was hashed as MD5 instead of SHA512, but changing the hash call didn't seem to fix anything.

           

          I also went through the C++ build, and when executing the client, gSOAP throws an exception that the certificate cannot be read. I tried using the Certificate Manager to generate a new cert for the calling client, however reverse DNS and NETBIOS doesn't work. Trying to generate the cert with only the IP doesn't work, so I'm kind of stuck here...

           

          Any advise would be greatly appreciated. I am hoping to run the SOAP client in a non-Windows environment (FreeBSD) without relying on COM, so it would be prefereable to solve the Java padding issue.

           

          Any advise would be greatly appreciated. Thanks!

           

          Chad

          • 2. Re: MVM 7.0 SDK API

            Chad,

             

               I see that you tried to re-generate the certificate for the calling system.  My question is did you get the new certificate manager installer for version 7.0?  I have not seen any issue with generating a new certificate, no matter what you use.  We do not actually tie the generation to any particular system attribute any longer it is simply for descriptive purposes.  You do not need to actually resolve the name.  Just put something descriptive (IP, NetBios, FQDN) in the system name field and click generate.  If this does not solve your issue please open a case and have it escalated to Tier III.

             

            Dave Cundiff

            • 3. Re: MVM 7.0 SDK API

              Hi Dave,

               

              Yes, I used the cert manager for v7. The error kept indicating that it could not resolve the hostname, and would not work if the field was empty either. I will pursue this with your support staff. Thanks,

               

              Chad