2 Replies Latest reply on Nov 9, 2012 8:15 AM by cezmi.cal

    Disable X-Forwarded-For Header

      I'm trying to disable this header and can't figure it out.  I'm running 7.0.1.5.0.  Please help, thanks.

        • 1. Re: Disable X-Forwarded-For Header
          Remove Via: and X-Forwarded-For:
          Enabled
          Applies to Requests: True / Responses: False / Embedded Objects: False
          Always
          EnabledRuleActionEventsComments
          EnabledRemove Via:
          Always
          ContinueHeader.RemoveAll("Via")
          EnabledRemove X-Forwarded-For:
          Always
          ContinueHeader.RemoveAll("X-Forwarded-For")
          • 2. Re: Disable X-Forwarded-For Header
            cezmi.cal

            Hi,

             

            I applied this rule; however, the problem still exists. The rule is top of all other rules. MWG version is 7.2.0.3.

             

            Is there any other solution suggestion?

             

            Message was edited by: cezmi.cal on 11/9/12 7:15:46 AM CST

             

            I have solved the problem by using the latest "Remove Proxy Header" rule, downloaded from online rule set library. It is for McAfee Web Gateway Version>=  7.2.0.0

             

            Message was edited by: cezmi.cal on 11/9/12 8:15:24 AM CST