7 Replies Latest reply on Dec 10, 2010 10:59 AM by Tristan

    Can't execute Client Tasks from ePO

      My ePO 4.5 has a Client Task "Remove Old Version of Site Advisor 1.7" which will run Once.

       

      I have 6 Windows 7 clients and 1 Windows XP client, all of which I need this Task deployed.

       

      I used the command Wake Up Agents and set the configuration to "Force Complete policy and task update" but after several attempts, the software is still in the client machines.

       

      Anyone can help ?

       

      I understand Windows 7 may have some communication issues with ePO, but based on KB67347, the issue is resolved with McAfee Agent 4.5 Patch1, which I've installed in my ePO.

       

      Also, ICMP echo request ping can't seem to reach any of the Windows 7 clients. Any idea why? Is this part of the reason why my clients can't execute my Tasks?

        • 1. Re: Can't execute Client Tasks from ePO

          In addition, I also faced another issue....

           

          I am trying to add more Windows XP based clients to my ePO System Tree. It was able to find the system and I have since added this single machine into my tree.

           

          However, this system is in Unmanaged state. I choose to Deploy Agents to this system, but the task failed.

           

          Error was "Failed to authenticate with remote system, system error: The network path was not found."

           

          At this new client system, it is running Windows XP with SP 3 and with Firewall turned on.

           

          After turning off the Firewall, I was able to deploy the agent to this system..

           

          Does this mean for every new system in my network, I need to DISABLE the FIREWALL in order to DEPLOY AGENTS? Is there any workaround for this?

          • 2. Re: Can't execute Client Tasks from ePO
            JoeBidgood

            weak_pig wrote:

             

            My ePO 4.5 has a Client Task "Remove Old Version of Site Advisor 1.7" which will run Once.

             

            I have 6 Windows 7 clients and 1 Windows XP client, all of which I need this Task deployed.

             

            I used the command Wake Up Agents and set the configuration to "Force Complete policy and task update" but after several attempts, the software is still in the client machines.

             

            Anyone can help ?

             

            The first thing is to check on the client machine whether or not the task has been received. If you look in the Task folder, you will see a number of .ini files: if you open them in a text editor, you'll be able to see the name of the task. Does the task exist on the client machine? If it does, check the agent log and see if it was correctly executed - are there any errors?

            Also, please be aware that a Run Once task does exactly that - it onyl runs once, regardless of whether it succeeds or fails. So, for example, if the task was received by the client, ran, but failed to complete successfully for any reason, it will not run again.

             

            Does this mean for every new system in my network, I need to DISABLE the FIREWALL in order to DEPLOY AGENTS? Is there any workaround for this?

             

            You don't need to disable the firewall, but you do need to allow access through it. Please see KB 56317 for more details - but at a guess, I would imagine that you either don't have File&Print sharing set as an exception, or the admin$ share is not accessible: those are the most common reasons.

             

            HTH -

             

            Joe

             

             

            Message was edited by: Joe Bidgood on 16/11/10 09:33:45 GMT
            1 of 1 people found this helpful
            • 3. Re: Can't execute Client Tasks from ePO

              It seems I still have trouble getting ePO to Wake up one of my agent. This user is on Windows 7, already have McAfee Agent installed and is listed as a Managed System in ePO. However, modifying tasks or sending new task to this agent is a headache.

               

              This is the log below.

               

              12/9/10 3:14:13 PM  Starting agent wakeup for JOANNE-CAI 

              12/9/10 3:14:13 PM  Waking up agent joanne-cai.sttelemedia.com using DNS name 

              12/9/10 3:14:13 PM  Unknown error contacting agent 

              12/9/10 3:14:13 PM  Waking up agent JOANNE-CAI using NetBIOS 

              12/9/10 3:14:13 PM  Unknown error contacting agent 

              12/9/10 3:14:13 PM  Waking up agent at IP address 10.90.15.65 

              12/9/10 3:14:13 PM  Unknown error contacting agent 

              12/9/10 3:14:13 PM  Wakeup agent failed 

              12/9/10 3:16:53 PM  Waking up agent joanne-cai.sttelemedia.com using DNS name 

              12/9/10 3:16:53 PM  Unknown error contacting agent 

              12/9/10 3:16:53 PM  Waking up agent JOANNE-CAI using NetBIOS 

              12/9/10 3:16:53 PM  Unknown error contacting agent 

              12/9/10 3:16:53 PM  Waking up agent at IP address 10.90.15.65 

              12/9/10 3:16:53 PM  Unknown error contacting agent 

              12/9/10 3:16:53 PM  Wakeup agent failed 

              12/9/10 3:18:09 PM  Expired

              It seems that the ePO is not able to contact this agent at all.
              In the Entire Network of Microsoft Windows Network, I was not able to locate her system in it.
              However, I could connect to her system or C Drive simply by entering the following :
              \\joanne-cai.sttelemedia.com\c$, or
              \\joanne-cai\c$
              What does this mean?  Please help..
              Thanks.

              • 4. Re: Can't execute Client Tasks from ePO

                Hi some updates.

                 

                I just check my client's agent event log.

                 

                I noticed that the agent actually managed to receive the events from my ePO server, even though the ePO claims that this agent is unreachable. Any idea why there is a contradiction in the tasks reported?

                 

                The task I am sending to this agent is to REMOVE VirusScan Enterprise with Patch 2 and INSTALL VirusScan Enterprise with Patch 3.

                 

                Pls see the attached jpeg for the image of the client task events

                • 5. Re: Can't execute Client Tasks from ePO
                  JoeBidgood

                  This looks like the agent is able to communicate with the server, but the server is unable to send wakeup calls to the agent. Check that you have the "enable agent wakeup call support" option enabled in the policy, and that nothing is blocking the wakeup call port (8081 by default) between the server and the client machine. Check the local firewall settings.

                   

                  HTH -

                   

                  Joe

                  • 6. Re: Can't execute Client Tasks from ePO

                    Hi, some updates. This is the server log. I find this error on it.

                     

                     

                     

                     

                    20101209164500 I #4040 mod_epo Signing agent response package with key gy/qDnGYCH06JHnTjdBUa80RwWQ=

                    20101209164556 I #4932 NAIMSRV Wake up agent on DNS name joanne-cai.sttelemedia.com...

                    20101209164617 E #4932 NAIMSRV Failed to connect to joanne-cai.sttelemedia.com:8081, network error was 10060

                    20101209164638 E #4932 NAIMSRV Failed to connect to joanne-cai.sttelemedia.com:8081, network error was 10060

                    20101209164638 I #4932 NAIMSRV Wake up agent on NetBIOS name JOANNE-CAI...

                    20101209164659 E #4932 NAIMSRV Failed to connect to JOANNE-CAI:8081, network error was 10060

                    20101209164720 E #4932 NAIMSRV Failed to connect to JOANNE-CAI:8081, network error was 10060

                    20101209164720 I #4932 NAIMSRV Wake up agent on IP Addr 10.90.15.65...

                    20101209164741 E #4932 NAIMSRV Failed to connect to 10.90.15.65:8081, network error was 10060

                    20101209164802 E #4932 NAIMSRV Failed to connect to 10.90.15.65:8081, network error was 10060

                    20101209164802 E #4932 NAIMSRV Server failed to wake up joanne-cai.sttelemedia.com, detailed error = -999

                    20101209164802 I #4932 MCUPLOAD Successfully disabled CA trust options.

                    20101209164836 I #0988 NAIMSRV Wake up agent on DNS name joanne-cai.sttelemedia.com...

                    20101209164857 E #0988 NAIMSRV Failed to connect to joanne-cai.sttelemedia.com:8081, network error was 10060

                    20101209164918 E #0988 NAIMSRV Failed to connect to joanne-cai.sttelemedia.com:8081, network error was 10060

                    20101209164918 I #0988 NAIMSRV Wake up agent on NetBIOS name JOANNE-CAI...

                    20101209164939 E #0988 NAIMSRV Failed to connect to JOANNE-CAI:8081, network error was 10060

                    20101209165000 E #0988 NAIMSRV Failed to connect to JOANNE-CAI:8081, network error was 10060

                    20101209165000 I #0988 NAIMSRV Wake up agent on IP Addr 10.90.15.65...

                    20101209165021 E #0988 NAIMSRV Failed to connect to 10.90.15.65:8081, network error was 10060

                    20101209165042 E #0988 NAIMSRV Failed to connect to 10.90.15.65:8081, network error was 10060

                    20101209165042 E #0988 NAIMSRV Server failed to wake up joanne-cai.sttelemedia.com, detailed error = -999

                    20101209165042 I #0988 MCUPLOAD Successfully disabled CA trust options.

                     

                     

                     

                     

                    Any idea what is error 10060? I tried to google it and found that it could be a windows socket error....
                    I also did a ping test on this user, it seems that the the destination is unreachable.
                    Pinging joanne-cai.sttelemedia.com [10.90.15.65] with 32 bytes of data:
                    Reply from 10.90.15.152: Destination host unreachable.
                    Reply from 10.90.15.152: Destination host unreachable.
                    Reply from 10.90.15.152: Destination host unreachable.
                    Reply from 10.90.15.152: Destination host unreachable.

                     

                     

                    Message was edited by: weak_pig on 12/10/10 8:58:33 AM MYT
                    • 7. Re: Can't execute Client Tasks from ePO
                      Tristan

                      Are the Epo server and clients all on the same LAN subnet?

                       

                      This might be either a Firewall issue or IP routing issue as the server can't see the client

                      1 of 1 people found this helpful