2 Replies Latest reply on Jan 18, 2011 5:31 AM by jmcleish

    USB client 1.3 not recognising\initialising McAfee EUSB

    jmcleish

      I'm currently testing before our deployment of around 40 EEPC 6.0.1 and McAfee EUSB Standard v2.  (Using ePO 4.5.973 and 8.7p3 +ASM +MA 4.5.0.1499)

       


      Question 1:

       

      I've come across something very odd:.

       

      Both machines running WXPSP3

       


      Machine 1: Encrypted first then deployed USB 1.3 client and USB admin. Dell Latitude e5400

       

      Insert the EUSB, it mounts normally into windows, but no initialisation or personalisation occurs.

       

      In USB Admin it says device removed and doesn't change.

       


      Machine 2: Deployed USB 1.3 client and USB admin.

       

      Insert same USB - it initialised and acts as expected. When other EUSB is inserted- acts as expected- initialises and personalises etc.

       

      USB Admin device shows locked and the SN shows.

       

      Encrypted machine and still the USB client works as expected.Device is recognised when inserted.

       


      on Machine 1 I have reinstalled the agent, uninstalled and reinstalled the USB client and Admin, but still it doesn't work. The agent appears to enforce the policies correctly- DPEUCLNT1000, DPEUADMU1000, EEADMIN_1000 and the agents enforcement. No EUSB that I've tried do anything on this first machine, but work fine on the other.

       


      Does anyone have any ideas whats going on on machine 1 or how to fix it please?

       


      Question 2:

       

      On these machines I was wanting to allow only these devices. I've discovered that you can initialise the EUSBs but not personalise them, so ePO recognises them as managed native devices. Then i was going to enforce the foreign devices policy to disallow any other USB pen from working. Will this work?

       


      I have 3 options in Foreign Device Behaviour

       


      Allow Managed Foreign Devices

       

      Allow Other (Unmanaged) Foreign Devices

       

      Restrict device use to managed systems

       


      If uncheck the first two options, will this only allow these managed devices and not any other USB pens?? - and will I still be able to initialise them if these policies are set (Hence why i was thinking of pre-initialising them before giving them to the users)

       

      Question 3: Is there an ETA for v1.4?

       


      Thanks for any help.

      Jane

      (New to all this encryption stuff)

       

       

      Message was edited by: jmcleish on 10/11/10 14:50:20 CST
        • 1. Re: USB client 1.3 not recognising\initialising McAfee EUSB
          jmcleish

          OK... I'm testing the USB 1.3 client on a W7 x64 laptop and the install task says its not supported on W7.

           

          I know that devices can't be initialised on W7, but doesn't say anything about not supporting W7 at all?

           

           

          Scheduler    15/11/2010    11:15:31    Info    Scheduler: Task [Deploy Encrypted USB client] is finished   
          Scheduler    15/11/2010    11:15:31    Info    The task Deploy Encrypted USB client is successful   
          Updater    15/11/2010    11:15:31    Info    Update Finished   
          Updater    15/11/2010    11:15:31    Info   DPEUCLNT1000 is not supported on this platform (WNT7W:6:1:0).   
          Updater    15/11/2010    11:15:30    Info    Loading update configuration from: catalog.xml   
          Updater    15/11/2010    11:15:29    Info    Extracting catalog.z.   
          Updater    15/11/2010    11:15:29    Info    Verifying catalog.z.   
          Updater    15/11/2010    11:15:29    Info    Initializing update...   
          Updater    15/11/2010    11:15:29    Info    Checking update packages from repository Distrib2.   
          Scheduler    15/11/2010    11:15:29    Info    Scheduler: Invoking task [Deploy Encrypted USB client]...   
          Agent Subsystem    15/11/2010    11:15:13    Info    Next policy enforcement in 15 minutes   
          Agent Subsystem    15/11/2010    11:15:13    Info    Agent finished Enforcing policies   
          Management    15/11/2010    11:15:13    Info    Enforcing Policies for McAfee Agent   
          Management    15/11/2010    11:15:13    Info    Enforcing Policies for EEADMIN_1000   
          Management    15/11/2010    11:15:13    Info    Enforcing Policies for EPOAGENT3000   
          Management    15/11/2010    11:15:13    Info    Enforcing Policies for EPOAGENT3000META   
          Management    15/11/2010    11:15:13    Info    Enforcing Policies for VIRUSCAN8700   
          Agent Subsystem    15/11/2010    11:15:12    Info    Agent Started Enforcing policies   
          Agent Monitor    15/11/2010    11:15:12    Detail    Enforcing policies   
          Agent Subsystem    15/11/2010    11:14:57    Info    Agent communication session closed   
          Agent Subsystem    15/11/2010    11:14:57    Info    No package received from ePO Server   
          Agent Subsystem    15/11/2010    11:14:56    Info    Agent is connecting to ePO server   
          Agent Subsystem    15/11/2010    11:14:56    Info    Agent communication session started   
          Agent Subsystem    15/11/2010    11:14:56    Info    Sending the next batch of 1 data channel items   
          Agent Subsystem    15/11/2010    11:14:44    Info    Agent is looking for events to upload   
          Agent Subsystem    15/11/2010    11:14:44    Info    Agent communication session closed   
          Agent Subsystem    15/11/2010    11:14:44    Info    Package uploaded to ePO Server successfully   
          Agent Subsystem    15/11/2010    11:14:44    Info    Agent is connecting to ePO server   
          Agent Subsystem    15/11/2010    11:14:44    Info    Agent communication session started   
          Agent Subsystem    15/11/2010    11:14:42    Info    Agent communication session closed   
          Agent Subsystem    15/11/2010    11:14:42    Info    No package received from ePO Server   
          Agent Subsystem    15/11/2010    11:14:42    Info    Agent is connecting to ePO server   
          Agent Subsystem    15/11/2010    11:14:42    Info    Agent communication session started   
          Agent Subsystem    15/11/2010    11:14:42    Info    Sending the next batch of 1 data channel items   
          Agent Subsystem    15/11/2010    11:14:34    Info    Agent communication session closed   
          Agent Subsystem    15/11/2010    11:14:34    Info    Package uploaded to ePO Server successfully   
          Agent Subsystem    15/11/2010    11:14:34    Info    Agent is connecting to ePO server   
          Agent Subsystem    15/11/2010    11:14:34    Info    Agent communication session started   
          Agent Subsystem    15/11/2010    11:14:31    Info    Agent communication session closed   
          Agent Subsystem    15/11/2010    11:14:31    Info    No package received from ePO Server   
          Agent Subsystem    15/11/2010    11:14:30    Info    Agent is connecting to ePO server   
          Agent Subsystem    15/11/2010    11:14:30    Info    Agent communication session started   
          Agent Subsystem    15/11/2010    11:14:30    Info    Sending the next batch of 1 data channel items   
          Agent Subsystem    15/11/2010    11:14:28    Info    Next policy enforcement in 15 minutes   
          Agent Subsystem    15/11/2010    11:14:28    Info    Agent finished Enforcing policies   
          Scheduler    15/11/2010    11:14:28    Info    The task Deploy Encrypted USB client is modified  

           

          I checked the tasks in SQL and W7 is listed as a supported platform:

          447    EPOAGENTMETA    Deployment    Deploy Encrypted USB client    WIN95|WIN98|WINME|WNTS|WNTW|WXPW|WXPS|WXPHE|W2KS|W2KW|WVST|WVSTS|WNT7W

           

          Can anyone please tell me what's going on at all?

           

          And does anyone know when v1.4 is being released?

           

           

          And in relation to the first post above; I had initialy setup the foreign device policies for this machine to not allow anything foreign. Could this be whats casuing the problem- although i have uninstalled and reinstalled the USB client and looked at the foreign policy xml file and it says as expected from what i've set as the policy: foreign_manged=true, foreign_unmanged=true and restrict to network=false.

          I'm at a loss as to why this isn't working...

          So still no further....

           

          Thanks

          Jane

          • 2. Re: USB client 1.3 not recognising\initialising McAfee EUSB
            jmcleish

            I was told in December that Windows 7 isn't supported until USB Client 1.4

             

            Can anyone please tell me when this is scheduled to be released?

             

            Thanks

             

            Jane