3 Replies Latest reply on Oct 28, 2010 6:35 AM by JoeBidgood

    ePO 4.5 Global Administrator Permission set does not list any users

    pschmehl

      This is a weird one.

       

      Global Administrator
      0 users
      1 Active Directory group mappings

       

      If you edit Names and Users, you can see a list of all users on the system.  All those who have been assigned GA rights are greyed out but their box is checked.  All other boxes are available for checking.  I tried deleting my account, recreating it and assigning it no permissions.  Then I edited GA Names and Users and checked the box beside my name.  GA then said there was 1 user (my account, obviously), but I still had the same problem with some queries failing.

       

      I added the AD mapping to see if that would help resolve the issue I'm seeing.  It did not.

       

      Certain queries return a  " You are not authorized for this operation" even though I'm using an account with GA privileges.  I thought it might be related to this oddity of the GA permission set thinking there were no users assigned to that permission set.

       

      I'm running a brand new clean install (not upgrade) of ePO 4.5 build 937.

        • 1. Re: ePO 4.5 Global Administrator Permission set does not list any users
          JoeBidgood

          Can you give us a screenshot of what you're seeing? I'm not sure I'm understanding the problem...

          Is the Global Administrator permission set one that you created? It doesn't exist by default as far as I know.

           

          Thanks -

           

          Joe

          • 2. Re: ePO 4.5 Global Administrator Permission set does not list any users
            pschmehl

            JoeBidgood wrote:

             

            Can you give us a screenshot of what you're seeing? I'm not sure I'm understanding the problem...

            Is the Global Administrator permission set one that you created? It doesn't exist by default as far as I know.

             

            Thanks -

             

            Joe

             

            Well, I'd rather not, for security reasons.  I'd have to display all the usernames on our system.  :-(

             

            I created the Global Administrator group and gave it full permissions to everything, because I was getting the "You are not authorized for this procedure" errors when logged in as the service account that is admin for ePO and admin for the database.  Full permissions on everything, and yet I'm getting permissions errors.  It was my lame attempt to resolve the permissions issues that I was seeing that defy logic.  (How can a global admin not have perms to everything?)

            • 3. Re: ePO 4.5 Global Administrator Permission set does not list any users
              JoeBidgood

              Ah, OK. I have a suspicion that the "not authorised" message may be a red herring - check your PM

              As far as I know the global admin is a special permission set, so granting full permissions to an account doesn't give you a global admin - it has some additional system privileges that can't be explicitly assigned.

               

              Thanks -

               

              Joe