9 Replies Latest reply on Oct 10, 2012 12:57 PM by pcole

    Problem deploying VirusScan for Linux 1.6

      So here is the issue I am having:

       

      When I deploy VirusScan for Linux 1.6 via ePO the task completes successfully, (as seen in the local cma lagent log) but the product never gets fully installed.

       

      For instance, the "nails" user is never created and when I try to check the status of the services via /etc/init.d/nails status, the directory doesn't exist.

       

      I have version 4.5.0.1470 of the McAfee Agent for Linux installed on the client machines and have already successfully deployed Policy Auditor.

       

       

      It should be noted that when I install the product manually via "rpm -ivh McAfeeVSEForLinux-1.6.0-28488.noarch.rpm" all works fine.  It gets installed properly and takes policy from the ePO server.  I then can successfully uninstall virusscan 1.6 from the client via ePO.  The only problem is installing it . . . .

       

       

      Any help would be appreciated.

        • 1. Re: Problem deploying VirusScan for Linux 1.6

          Did you solve this problem?  I am having a similar issue.  The deployment task completes successfully according to the local mcafee agent log, but VirusScan never shows as an installed product in ePO. The VirusScan services are running on the Linux client.

          • 2. Re: Problem deploying VirusScan for Linux 1.6

            I have not had time to work on this issue since my last post, so no, as far as I know it is still an issue in our environment.

            • 3. Re: Problem deploying VirusScan for Linux 1.6

              Has anyone gotten this fixed.  I am having the same problem.  I manually install the agent 4.5 and once I do that the systems show up in my ePO4.5 console.  I push out VirusScan for Linux 1.6 but when I look at the system, the only thing there is the agent.  I cannot even get the dat files to the systems or the policies.  How do you check on the actual systems to see if the DAT files are updated?

              • 4. Re: Problem deploying VirusScan for Linux 1.6

                Hello,

                 

                what distro / kernel are you having trouble with? I suggest (in case you have not done so yet) you open a case with support so they can look further into this for you.

                 

                Kind regards,

                 

                Marcelo Ramos

                • 5. Re: Problem deploying VirusScan for Linux 1.6

                  I have a case open with support, but unfortunately there has not been any movement on it lately.

                  • 6. Re: Problem deploying VirusScan for Linux 1.6
                    bragot

                    I thought I had a similar problem before as well.  Eventually, it worked though.   Here are some things for you to check though:

                     

                    1. The agent log will tell you if it's downloading the package or not.  You can tail this.  The file is /opt/McAfee/cma/scratch/etc/log
                    2. The /var/log/messages file might also provide some information as to whether or not the service is starting correcly.
                    3. Check the /tmp folder for any files being created.  This is where the rpm file is initially downloaded to
                    4. Make sure that your local firewall is allowing the deployment.  If all else, disable it completely during the deployment to eliminate it as a possible cause.  service iptables stop is the command
                    5. The service that is created from a successful install is called nailsservice nails status will tell you if it's running well
                    6. Make sure you checked in all the necessary packages AND extensions (I always forget the extensions).  Also check in the latest hotfixes if there are some available.

                     

                    I'm not really sure why it took me multiple deployments to get this fixed.  But eventually it worked so I'm happy now.  Good luck!

                    • 7. Re: Problem deploying VirusScan for Linux 1.6

                      @Bragot or whoever -- I was able to establish the communication between the linux server and ePO, but when i log into the linux server I notice that nails isn't started.  I have to manually type service nails start for the service to start, instead of ePO starting the service after it's deployed.  When you deploy VSEL 1.6, do you have to log into each individual linux server to start the nails service?  What am I missing here? 

                       

                      I appreciate your support.

                      • 8. Re: Problem deploying VirusScan for Linux 1.6

                        Hey,

                         

                        I have problems to install MFEcma 4.6.1694, MFErt 2.0 and McAfeeVSEForLinux-1.6.0-28488 under Suse Linux.

                         

                        I have wrote a script to silent install this Products. When i manuelly execute the script under Linux the installation was successfully.

                         

                        When i install the products via our deployment tool:

                        1. the SiteList.xml  is wrong under /opt/Mcafee/cma/scratch/etc -> only the default not the one with our EPOServer descriptions

                        2. The ServerSiteList.xml under /opt/Mcafee/cma/scratch is missing

                        3. The keystore directory under /opt/Mcafee/cma/scratch is empty

                        4. A empty .generate_guid file is present under /opt/Mcafee/cma/scratch

                         

                        can anyone help me.

                         

                        regards

                        Günther

                        • 9. Re: Problem deploying VirusScan for Linux 1.6

                          Ok, I think the information I have is useful though i've been working on this with VSE for Linux v1.7 through an 4.5 ePO. I am working with a 64-bit Redhat 6.

                           

                          First in the logs (/var/log/messages)  you will see a pam 32-bit library requirement. This pam lib is dependent on 4 other libs (which must be installed). These are libselinux, libcrack, libaudit, and libdb-4.7.  Once these have been installed on the Linux system you should be able to use a deployment task from the ePO to deploy VSE 1.7. I have also verifies that I can use a removal task in the same.

                           

                          Hope this is helpful!