5 Replies Latest reply on Oct 12, 2010 10:24 AM by jcmiller54

    Sierra Wireless 308 USB 3G modem

      Anyone sucessfuly use this modem on a on firmware 4.0.8?

       

      It appears that the device is detected and is 'up' but cannot establish a connection.

       

      The device is detected as

      Modem: USB 308

      Vendor ID: 1199

      Product Id: 68A3

      Serial Interface to use: 0

       

      Connection string: AT+CGDCONT=1,"IP","%s"

      Sim card code command: AT+CPIN="%s"

       

      Modem init string: ATE1V1Q0

       

      ---- log snip ---

      Oct  3 19:30:46 diald[13421]: running dialer "/bin/chat -v -T *99# -R /var/run/dialout-sg-usb_serial-2-dev.speed -f /etc/config/chat.sg-usb_serial-2-dev" 
      Oct  3 19:30:46 chat[13527]: report (CONNECT)
      Oct  3 19:30:46 chat[13527]: abort on (BUSY)
      Oct  3 19:30:46 chat[13527]: abort on (NO CARRIER)
      Oct  3 19:30:46 chat[13527]: send (ATZ\d\d\d^M)
      Oct  3 19:30:46 diald[13421]: Running connect (pid = 13527).
      Oct  3 19:30:49 chat[13527]: send (ATE1V1Q0^JAT+CGDCONT=1,"IP","telstra.internet"^M)
      Oct  3 19:30:50 chat[13527]: expect (OK)
      Oct  3 19:31:04 ifmond[828]: conn-sg-usb_serial-2-dev was checking and is now up
      Oct  3 19:31:04 ifmond[828]: conn-sg-usb_serial-2-dev-connected was waiting-to-start and is now starting
      Oct  3 19:31:04 ifmond[828]: conn-sg-usb_serial-2-dev-connected was starting and is now checking
      Oct  3 19:31:07 firewall[13570]: executing firewall rules
      Oct  3 19:31:09 dnsmasq[830]: reading /etc/config/resolv.dnsmasq
      Oct  3 19:31:09 dnsmasq[830]: using nameserver 10.255.255.254#53
      Oct  3 19:31:35 last message repeated 1 time(s)
      Oct  3 19:31:35 chat[13527]: alarm
      Oct  3 19:31:35 chat[13527]: Failed
      Oct  3 19:31:35 diald[13421]: Connect script failed.
      Oct  3 19:31:36 diald[13421]: Delaying 30 seconds before clear to dial.
      Oct  3 19:32:04 ifmond[828]: connection conn-sg-usb_serial-2-dev-connected failed check, status 1
      Oct  3 19:32:04 ifmond[828]: conn-sg-usb_serial-2-dev-connected was checking and is now stopping
      Oct  3 19:32:04 ifmond[828]: conn-sg-usb_serial-2-dev-connected was stopping and is now down
      Oct  3 19:32:04 ifmond[828]: conn-sg-usb_serial-2-dev-connected was down and is now waiting-to-start
      Oct  3 19:32:08 diald[13421]: running dialer "/bin/chat -v -T *99# -R /var/run/dialout-sg-usb_serial-2-dev.speed -f /etc/config/chat.sg-usb_serial-2-dev"
      Oct  3 19:32:08 chat[13887]: report (CONNECT)
      Oct  3 19:32:08 chat[13887]: abort on (BUSY)
      Oct  3 19:32:08 chat[13887]: abort on (NO CARRIER)
      Oct  3 19:32:08 chat[13887]: send (ATZ\d\d\d^M)
      Oct  3 19:32:08 diald[13421]: Running connect (pid = 13887).
      Oct  3 19:32:11 chat[13887]: send (ATE1V1Q0^JAT+CGDCONT=1,"IP","telstra.internet"^M)
      Oct  3 19:32:12 chat[13887]: expect (OK)

      --- end ---

      The connection status is "up" but it has no IP.

       

      I am using a sierra wireless 880 without problem (it's fussy some times howerver)

       

      Notice how it claimed to recieved a DNS address of 10.255.255.254#53

       

      ISP is Telstra NextG, any idea?

       

       

      Message was edited by: orionweb on 3/10/10 10:24:16 PM