3 Replies Latest reply: Nov 5, 2010 4:24 PM by Aldrin RSS

    Firewall Still Blocking Program After Being Granted Permission

      I use Windows 7 64 bit. I recently set my firewall to "Stealth" mode, after having a game account hacked 3 times in a month. This fixed my problem with being hacked, but the stealth setting is giving me problems now. Another game that I have had installed for a year (and has always worked perfectly), is being blocked from accessing the internet. Every time I start the game, and try to connect to the server, it says it can't connect, and closes. After the game closes, Mcafee asks me if I want to "allow always", "allow once" or "block" internet access for this program. I've pressed "allow always" every time. This has happened at least 12 times. I've also gone into the Mcafee Firewall settings, and put the game program on the "full access" list. The problem is not fixed. My subscription to Mcafee runs out in 15 days, and if I can't fix this by then, I'm going to have to switch to a different provider.



        • 1. Re: Firewall Still Blocking Program After Being Granted Permission



          Could you please provide us the following details;
          How is the computer connected to internet ? (dsl/wireless/cable)

          What is name & version of your gaming software.

          What is the version of McAfee firewall ?
          Do we have any router engaged for your network ?




          McAfee Online Community Moderator

          • 2. Re: Firewall Still Blocking Program After Being Granted Permission

            I know this is an old post that I'm replying to, but I was just having the same issue tonight.  The game that I was trying to play was City of Heroes.  There had been no connection issues at all until tonight when the game downloaded an update.  (This will always trigger McAfee to tell me that the game was changed and it gives me the pop up asking if I want to allow it again.)  So I clicked "Allow" like usual, switched back to the game and tried to connect, but got nothing.


            *Automagical Fail*


            I tried a bunch of different things, and even went as far as trying a couple restore points with System Restore.  That did nothing but further **** me off.


            To make a long story short, in the program access list, there were actually multiple entries for City of Heroes (due to me having separate installations for Beta releases, and the Test Server).  I decided to nuke them all and let the firewall start permissions from scratch.  I fired CoH up, told McAfee to "Always Allow", and it's working.  Still in Stealth Mode on the firewall.  Pretty happy about that.


            Yes, McAfee, you may hire me.

            • 3. Re: Firewall Still Blocking Program After Being Granted Permission

              Well, that's a good piece of information. Thanks