5 Replies Latest reply on Sep 15, 2010 7:53 AM by Attila Polinger

    Log says update successful yet DAT not updating

      Hi All,

       

      Don't ask why but we have to keep a couple NT domain controllers hanging around for a bit. I have got them to the point of being able to update manually, but the HTTP auto update is failing, although it does say it is successful. Using VScan 8.5i (patch 8) and CMA 3.6 (latest I think). Tried getting this working in ePO 4 with no joy either. I also get the same errors when using a UNC path. Please help!!

       

      14/09/10 12:00:14 FI\BMurphy Starting task: AutoUpdate
      14/09/10 12:00:15 FI\BMurphy Starting update session.
      14/09/10 12:00:15 FI\BMurphy Checking update packages from repository NAIHttp.
      14/09/10 12:01:40 FI\BMurphy Initializing update...
      14/09/10 12:01:40 FI\BMurphy Downloading catalog.z.
      14/09/10 12:03:03 FI\BMurphy Verifying catalog.z.
      14/09/10 12:03:03 FI\BMurphy Extracting catalog.z.
      14/09/10 12:03:03 FI\BMurphy Loading update configuration from: Catalog.xml
      14/09/10 12:03:04 FI\BMurphy Verifying datdet.mcs.
      14/09/10 12:03:04 FI\BMurphy Searching available updates for DATs.
      14/09/10 12:03:05 FI\BMurphy Downloading PkgCatalog.z.
      14/09/10 12:04:29 FI\BMurphy Verifying PkgCatalog.z.
      14/09/10 12:04:29 FI\BMurphy Extracting PkgCatalog.z.
      14/09/10 12:04:29 FI\BMurphy Loading update configuration from: PkgCatalog.xml
      14/09/10 12:04:30 FI\BMurphy Starting DAT update.
      14/09/10 12:04:30 FI\BMurphy Verifying EngDet.mcs.
      14/09/10 12:04:30 FI\BMurphy Searching available updates for Engine.
      14/09/10 12:04:30 FI\BMurphy Product(s) running the latest Engine.
      14/09/10 12:04:30 FI\BMurphy Updates were not applied because packages were not in the repository:  EXTRADAT1000.
      14/09/10 12:04:32 FI\BMurphy Update Finished
      14/09/10 12:04:41 FI\BMurphy Closing the update session.

        • 1. Re: Log says update successful yet DAT not updating
          Attila Polinger

          Hello,

           

          would you post here as attachment the McScript.log from the affected DC?

           

          In the meantime please check out these two KB article, just to be sure you are using the right HTTP source:

          https://kc.mcafee.com/corporate/index?page=content&id=KB60992&actp=search&viewlo cale=en_US&searchid=1284467397749

           

          https://kc.mcafee.com/corporate/index?page=content&id=KB60772

           

          Attila

          • 2. Re: Log says update successful yet DAT not updating

            Thanks again Attila!

             

            That article about gen files is the whole reason I have had to upgrade the NT boxes to 8.5i. They were working happily with 8.0 and PPilot

             

            Tried the Common Updater URL as per the other article and getting the same error.

             

            McScript.log:

            20100914135625: PR-DC-01: ScriptEngine: PR-DC-01 Initializing update...
            20100914135625: PR-DC-01: ScriptEngine: PR-DC-01 Downloading catalog.z.
            20100914135747: PR-DC-01: ScriptEngine: PR-DC-01 Verifying catalog.z.
            20100914135747: PR-DC-01: ScriptEngine: PR-DC-01 Replacing file C:\Program Files\Network Associates\Common Framework\Data\Common Framework\catalog.ztp with C:\Program Files\Network Associates\Common Framework\Data\Common Framework\catalog.z
            20100914135748: PR-DC-01: ScriptEngine: PR-DC-01 Extracting catalog.z.
            20100914135748: PR-DC-01: ScriptEngine: PR-DC-01 Loading update configuration from: Catalog.xml
            20100914135749: PR-DC-01: ScriptEngine: PR-DC-01 These updates will be applied if they are in the repository:  DAT, Engine, EXTRADAT1000, BOCVSE__1000.
            20100914135749: PR-DC-01: ScriptEngine: PR-DC-01 Verifying datdet.mcs.
            20100914135750: PR-DC-01: ScriptEngine: PR-DC-01 Searching available updates for DATs.
            20100914135750: PR-DC-01: ScriptEngine: PR-DC-01 *** Start [DoesWsmtp500NeedToBeUpdated]
            20100914135750: PR-DC-01: ScriptEngine: PR-DC-01 Downloading PkgCatalog.z.
            20100914135914: PR-DC-01: ScriptEngine: PR-DC-01 Verifying PkgCatalog.z.
            20100914135914: PR-DC-01: ScriptEngine: PR-DC-01 Extracting PkgCatalog.z.
            20100914135914: PR-DC-01: ScriptEngine: PR-DC-01 Loading update configuration from: PkgCatalog.xml
            20100914135915: PR-DC-01: ScriptEngine: PR-DC-01 Starting DAT update.
            20100914135916: PR-DC-01: ScriptEngine: PR-DC-01 ERROR: Unrecognized command in script file. : Line: 127 CONCATSTRING
            20100914135916: PR-DC-01: ScriptEngine: PR-DC-01 ERROR: Unrecognized command in script file. : Line: 127 CONCATSTRING
            20100914135916: PR-DC-01: ScriptEngine: PR-DC-01 Verifying EngDet.mcs.
            20100914135916: PR-DC-01: ScriptEngine: PR-DC-01 Searching available updates for Engine.
            20100914135916: PR-DC-01: ScriptEngine: PR-DC-01 *** Start [DoesWsmtp500NeedToBeUpdated]
            20100914135916: PR-DC-01: ScriptEngine: PR-DC-01 Product(s) running the latest Engine.
            20100914135916: PR-DC-01: ScriptEngine: PR-DC-01 Updates were not applied because the updates are not supported on this platform:  BOCVSE__1000.
            20100914135916: PR-DC-01: ScriptEngine: PR-DC-01 Updates were not applied because packages were not in the repository:  EXTRADAT1000.
            20100914135918: PR-DC-01: ScriptEngine: PR-DC-01 Update Finished
            20100914135948: PR-DC-01: ScriptEngine: PR-DC-01 Deleting  C:\Program Files\Network Associates\Common Framework\Data\Common Framework\Catalog.xml
            20100914135948: PR-DC-01: ScriptEngine: PR-DC-01 Deleting  C:\Program Files\Network Associates\Common Framework\Data\Common Framework\Catalog.ztp
            20100914135948: PR-DC-01: ScriptEngine: PR-DC-01 Closing the update session.

             

            Didn't check this log before, I will look into, thanks

            • 3. Re: Log says update successful yet DAT not updating
              Attila Polinger

              Hi Trotski,

               

              I'm very glad I could help you.

               

              I saw some errors in the text that makes me believe that your current Updater or whatever module interprets the .MCS scripts, has problems with them. I'm not sure what is your current management system, but upgrading the CMA 3.6 to McAfee Agent 4.0 Patch 3 might resolve these errors if you use ePO 4 or above.

               

              As for the below lines:

               

              20100914135916: PR-DC-01: ScriptEngine: PR-DC-01 Updates were not applied because the updates are not supported on this platform:  BOCVSE__1000.
              20100914135916: PR-DC-01: ScriptEngine: PR-DC-01 Updates were not applied because packages were not in the repository:  EXTRADAT1000.

              They are normal, meaning that the first type of update is not supported and the other is not checked in the repository (but the update policy is such that it is trying to update everything it has on its list).

               

              Attila

              • 4. Re: Log says update successful yet DAT not updating

                Thanks again Atilla.

                 

                This is NT so Agent 4+ won't work. We are using ePO 4 but I would be happy to get it just updating from the Net right now.

                 

                Thought I installed the latest version of 3.6 but looking in the registry it says 3.5. going to go back to square one for the umpteen time and reinstall 3.6.

                 

                If this fails I will just automate the DAT download to a share and use a script to update it via command line.

                • 5. Re: Log says update successful yet DAT not updating
                  Attila Polinger

                  If you have NT, then please take a look at this article and select which is the highest supported McAfee Agent (or CMA) version you should install.

                   

                  https://kc.mcafee.com/corporate/index?page=content&id=KB51573

                   

                  I think CMA latest version for NT SP6 is CMA 3.6 patch 4.

                   

                  Attila