3 Replies Latest reply on Sep 14, 2010 8:09 AM by SergeM

    ePO server has two IP adresses

    SergeM

      Hi,

       

      One of my ePO servers has two different IP adresses.One is for internal (inside our network) use only and the other is for external (internet) use only.

      The DNS servers will redirect calls to FQDN to the correct IP depending on whether the incoming (agent) connexion comes from inside or outside our network.

       

      This worked quite well until recently. I now have a few (~100!?) laptops that can't connect to the ePO server (when not inside our net).

       

      I was able to reproduce last night (when not at the office) and could see that the laptop insists on using the numeric IP that last worked and wont use the FQDN.

      I checked with nslookup and ping that FQDN and DNS work.

      I know that the actual IP of the last used server is stored in SiteList.xml and ServerSiteList.xml, I tried manually changing it but it didn't work (it used to last time I'd had a similar problem).

       

      anyone has an idea ?

       

      Serge

        • 1. Re: ePO server has two IP adresses
          jmcleish

          unfortuanely i can't help too much but if you check the KB with the search "epo server two network cards" it comes up with quite a few articles. maybe have a look to see if one applies to your situation?

           

          HTH

          Jane

          • 2. Re: ePO server has two IP adresses
            Troja

            Hi, can you activate LogLevel 8 and sending the Agents Logs?

            • 3. Re: ePO server has two IP adresses
              SergeM

              Hi again,

               

              Thanks for the suggestions. I did check the KB, but didn't find anything that applies.

               

              I'd like to specify that the server doesn't have 2 network adapters. The IP adress is NAT-ed by our (internal/external) DNS (simpler text for my complicated explanation above).

               

              When I check the Agents'logs I don't see anything special.  I just found out how to activate LogLevel 8 in KB https://kc.mcafee.com/corporate/index?page=content&id=KB56207, will test and see what I get.

               

              Checking the Host IPS logs (or through Wireshark), I seen connection attempts to both (numeric) IP addresses (!) even after the systems can see only one IP responds.

               

              I have a suspicion that it might be related to the actual IP of both the laptops & the server...

              Internal IP of the server is in the 192.168.aaa.0 range and most of the time, laptops have an IP in the 192.168.1.x range when outside our network.

              So, when the laptop is @home, it has an IP more or less in the same range (192.168.0.0/16) as the server used to have... and yet the agent is expected to connect to the DNS to obtain the new IP of the server... which doesn't seem to work correctly.

               

              Serge