7 Replies Latest reply on Jul 20, 2010 3:51 PM by Peacekeeper

    Can't click McAgent notification buttons

      It seems I can no longer click buttons (as in graphical) within the McAgent alert dialogs (like growl notifications). This is very annoying since I can't close the dialog and I forever have it blocking content on my screen. I have restarted the computer and even McAfee applications, multiple times. If there are text links - like "More Info >>" - those work fine. I have also run all updates and it says I am up to date. Running McAfee Internet Security on Windows Vista. I closed all applications that simulate the mouse, like Synergy and VNC, still no luck.

        • 1. Re: Can't click McAgent notification buttons
          k3tg

          Try to run the McAfee Virtual Technician. MVT will scan your computer for McAfee related issues and it finds any it will attempt to fix them for you. When you have completed MVT it wiil prompt you to contact Technical Support Chat which can diagnose your issue further. Just click on Technical Support link under Useful Links at the top of this page.

          • 2. Re: Can't click McAgent notification buttons
            Peacekeeper

            Are you saying you click close and it does not or it is greyed out or off the edge of the box?

            • 3. Re: Can't click McAgent notification buttons

              Am saying that clicking does nothing. The button is not disabled.

              I spent some time with the online support, and here is the solution to this. Apparently its an issue with Internet Explorer, which is what the dialog window is using to display the messaging

               

              Open a Commandline window (START BUTTON >> type in CMD and it will show the command line application >> Right click it and choose RUN AS ADMINISTRATOR), then enter the following:

               

               

              regsvr32 msoeacct.dll /s

              rem regsvr32 wab32.dll /s

              rem regsvr32 wabimp.dll /s

              rem regsvr32 wabfind.dll /s

              rem regsvr32 oemiglib.dll /s

              rem regsvr32 directdb.dll /s

              regsvr32 inetcomm.dll /s

              rem regsvr32 msoe.dll /s

              rem regsvr32 oeimport.dll /s

              regsvr32 msdxm.ocx /s

              regsvr32 dxmasf.dll /s

              rem regsvr32 laprxy.dll /s

              regsvr32 l3codecx.ax /s

              regsvr32 acelpdec.ax /s

              regsvr32 mpg4ds32.ax /s

              regsvr32 voxmsdec.ax /s

              regsvr32 danim.dll /s

              regsvr32 Daxctle.ocx /s

              regsvr32 lmrt.dll /s

              regsvr32 datime.dll /s

              regsvr32 dxtrans.dll /s

              regsvr32 dxtmsft.dll /s

              rem regsvr32 vgx.dll /s

              regsvr32 WEBPOST.DLL /s

              regsvr32 WPWIZDLL.DLL /s

              regsvr32 POSTWPP.DLL /s

              regsvr32 CRSWPP.DLL /s

              regsvr32 FTPWPP.DLL /s

              regsvr32 FPWPP.DLL /s

              rem regsvr32 FLUPL.OCX /s

              regsvr32 wshom.ocx /s

              regsvr32 wshext.dll /s

              regsvr32 vbscript.dll /s

              regsvr32 scrrun.dll mstinit.exe /setup /s

              regsvr32 msnsspc.dll /SspcCreateSspiReg /s

              regsvr32 msapsspc.dll /SspcCreateSspiReg /s

              regsvr32 licdll.dll /s

              regsvr32 regwizc.dll /s

              regsvr32 softpub.dll /s

              regsvr32 IEDKCS32.DLL /s

              regsvr32 MSTIME.DLL /s

              regsvr32 WINTRUST.DLL /s

              regsvr32 INITPKI.DLL /s

              regsvr32 DSSENH.DLL /s

              regsvr32 RSAENH.DLL /s

              regsvr32 CRYPTDLG.DLL /s

              regsvr32 Gpkcsp.dll /s

              regsvr32 Sccbase.dll /s

              regsvr32 Slbcsp.dll /s

              exit

               

              Now it works fine. A bit of a scary experience when I allow remote access, and they open up a command prompt and dump a ton of commands and close it right away with no explaination of what they are doing. It also took quite a bit of back-and-forth to get the support person to give me the command script he used so that incase it causes other issues I know what was changed. I suppose most people asking for remote assistance likely don't know what the command prompt is other than "that black window with text", and probably don't make a request like this often.

               

               

              Message was edited by: mondo on 7/20/10 7:41:17 AM CDT
              • 4. Re: Can't click McAgent notification buttons
                Peacekeeper

                Gees that is a lot of changes will ask our tech why this necessary and if there is a permanent fix comes IE not happen to others.

                • 5. Re: Can't click McAgent notification buttons
                  Peacekeeper

                  What IE version are you running?

                  • 6. Re: Can't click McAgent notification buttons

                    Version: 8.0.6001.18928

                    • 7. Re: Can't click McAgent notification buttons
                      Peacekeeper

                      Now that is strange as those fixes were made for vresion IE 6. Thanks at least it is fixed now so make this as answered please

                       

                       

                      Message was edited by: Peacekeeper on 21/07/10 6:51:14 AM