5 Replies Latest reply on Jun 24, 2010 3:33 PM by kink80

    Install VSE 8.7i with Patch 3 over VSE 8.7i Patch 2

    kink80

      Is it possible to install VSE 8.7i with Patch 3 rolled up in the installer over the top of VSE 8.7i Patch 2 that is already on the machine? I would like to do this to test Patch 3 on a few machines without having to check patch 3 into the Current branch. I am using McAfee Agent 4.5.1270 which cannot distribute patches from the Eval and Previous branches.

        • 1. Re: Install VSE 8.7i with Patch 3 over VSE 8.7i Patch 2
          rmetzger

          kink80 wrote:

           

          Is it possible to install VSE 8.7i with Patch 3 rolled up in the installer over the top of VSE 8.7i Patch 2 that is already on the machine? I would like to do this to test Patch 3 on a few machines without having to check patch 3 into the Current branch. I am using McAfee Agent 4.5.1270 which cannot distribute patches from the Eval and Previous branches.

          Well, are you testing the installation of VSE or just the patch?

           

          If you want to test a few machines (and not the installation or distribution), then I would download Just The Patch (3) which allows you to manually install the patch at the local machine. Just follow the directions in the Patch3 pdf included with the download.

           

          If you are in 'eval mode' and don't have a grant number, I would try to find a McAfee Service Rep. to get you a copy, or maybe it's time. . .

           

          Hope this helps.

          Ron Metzger

           

           

          Message was edited by: rmetzger on 6/24/10 1:12:21 PM EDT
          1 of 1 people found this helpful
          • 2. Re: Install VSE 8.7i with Patch 3 over VSE 8.7i Patch 2
            kink80

            Thanks for the response. I know that I can install the patch manually on machines however I was looking for an automated resolution. I have about 10 machines spread throughout my enterprise that need to get this patch before I can install McAfee Agent 4.5.1499 (patch 1). If I try to go from McAfee Agent 4.5.1270 (RTW) to Agent 4.5.1499 (Patch 1) with VSE 8.7i Patch2 installed I get an error closing Mctray.exe when the upgrade takes place and the user would see this error and have to click on close. This is why I wanted to know if I could use ePO to distribute the VSE 8.7i with Patch 3 installer to install over VSE 8.7i Patch 2.

            • 3. Re: Install VSE 8.7i with Patch 3 over VSE 8.7i Patch 2
              rmetzger

              I see.

               

              Since you state you are in 'Eval' mode, I cannot see an easy way to do this.

               

              I think you may want to break this up in to two stages:

              1) uninstall VSE 8.7i P2

              2) Install Full VSE 8.7i P3.

               

              Many people have tried doing an over-install but not all are successful. A complete removal and replacement might be the best approach, given that you are messing with the agent and all. Given that you are testing the product, not the distribution, on approximately 10 nodes, this might not be that bad. Once out of Eval mode, other distribution methods are available which you can then check.

               

              Not much help I know; maybe someone else can help more.

               

              Have you spoken with your McAfee Service Rep.?

              Ron Metzger

              • 4. Re: Install VSE 8.7i with Patch 3 over VSE 8.7i Patch 2
                mrandolp

                My questionis is, are you using ePO to manage nodes?  If you are why don't you setup a group and place those nodes in the group.  Once you have created the group and added the nodes, create a client task and push hotfix 3 to the workstations.  Make sure you have download the patch and checked it in.  I currently have over 5000 nodes and about 150 that need the patch.  This is what I havce done.  I have schedule the task for daily and set the time for 12:00 PM.

                 

                Hope this helps.

                Mike

                • 5. Re: Install VSE 8.7i with Patch 3 over VSE 8.7i Patch 2
                  kink80

                  I am using ePO. What I had setup was a client task that would install Patch 3  if I tagged a machine with a certain value. The problem with this method is that I have to check Patch 3 into the Current branch. When this is done any machine that does a manual "Update Now" task from the client will also get this patch and it seems that some machines performed a one-click update on their own with an "Update list doesn't exist or is empty.  Performing one-click update" entry in the agent log which resulted in the machine getting the patch 3 as well. I want to be able to control where and when this patch is installed. The ultimate solution is going to be when I get all of my machines on McAfee agent 4.5 Patch 1. This version of McAfee agent allows for patches to be distributed from the "Evaluation" and "Previous" repository branches. I cannot get to this version of the agent because installing McAfee Agent 4.5.0.1499 over MA 4.5.0.1270 when VSE 8.7i Patch 1 is installed results in mctray.exe crashing. So I first have to upgrade the clients that had VSE 8.7i Patch 2 and the McAfee Agent 4.5.0.1270 to VSE 8.7i Patch 3 to eliminate the mctray.exe crashes in order to upgrade my McAfee Agent to 4.5.0.1499.