3 Replies Latest reply on May 27, 2010 9:28 AM by jhaynes

    Unable to Upgrade Database Component 6.5 to 6.8

      Foundstone database component does not pass the upgrade/install self-test. All other components are on an application server while the dB is on a SQL box. We've placed the upgrade/install on the SQL box, run the agent, select Database only, and run it. It perofrms some tasks then a pop-up box appears saying TCP/IP connectivity error and upgrade/install halts. Current version (6.5) scan engine and db work fine. Any ideas? What specifically is this self-check looking for? If we knew that, we might be able to address it on the SQL box.

      FS Error.png

        • 1. Re: Unable to Upgrade Database Component 6.5 to 6.8

          Are you using the default DB instance?  If not you may need to specify it to the installer by following this KB:

           

          https://kc.mcafee.com/corporate/index?page=content&id=KB67318

           

          or is this SQL Express?  These are the requirements for using SQL Express (in the install guide):

           

          Enabling TCP/IP

          By default, TCP/IP is disabled in Microsoft SQL Express 2005. TCP/IP must be

          enabled for Foundstone to function properly.

           

           

           

          Open the SQL Server 2005 Surface Area Configuration wizard

          Select

           

          Start | All Programs | Microsoft SQL Server 2005 | Configuration

          Tools | SQL Server 2005 Surface Area Configuration

           

           

          .

           

           

           

           

          Select Surface Area Configuration for Services and Connections.

           

           

           

          Select Remote Connections under Database Engine.

           

           

           

          Select Local and remote connections and select a TCP/IP option.

           

           

           

          Select OK to save the settings.

           

           

           

          Restart the Database Engine service for the change to take affect.

           

          I hope that helps.

           

          -Cathy

          1 of 1 people found this helpful
          • 2. Re: Unable to Upgrade Database Component 6.5 to 6.8

            We followed the points/information in the linked KB article without success. The SQL Express information does not apply as we're not using it.

             

            Any other thoughts?

             

            Thanks

            • 3. Re: Unable to Upgrade Database Component 6.5 to 6.8
              jhaynes

              Off the top of my head I don't have any other suggestions. I would open up a service request so we can take a better look at your system. This isn't an issue that we have seen before.

               

              Jeff Haynes