4 Replies Latest reply on Jun 30, 2010 3:25 AM by ganman

    McAfee Agent 4.5 deinstallation kb67796

      hi,

       

      i'm using mcafee agent 4.0 p3 and virusscan enterprise 8.7i p2. in the next week(s) i must upgrade to mcafee agent 4.5 and virusscan 8.7i witch patch 3. there is no ePO running.

      i created a msi package for virusscan 8.7i p3 with the installation designer without a problem. it works fine. with the kb67796  (https://kc.mcafee.com/corporate/index?page=content&id=KB67796) i created a msi package for the agent 4.5. with the same instructions i created my agent 4.0 p3 msi as well. the installation works fine but the deinstallation with gpo policy is quite troublesome (McAfee Agent cannot be removed while it is in managed mode.)

       

      For my test environment i created a batch script that solves my problem.

      "c:\program files\mcafee\common framework\frminst.exe" /remove=agent

       

      My hope is to perform this in the msi package for agent 4.5 so that i don't need my script anymore.

       

      the product guide for agent 4.5 says (page 48):

      Removing the McAfee Agent
      Use these tasks to remove agents from systems.
      NOTE: You cannot remove the agent using the Product Deployment task, which can remove
      products such as VirusScan Enterprise.
      Tasks
      Running FrmInst.exe from the command line
      Removing agents when deleting systems from the System Tree
      Removing agents when deleting groups from the System Tree
      Removing agents from systems in query results
      Uninstalling from non-Windows operating systems

       

      Any ideas to how i can fix this problem? my boss don't want to use a ePO.

       

       

      on 20.05.10 09:49:24 GMT+01:00
        • 1. Re: McAfee Agent 4.5 deinstallation kb67796

          afaik if there is no epo server in your environment then none of the agents should be in managed mode anyway??

          • 2. Re: McAfee Agent 4.5 deinstallation kb67796

            hi.

             

            no epo server is running in my environment. mcafee agent 4.5 can't be removed because it's in managed mode. i hoped that mcafee agent 4.5 p1 solves this problem but it doesn't. so i need to run my script to remove the agent when it's needed.

            • 3. Re: McAfee Agent 4.5 deinstallation kb67796

              Hi, I understand that you have no epo server, but my point was that if you install the agent from the default  download it has no references to any servers and should not go into  managed mode.

               

              From my understanding of the link you provided, you are getting a framepkg.exe file from some epo server somewhere to make your msi package from and that would contain references to that epo server. So I'm wondering if, when you deploy the msi it goes into managed mode and looks for the epo server the framepkg.exe originated from.

               

              Why would you need the agent in an unmanaged environment anyway? Couldn't you just install VSE and set up your repositories within VSE (though I'm not sure how without going to each machine)?

              • 4. Re: McAfee Agent 4.5 deinstallation kb67796

                hi,

                 

                thanks to you i think that i solved my problem. i uses the default mcafee agent 4.5 p1 package and i tested it on a virtual pc. it works fine. so i think it will work on real computers as well. i think that the framepkg_udp.exe that i used to create my package was the problem. it's for an epo environment and i don't have an epo server running so i think that's the mayor problem.

                 

                now it works and i'm happy. ;-)

                 

                thx a lot smiabe. you pushed me in the right direction.