5 Replies Latest reply on May 20, 2010 1:01 AM by RayP

    Content Does Not Match Content Type

    RayP

      Hi,

       

      When a user visit the a page for shopping, they get the following error.

       

      Content Does Not Match Content Type

       

      The transferred file "http://www.inmac.nl/gy_portal/index.php?option=com_oscommerce&osMod=redirect&act ion=login&shop=nlpro&trash=" has been blocked by Webwasher, because the content of the file does not match the content type "text/html" and Webwasher can not correct it.

       

      How can I allow this type of content?

       

       

      Regards,

      Raymond

        • 1. Re: Content Does Not Match Content Type
          asabban

          Hello Raymond,

           

          this actually happens if you download a file and the Webserver sends a specific Content Type, but the announced Content Type does not match the Content Type Webwasher identified.

           

          This happens pretty often, therefore you may consider set the Media Type filter to generally allow Files where this mismatch happens. If you want to leave it in place I recommend to put in a Whitelist Entry for the URL and Path and Disabled "Media Type Filter" for this kind of request.

           

          This should allow you to access that Website.

           

          Best,

          Andre

          • 2. Re: Content Does Not Match Content Type
            RayP

            Hello Andre,

             

            Thanks for your reply.

            U mean putting the media type "text/html" in the Media Type White List and adding this to all policies?

             

            ScreenHunter_01 May. 19 15.53.gif

             

            When I do this I still get the same error.

             

            Regards,
            Raymond

            • 3. Re: Content Does Not Match Content Type
              jnemitz

              Hi Ray,

               

              The actual setting affecting this can be found under Common --> Media Type Filters --> Actions --> Non-rectifiable media types with magic bytes mismatch.  To allow this type of behavior in general, you could set an allow action for this setting.

              To white list a specific URL, you can add an entry to Common --> White List.

              Select String from the dropdown, and enter the URL in question.  From the other dropdowns, select Web and Any URL.  Then check the box for Media Type Filter and add the entry.

               

              Regards,

               

              John

              • 4. Re: Content Does Not Match Content Type
                asabban

                Yeah John is right, I am sorry for not being more precise.

                 

                The Media Type Whitelist is only considered for the "Default action for unlisted media types" setting. It is pretty confusing, but should be explained in the Online Help in case you would like to follow up.

                 

                Let us know if you encounter additional issues with accessing that URL.

                 

                Best,

                Andre

                1 of 1 people found this helpful
                • 5. Re: Content Does Not Match Content Type
                  RayP

                  Hi John and Andre,

                   

                  I removed the entry within "Media Type White List".

                  Then I configured the "Non-rectifiable media types with magic bytes mismatch" from Block to Allow.

                  That didn't work..still the message about "Content Does Not Match Content Type".

                   

                  One thing that has to be done first...select the corresponding policy.

                   

                  Thanks for help John and Andre.

                   

                  Regards,
                  Raymond