Skip navigation
McAfee Secure sites help keep you safe from identity theft, credit card fraud, spyware, spam, viruses and online scams
This discussion is archived
17741 Views 11 Replies Latest reply: Aug 1, 2010 3:39 PM by Peacekeeper RSS 1 2 Previous Next
JohninLA Newcomer 16 posts since
Feb 26, 2006
Currently Being Moderated

May 16, 2010 12:49 PM

mcshield.exe using 100% cpu

This has started in the past week or so.I am using McAfee Total Protection 2010. I'm using Vista.

 

I noticed my system was slowing down to a halt, and I could not do a thing on my computer. I would try to click a desktop icon, and I get a notice that Windows Explorer was not responding. I let it wait to see if it would clear on it's own.and it wouldn't. After much playing around, rebooting, shutting down all open windows, I still could not get my system moving again.

 

After a reboot, I tried running a complete system scan, and after 5-6 hours, McAfee reported no viruses or malware found, the system was clean. After more playing around, I saw that mcshield.exe was using 100% of my cpu. My hard drive was running continuously, it never ended. I finally got into my McAfee control panel, and shut down Real Time Scanning, and that did it, my cpu returned to normal, my system was running smoothly again.

 

I ran the McAfee Virtual Technician, and it said my products were fine. I also received an update today, so thinking all was fine, I turned Real Time Scanning on again, and the same thing happened. When I was able to get into McAfee's control panel again, I turned it off, and ran McAfee Virtual Technican again. This time it said I had 4 errors in my registry, all related to mcshield. Not sure why it didn't find it a few minutes ago, but whatever.

 

I tested it to see if I could recreate the problem, and I did. What is the problem here? I've used McAfee all last year with no problem, and just renewed my license for another year. I'm beginning to think this was a mistake. Is there a problem with mcshield, and how can I fix this?

  • k3tg Veteran 870 posts since
    May 22, 2007
    Currently Being Moderated
    1. May 16, 2010 1:05 PM (in response to JohninLA)
    Re: mcshield.exe using 100% cpu

    I suggest you contact Technical Support Chat and ask they remote into your computer to see whats going on. If they can't figure out what is going on then ask your case be escalated to the next level of support and get a case number and post it here on the forum for additional help.


    Tom K3TG

    Volunteer Moderator
  • graudieb Newcomer 3 posts since
    May 14, 2010
    Currently Being Moderated
    2. May 16, 2010 1:13 PM (in response to JohninLA)
    Re: mcshield.exe using 100% cpu

    My computer has been freezing repeatedly since the most recent version of mcafee. I can't find a version number but it has changed the security center to a new look.  I turned off real time scan and it seems to be working but at what cost to the security of my computer?

     

    Does anyone have a suggestion for an alternative to mcafee? I've tried Kaspersky previously and found it too secure. It would not allow  me to go to known websites.

  • k3tg Veteran 870 posts since
    May 22, 2007
    Currently Being Moderated
    3. May 16, 2010 1:52 PM (in response to graudieb)
    Re: mcshield.exe using 100% cpu

    Graudieb,

     

    I suggest you also open a service ticket with Technical Support Chat


    Tom K3TG

    Volunteer Moderator
  • kumar_B McAfeeSME 58 posts since
    Feb 24, 2010
    Currently Being Moderated
    4. May 17, 2010 5:25 AM (in response to graudieb)
    Re: mcshield.exe using 100% cpu

    Hi,

    Wat s the opertin systm u r usin > xp , vista or windows 7 .

    Do u hav any othr antivirus  like antispyware  ,  or spy search & destroy , spybot , spysweeper  or any other trojan hunter  or anti malware like malware bites or defender, or malware eraser in your computer . If so this might haped due to conflict between these programs and mcafee in the system . Inorder  to confirm that you dont have any other antivirus  go to > start > control panel >  add or remove for xp ( programs & features for vista ). open the list  where u can check for thesse traces . if you have you can remove it .

     

    SpywareBlaster or Spybot Search & Destroy is installed. SystemGuard is not compatible with some features of these products.

    Solution

    SpywareBlaster

    The slowdown of the VirusScan mcsysmon.exe process is caused by the SpywareBlaster Autoupdate that re-applies the protection settings. If this feature is disabled, the slowdown will not occur.

    Disable AutoUpdate feature:

    1. Launch SpywareBlaster.
    2. Select the Updates tab.
    3. Select the AutoUpdate tab.
    4. Click Click here for AutoUpdate!
    5. Select the Advanced tab.
    6. De-select the Always Verify and set Protection on Startup option.
    7. Save settings.
    8. Close SpywareBlaster.
    9. Restart the computer
    10. ----------------------------------------------
    11. SpywareBlaster AutoUpdate verifies and sets protection every time the computer is started if no newer updates are available. This behavior is not required (protection should remain between restarts), but has been put in place in case a malicious program tries to remove protection between restarts.

      Spybot Search & Destroy

      Spybot Search & Destroy has an Immunize feature which is causing McAfee SystemGuards to be consistently bombarded with changes, based on the system settings that are enabled.

      Disable the Immunize feature:

      1. Start Spybot in Advanced mode.
      2. Select the Settings tab.
      3. Click Settings.
      4. Navigate to the Program Start of Automation section.
      5. De-select the Immunize on program start if program has been updated option.
      6. Save settings.
      7. Close Spybot.
      8. Restart the computer.
      .

     

    Also if you want to remove spyware or spysearch can follow the steps below:

     

    you can go to start > computer (or my computer ) > open the c drive > program files > if you have the 3rd party  protection traces like spyware or malware remove it  .

    and then go to start > computer (or my computer ) > open the c drive > program files > comon files > evenhere if find any remove it .

    then go to start > run (or press Windows - R) > type %appdata% > if you want to remove 3rd partty traces u can remove it  from here .

     

     

    Message was edited by: kumaravel on 5/17/10 5:25:17 AM CDT
  • montrose1504 Newcomer 5 posts since
    Oct 31, 2009
    Currently Being Moderated
    5. May 22, 2010 6:47 AM (in response to JohninLA)
    Re: mcshield.exe using 100% cpu

    See my solution posted in message 100 of the following thread:  http://community.mcafee.com/thread/24530?start=90&tstart=0

  • graudieb Newcomer 3 posts since
    May 14, 2010
    Currently Being Moderated
    6. May 28, 2010 11:20 AM (in response to graudieb)
    Re: mcshield.exe using 100% cpu

    I was having the same problem after the most recent version change in my Mcafe software. I noticed that my computer worked fine if I turned off real time scanning. A non-fix. So I have been trying Eset Smart Security 4 for the last week. It is working fine so goodbye Mcafee.

  • DGPickett Newcomer 26 posts since
    Jun 4, 2009
    Currently Being Moderated
    8. Jul 15, 2010 7:20 PM (in response to JohninLA)
    Re: mcshield.exe using 100% cpu

    My flavor of this: Sometimes, when I hit the start button, the start menu half-draws, up to and including "Programs", and then locks there for maybe 12 minutes with mcshield sometimes going a bit over 50% = one cpu.  Usually, this in not convenient.  I have spybot, but that config box listed below was not checked.  I already divested myself of the other spywares when I came aboard with McAfee, which I bought to replace Norton, which locked even harder and more often, taking the whole machine not just Windows Explorer.

  • DGPickett Newcomer 26 posts since
    Jun 4, 2009
    Currently Being Moderated
    9. Jul 31, 2010 4:56 PM (in response to DGPickett)
    Re: mcshield.exe using 100% cpu

    I see no fix for this, and still my system locks up erratically as I attempt to use it.

     

    McAfee should fix this.

     

    It should go out as a normal update to everyone.

     

    We should never be asked if we think we have no malware, detecting that is McAfee's job!

     

    We should never be asked if we have a conflicting application, detecting that is also McAfee's job!

     

    It seems objious there are problems in the real time on demand scanner that should be addressed, even if it means putting a watchdog into the product to report on the problem.  A process using up every cycle the CPU can give for many minutes is something that they should be able to detect and send themselves reports on, so they can stop this.  It is beginning to motivate me to drop Windows for MAC or LINUX.  I got this sort of problem with Norton, too.  I dumped a load of other security products that McAfee said were problematic, although it should be able to tolerate them if it was soundly written.  This is so bogus, so peter principle.  The people that read these blogs apparently have no leverage on the people who might start fixing this, so they just message with boilerplate, cash their check and go home.  All th time I was writing this, the variable speed fan on my cpu was screaming, but now it stopped, so I better get my slice of PC before Mcafee takes it back.

1 2 Previous Next

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • Correct Answers - 5 points
  • Helpful Answers - 3 points