0 Replies Latest reply: May 10, 2010 6:28 PM by MilHoe RSS

    VirusScan Enterprise 8.5.0i Fails on Automatic Update, Ok with Manual Update

    MilHoe

      Hi all,

       

      I hope someone can help me with what has become a very frustrating experience. I am running VSE 8.5.0i on a Win2k SP2 box (hence not using VSE 8.7.0i), and all has been going smoothly until a couple of weeks ago, when my AutoUpdate logs started showing Update failures due to a corrupt gdeltaavv.ini file.At this point not even _manual_ updates from the console could get past the problem. I then searched these forums, where I found suggestions to

      (a) find and update some files called "frameworkservice.exe" and "updateui.exe" (??) but I was unable to locate these - where can they be found? ...       

      or

      (b) download and install the latest SuperDAT (5975 at the time).

       

      Option (b) seemed to do the trick, and I was again able to update both manually and automatically... for a few days. Now, I am only able to update manually again, with the same sort of gdeltaavv.ini errors as before. Very frustrating! To give you a taste, here is the relevant snippet from the Automatic (failing) and Manual (successful) AutoUpdate Log files:

       

      Automatic (failing)

      5/11/2010    3:36:17 AM    NT AUTHORITY\SYSTEM    Starting DAT update.
      5/11/2010    3:36:18 AM    NT AUTHORITY\SYSTEM    Downloading DAT.
      5/11/2010    3:36:18 AM    NT AUTHORITY\SYSTEM    Downloading gdeltaavv.ini.
      5/11/2010    3:36:20 AM    NT AUTHORITY\SYSTEM    File gdeltaavv.ini is corrupt. Downloading complete file again.
      5/11/2010    3:36:20 AM    NT AUTHORITY\SYSTEM    Error occurred while verifying gdeltaavv.ini.
      5/11/2010    3:36:20 AM    NT AUTHORITY\SYSTEM    Update failed to version 5978.0000.

       

      Manual (successful)

      5/11/2010    8:54:01 AM    DGVIMS-TOPLICA\Administrator    Starting DAT update.
      5/11/2010    8:54:02 AM    DGVIMS-TOPLICA\Administrator    Downloading DAT.
      5/11/2010    8:54:02 AM    DGVIMS-TOPLICA\Administrator    Downloading gdeltaavv.ini.
      5/11/2010    8:54:02 AM    DGVIMS-TOPLICA\Administrator    Downloading 59765977avv.gem.
      5/11/2010    8:54:02 AM    DGVIMS-TOPLICA\Administrator    Downloading 59775978avv.gem.
      5/11/2010    8:55:19 AM    DGVIMS-TOPLICA\Administrator    Backing up file(s) Engine DAT
      5/11/2010    8:55:27 AM    DGVIMS-TOPLICA\Administrator    Pre-notifying for DAT update.
      5/11/2010    8:55:27 AM    DGVIMS-TOPLICA\Administrator    Copying DAT.
      5/11/2010    8:55:39 AM    DGVIMS-TOPLICA\Administrator    Update succeeded to version 5978.0000.

       

      At first, I suspected that it was because the automatic updates were executing under "NT AUTHORITY\SYSTEM" while the manual ones under "DGVIMS-TOPLICA\Administrator", but I don't think this is the problem because what I've described above is _not_ a deterministic process.On some automatic updates the problem _may_ happen, but on others it won't. Weird.. Please help!

       

      Cheers,

      MilHoe