1 Reply Latest reply on May 10, 2010 10:55 AM by Thomashabs31

    Replication failure to FTP server.

      I am having problems with replication failing to my FTP server. Oddly enough the replications don't always fail, but recently they have been failing 8/10 times.

       

      Here is a copy of the point of failure durring the replication from my EvoApSrv.log. Its always failing on FramePkg.exe.

       

      20100510075920    I    #9988    SIM_InetMgr    Downloaded file Replica.log successfully in session 1, size=222, hash=07B9374BE7B1EF121A887C0C49870611EBF7FB3E
      20100510075920    I    #9988    SiteMgr     Incremental replication, file Current\EPOAGENT3000\Install\0409\FramePkg.exe size mismatch source: 5270109, dest: 5270075, forcing upload
      20100510075920    I    #11876    SiteMgr     ReplicationUploadFile: Uploading file FramePkg.exe to site FTP Server::Current\EPOAGENT3000\Install\0409, retry limit remaining: 5
      20100510075920    I    #11876    SIM_InetMgr    Uploading file FramePkg.exe from session 1, LocalDir=C:/PROGRA~1/McAfee/EPOLIC~1/DB\Software\Current\EPOAGENT3000\Install\0 409, RemoteDir=Current\EPOAGENT3000\Install\0409
      20100510075920    I    #11876    NaInet      FTP session 28 Uploading file: /VirusScanDats/Current/EPOAGENT3000/Install/0409/FramePkg.exe to FTP Server: ftp1.dcim.com
      20100510075923    E    #11876    naInet      FTP session 28 send on socket 6440 failed, WSAGetLastError = 10054
      20100510075923    I    #11876    SIM_InetMgr    Upload file FramePkg.exe failed in session 1, nainet ret=0
      20100510075923    I    #11876    SiteMgr     ReplicationUploadFile: Failed to upload file FramePkg.exe to site FTP Server::Current\EPOAGENT3000\Install\0409, hr=-2147467259, retry limit remaining: 4
      20100510075923    I    #11876    SiteMgr     ReplicationUploadFile: Uploading file FramePkg.exe to site FTP Server::Current\EPOAGENT3000\Install\0409, retry limit remaining: 4
      20100510075925    I    #11876    SIM_InetMgr    Uploading file FramePkg.exe from session 1, LocalDir=C:/PROGRA~1/McAfee/EPOLIC~1/DB\Software\Current\EPOAGENT3000\Install\0 409, RemoteDir=Current\EPOAGENT3000\Install\0409
      20100510075925    I    #11876    NaInet      FTP session 28 Uploading file: /VirusScanDats/Current/EPOAGENT3000/Install/0409/FramePkg.exe to FTP Server: ftp1.dcim.com
      20100510075925    I    #11876    naInet      FTP session 28 Reply data socket not empty before CMD
      20100510075925    I    #11876    naInet      FTP session 28 Flushing Receive CMD buffer, read: 226 Transfer complete.

       

      20100510075928    E    #11876    naInet      FTP session 28 send on socket 6516 failed, WSAGetLastError = 10054
      20100510075928    I    #11876    SIM_InetMgr    Upload file FramePkg.exe failed in session 1, nainet ret=0

       

      This did seem to start after I Checked In 8.7i into ePO, but the other repositories (non FTP) don't have any replication problems...

       

      Thank you for any help you can provide.

       

      Tom

       

       

      Message was edited by: Thomas Habermehl on 5/10/10 8:50:29 AM CDT
        • 1. Re: Replication failure to FTP server.

          I was able to solve this issue by copying all of the files in "<ePo directory>\DB\Software\Current\EPOAGENT3000\Install\0409" to my FTP server manually. When I copied just FramePkg.exe just by itself the replication still failed. Only when I coppied all of the files in the 0409 folder did the replication pass. Very odd, but hopefully this helps anybody else that may come across this issue.

           

          -Tom