3 Replies Latest reply on Apr 26, 2010 10:12 AM by jmcleish

    HTTP repository and vscan.bof - file not found

    jmcleish

      Hi,

      I setup two http repositories and set my machine to update from the repositories as a test. It updates the dats fine and my update repository task completes without error.

       

      However, when the new version of Buffer Overflow Dat came out ( v499), my machine couldn’t update from the http repo- coming up with the error:

       

      2010-04-18 17:07:06    E    #1156    ScrptExe     [Line 564:  RunScript dwRet = C:\ProgramData\McAfee\Common Framework\Current\BOCVSE__1000\BocDet_VSE.McS, ScriptMain]->
      2010-04-18 17:07:06    E    #1156    ScrptExe     [Executing section ScriptMain]->
      2010-04-18 17:07:06    E    #1156    ScrptExe     [CallIf]->
      2010-04-18 17:07:06    E    #1156    ScrptExe     [Executing section RunInstallScript]->
      2010-04-18 17:07:06    E    #1156    ScrptExe     [Line 299:  RunScript dwRet = C:\ProgramData\McAfee\Common Framework\Current\BOCVSE__1000\DAT\0000\BocInstall.mcs, ScriptMain]->
      2010-04-18 17:07:06    E    #1156    ScrptExe     [Executing section ScriptMain]->
      2010-04-18 17:07:06    E    #1156    ScrptExe     [Call]->
      2010-04-18 17:07:06    E    #1156    ScrptExe     [Executing section UpdateRuleFile]->
      2010-04-18 17:07:06    E    #1156    ScrptExe     [Call]->
      2010-04-18 17:07:06    E    #1156    ScrptExe     [Executing section UpdatePointProductRuleFile]->
      2010-04-18 17:07:06    E    #1156    ScrptExe     [GetFiles]->
      2010-04-18 17:07:06    E    #1156    ScrptUtl      Failed to download from repository
      2010-04-18 17:07:06    I    #1156    imsite        Download to: C:\ProgramData\McAfee\Common Framework\Current\BOCVSE__1000\DAT\0000\SiteStat.xml
      2010-04-18 17:07:06    I    #1156    imsite        Download from: (Distrib1) SiteStat.xml
      2010-04-18 17:07:06    I    #1156    naInet    Open URL: http://10.1.1.43:80/SiteStat.xml
      2010-04-18 17:07:06    I    #1156    naInet    Trying to download using libcurl
      2010-04-18 17:07:07    I    #1156    ScrptUtl    Setting Flag after file not found to restart update.
      2010-04-18 17:07:07    I    #1156    imsite        Download to: C:\ProgramData\McAfee\Common Framework\Current\BOCVSE__1000\DAT\0000\SiteStat.xml
      2010-04-18 17:07:07    I    #1156    imsite        Download from: (Distrib1) SiteStat.xml
      2010-04-18 17:07:07    I    #1156    naInet    Open URL: http://10.1.1.43:80/SiteStat.xml
      2010-04-18 17:07:07    I    #1156    naInet    Trying to download using libcurl
      2010-04-18 17:07:08    I    #1156    ScrptExe    Setting flag after file not found to restart update.
      2010-04-18 17:07:08    I    #1156    ScrptExe    Failed to get the files from the server.  Setting bOk to FALSE
      2010-04-18 17:07:08    I    #1156    ScrptMgr    Error occurred while downloading vscan.bof.
      2010-04-18 17:07:08    I    #1156    ScrptMgr    Update failed to version 499.

       

      I have checked the repository and the files are there- including the vscan.bof,
      However, when you browse to  my repository via  a browser something strange happens.


      If you browse to http://10.1.1.43/Current/BOCVSE__1000/DAT/0000/ you can click on all the files- all of them prompt you to save or open, except vscan.bof. it comes up with a 404 error- file not found. It exists in the directory and its setup for anonymous access – read and execute for top level dir.
      Even the web log says error 404:

       

      2010-04-17 16:29:02 W3SVC1 10.1.1.43 GET /Current/VSCANENG1000/Engine/0000/PkgCatalog.z - 80 - 10.31.1.65 - 200 0 0
      2010-04-17 16:29:03 W3SVC1 10.1.1.43 HEAD /SiteStat.xml - 80 - 10.31.1.65 - 200 0 0
      2010-04-17 16:29:03 W3SVC1 10.1.1.43 GET /Current/VSCANDAT1000/DAT/0000/PkgCatalog.z - 80 - 10.31.1.65 - 200 0 0
      2010-04-17 16:29:04 W3SVC1 10.1.1.43 HEAD /SiteStat.xml - 80 - 10.31.1.65 - 200 0 0
      2010-04-17 16:29:04 W3SVC1 10.1.1.43 GET /Current/BOCVSE__1000/DAT/0000/PkgCatalog.z - 80 - 10.31.1.65 - 200 0 0
      2010-04-17 16:29:06 W3SVC1 10.1.1.43 HEAD /SiteStat.xml - 80 - 10.31.1.65 - 200 0 0
      2010-04-17 16:29:06 W3SVC1 10.1.1.43 GET /Current/BOCVSE__1000/DAT/0000/BocInstall.mcs - 80 - 10.31.1.65 - 200 0 0
      2010-04-17 16:29:06 W3SVC1 10.1.1.43 HEAD /SiteStat.xml - 80 - 10.31.1.65 - 200 0 0
      2010-04-17 16:29:06 W3SVC1 10.1.1.43 GET /Current/BOCVSE__1000/DAT/0000/vscan.bof - 80 - 10.31.1.65 - 404 3 50
      2010-04-17 16:29:06 W3SVC1 10.1.1.43 GET /Current/BOCVSE__1000/DAT/0000/vscan.bof - 80 - 10.31.1.65 - 404 3 50

       


      However, when i change the repo back to use the ePO server to update, it did it fine:
      mscript.log
      2010-04-20 14:26:50    I    #5124    ScrptMgr    Product(s) running the latest DATs.
      2010-04-20 14:26:50    I    #5124    ScrptMgr    Setting the working dir as C:\ProgramData\McAfee\Common Framework\Current\VSCANDAT1000
      2010-04-20 14:26:50    I    #5124    ScrptMgr    Setting the working dir as C:\ProgramData\McAfee\Common Framework
      2010-04-20 14:26:50    I    #5124    ScrptMgr    Verifying BocDet_VSE.McS.
      2010-04-20 14:26:50    I    #5124    ScrptMgr    Setting the working dir as C:\ProgramData\McAfee\Common Framework\Current\BOCVSE__1000
      2010-04-20 14:26:50    I    #5124    ScrptMgr    Loading and parsing:  C:\ProgramData\McAfee\Common Framework\Current\BOCVSE__1000\BocDet_VSE.McS
      2010-04-20 14:26:51    I    #5124    ScrptMgr    Searching available updates for BOC DAT.
      2010-04-20 14:26:51    I    #5124    ScrptMgr    Downloading PkgCatalog.z.
      2010-04-20 14:26:51    I    #5124    imsite        Download to: C:\ProgramData\McAfee\Common Framework\Current\BOCVSE__1000\DAT\0000\PkgCatalog.z
      2010-04-20 14:26:51    I    #5124    imsite        Download from: (ePO_ISAV1) Current/BOCVSE__1000/DAT/0000/PkgCatalog.z
      2010-04-20 14:26:51    I    #5124    naInet    Open URL: http://10.1.1.173:<port#>/Software/Current/BOCVSE__1000/DAT/0000/PkgCatalog.z
      2010-04-20 14:26:51    I    #5124    naInet    Trying to download using libcurl
      2010-04-20 14:26:51    I    #5124    ScrptMgr    Verifying PkgCatalog.z.
      2010-04-20 14:26:51    I    #5124    ScrptMgr    Extracting PkgCatalog.z.
      2010-04-20 14:26:51    I    #5124    ScrptMgr    Loading update configuration from: PkgCatalog.xml
      2010-04-20 14:26:52    I    #5124    ScrptMgr    Setting the working dir as C:\ProgramData\McAfee\Common Framework\Current\BOCVSE__1000
      2010-04-20 14:26:52    I    #5124    ScrptUtl    Always use %%%%VariableName%%%% to dereference a variable.
      2010-04-20 14:26:52    I    #5124    ScrptUtl    Continuing in backward compatibility mode for syntax ….
      2010-04-20 14:26:52    I    #5124    ScrptMgr    Setting the working dir as C:\Program Files\McAfee\VirusScan Enterprise
      2010-04-20 14:26:52    I    #5124    ScrptExe    Running "C:\Program Files\McAfee\VirusScan Enterprise\EntVUtil.EXE" "C:\Program Files\McAfee\VirusScan Enterprise\vscan.bof"
      2010-04-20 14:26:52    I    #5124    ScrptExe    Did not match searched path
      2010-04-20 14:26:52    I    #5124    ScrptExe    Executing "C:\Program Files\McAfee\VirusScan Enterprise\EntVUtil.EXE" "C:\Program Files\McAfee\VirusScan Enterprise\vscan.bof"
      2010-04-20 14:26:52    I    #5124    imsite        Download to: C:\ProgramData\McAfee\Common Framework\Current\BOCVSE__1000\DAT\0000\BocInstall.mcs
      2010-04-20 14:26:52    I    #5124    imsite        Download from: (ePO_ISAV1) Current/BOCVSE__1000/DAT/0000/BocInstall.mcs
      2010-04-20 14:26:52    I    #5124    naInet    Open URL: http://10.1.1.173:<port#>/Software/Current/BOCVSE__1000/DAT/0000/BocInstall.mcs
      2010-04-20 14:26:52    I    #5124    naInet    Trying to download using libcurl
      2010-04-20 14:26:52    I    #5124    ScrptMgr    Starting BOC DAT update.
      2010-04-20 14:26:52    I    #5124    ScrptMgr    Setting the working dir as C:\ProgramData\McAfee\Common Framework\Current\BOCVSE__1000\DAT\0000
      2010-04-20 14:26:52    I    #5124    ScrptMgr    Loading and parsing:  C:\ProgramData\McAfee\Common Framework\Current\BOCVSE__1000\DAT\0000\BocInstall.mcs
      2010-04-20 14:26:52    I    #5124    ScrptMgr    Downloading vscan.bof.
      2010-04-20 14:26:52    I    #5124    imsite        Download to: C:\Program Files\McAfee\VirusScan Enterprise\vscan.bof
      2010-04-20 14:26:52    I    #5124    imsite        Download from: (ePO_ISAV1) Current/BOCVSE__1000/DAT/0000/vscan.bof
      2010-04-20 14:26:52    I    #5124    naInet    Open URL: http://10.1.1.173:<port#>/Software/Current/BOCVSE__1000/DAT/0000/vscan.bof
      2010-04-20 14:26:52    I    #5124    naInet    Trying to download using libcurl
      2010-04-20 14:26:52    I    #5124    ScrptMgr    Setting the working dir as C:\Program Files\McAfee\VirusScan Enterprise
      2010-04-20 14:26:52    I    #5124    ScrptExe    Running "C:\Program Files\McAfee\VirusScan Enterprise\EntVUtil.EXE" "C:\Program Files\McAfee\VirusScan Enterprise\vscan.bof"
      2010-04-20 14:26:52    I    #5124    ScrptExe    Did not match searched path
      2010-04-20 14:26:52    I    #5124    ScrptExe    Executing "C:\Program Files\McAfee\VirusScan Enterprise\EntVUtil.EXE" "C:\Program Files\McAfee\VirusScan Enterprise\vscan.bof"
      2010-04-20 14:26:52    I    #5124    ScrptMgr    Setting the working dir as C:\Program Files\McAfee\VirusScan Enterprise
      2010-04-20 14:26:52    I    #5124    ScrptExe    Running "C:\Program Files\McAfee\VirusScan Enterprise\EntVUtil.EXE"
      2010-04-20 14:26:52    I    #5124    ScrptExe    Did not match searched path
      2010-04-20 14:26:52    I    #5124    ScrptExe    Executing "C:\Program Files\McAfee\VirusScan Enterprise\EntVUtil.EXE"
      2010-04-20 14:26:52    I    #5124    ScrptMgr    Update succeeded to version 499.

       

      Does anyone know what could be the problem at all? I don't want to enable the repositories for anyone else until i can be sure that all is working ok, and I can't really test that until another bof dat comes out.
      I still think its strange that it says file not found though.

       

      (port# has been edited)

       

      Thanks

      Jane