5 Replies Latest reply on Apr 28, 2010 11:03 AM by fab5friend

    The 5958 issue, cannot copy any files. How can I use the fix???

      In Safe Mode there is no task bar and the Start-key on the keybord doesn't work either. Because I cannot access files the normal way I used ctrl-alt-del to start the task manager and then used the Run-command to type E: so that I can at least see the files on the usb where I have put the SDAT5958_EM.exe file. But I cannot copy the file to the desktop as suggested in the "helpful" support documents. Tried using the menu copy/paste commands, tried ctrl c/ctrl v on keyboard. Nothing works. I am not a programmer, can someone please help me out?

      1) Is there another way to copy? Using the Run-command window somehow?

      2) Or can I run the fixfile from the usb?

       

      Desperate, please help, support does not answer!

        • 1. Re: The 5958 issue, cannot copy any files. How can I use the fix???

          Hi,

          I had the same problem. What I had to do for my home version of virus scan) was:

          Delete the DAT folder from c:\program files\mcafee\virusscan

           

          Copy the file svchost.exe from a working computer (easiest way for me as the %systemroot%..... etc  copying method didnt work) - from directory c:\windows\system32. By the way, copy it to the root directory of a usb drive/pen drive, for simplicity.

           

          Stick the pen drive in the affected computer and note the drive letter it is assigned. Reboot into safe mode with command prompt (F8 at startup). Am assuming you're familiar with this.

           

          I had forgotten a lot of DOS but finally hit on....

           

          At the command prompt make sure you're in the root directory of the c drive (i.e. if you're not, type "cd c:\"     (without the inverted commas). You should then end up with the prompt c:\>

          Check the drive letter assigned to the usb drive you stuck in earlier. e.g. If the drive letter was "E" when you previously inserted it, start with that, it should be the same now that you're in safe mode/command prompt. check it by typing cd e:\

          If you get the prompt changing to e:\> then it IS the e drive letter.

          So change back to c:\>  (type cd c:\)

          Then type "copy e:\svchost.exe c:\windows\system32\svchost.exe"     without the inverted commas. Note the spaces.

          If it has been done correctly you should get a message saying 1 file copied.

          Let me know if you get that far. After this, I was able to reboot windows normally, my wifi came back and I was able to startup visuscan and do a normal update of the dat file.

          The most frustrating part is that the McAfee website fix asks you to restore a file suing the dllcache, but that didn't work for me and copying files via copy/paste doesnt work on the affected computer, thats why I had to do it via DOS commands from a safe mode command prompt.

          • 2. Re: The 5958 issue, cannot copy any files. How can I use the fix???

            I had the same issue with not being able to copy the file from USB stick to my desktop.

             

            In the end my 11 year old son suggested burning the file to a CD (on another PC that we'd used to download the file onto a USB stick) and we were able to run the program from the CD drive on the affected PC.

             

            Slightly embarrassed - but relieved!

            • 3. Re: The 5958 issue, cannot copy any files. How can I use the fix???

              Your answer got me into business again! Thank you so very much for your effort to write it all down, making me as a novice able to fix it on my own :-))))

              • 4. Re: The 5958 issue, cannot copy any files. How can I use the fix???

                What can you do if your PC won't let you boot into safe mode?  All I get after hitting F8 and telling it to boot into safe mode (as well as with networking and command modes) is a black screen after it loads a few files (I've let it sit for a day and it never goes beyond the black screen).  Can you help, since McAfee has failed to do so?

                 

                McAfee, if you're reading this, your customer service is lousy!

                • 5. Re: The 5958 issue, cannot copy any files. How can I use the fix???

                  John Black - Thank you very much on your %systemroot% solution to copy the svchost file from another computer!  I did finally get it to copy to my affected computer.  Unfortunately I still can not get my PC to boot. So does anyone have any other ideas?

                   

                  Mcafee customer service is a joke.  Last night I wore the battery down on my home phone just on hold.  I never did get to speak to anyone.  This morning I get to the office and am on hold for almost an hour before I get to speak to someone who barely speaks English.  I told him I had gone through all the steps on the bulletins that Mcafee had on their website.  What does he do? He has me do them again with the same result. He is obviously reading from a script. He had me search for the svchost file of which there is only one copy on my PC. And yet he kept had me doing a copy from the servicepackfiles folder even though I had no such folder on my PC. I kept telling him the message that the file was not found but he insisted on me doing it over and over. If it doesn't suceed once, a 2nd and 3rd time will do the trick, right?

                   

                  I have a Dell Inpiron mini with no CD drive so no way to reload Windows.