4 Replies Latest reply on Apr 24, 2010 9:31 AM by MoxieMomma

    Losing internet connection when My desktop goes to sleep

      Whenever I bring my desktop out of sleep mode, I am disconnected from the internet.  Ieither have to turn offturn on my router, or rest my LAN network adapter.  My laptop has no issues and is on the same router.  My desktop is connected to my router through an ethernet cable

       

      I have Windows Vista

       


      Any help would be greatly appreciated!

        • 1. Re: Losing internet connection when My desktop goes to sleep
          k3tg

          Can you try to change the setting of your desktop so that it does not go to sleep and see if this issue still persists? I understand that you want it to go to sleep and that is ok, but if we can identify it by the process of elimination that is what we should consider doing initially. It may not be a McAfee related issue but we don't know that as of yet.

           

          Thank You

          Tom

          • 2. Re: Losing internet connection when My desktop goes to sleep

            Hi, Andrewr:

             

            This is a known (though only marginally acknowledged) issue with Vista and W7 power management that is unrelated to McAfee.

            I've experienced it with both my Vista Ult SP2 (32) and my W7 Ult (64) systems "right out of the box".

             

            TMALSS, as best I understand it, the OS cuts power to both USB devices and ethernet ports when it goes to sleep and/or hibernate.

            For me, the major issue was cutting power to the USB ports, since that broke the communication with my UPS/battary backup.

            So, if a power outage were to occur when the computer was asleep, the UPS software would be unable to perform a managed shutdown, since the UPS and the computer would be "disconnected".

            Moreover, some scheduled tasks, including McAfee scheduled scans, don't run when the computer is asleep (*some* 3rd-party apps can be configured to "wake the computer from sleep" to perform their tasks).

             

            There are many, many threads on this at the MS and SevenForums and VistaForums and other places (www.bleepingcomputer.com, etc).

            It's all VERY confusing for a computer moron such as myself, with "sleep"/"hybrid sleep"/"hibernation" and all the various levels of settings that can be changed.

            There are many, many proposed solutions and workarounds, most/all of which involve changing the (advanced) power settings and sometimes the sleep settings in the BIOS.

            Others involve editing the registry and fixes I'm just not willing to try.

            Overall, they do seem to work better to maintain the ETHERNET connection than the USB port power: IOW I think this is more easily fixed by tweaking the settings in the device manager/power settings than is the issue with the USB ports.

            But, I've never found any of them entirely satisfactory.

             

            The only "solution" that works for me on both the Vista and W7 systems is to create a "custom" power plan that "never" puts the computer to sleep.

            So, I have my screensaver set to come on at 10 minutes, and then the display to turn off at 30 minutes, but the computer is never put to sleep.

            This is not ideal from the standpoint of power consumption, but it does maintain connection to the ethernet port and to the USB ports.

             

            Perhaps someone with some actual computer expertise will weigh in on this here, or perhaps there will be a definitive fix with the next SP for Vista or W7.

             

            Anyway, I don't think this is a McAfee problem, per se (although I suppose it *could* have something to do with your networking settings?).

             

            Sorry this isn't more helpful,

             

            MM

            • 3. Re: Losing internet connection when My desktop goes to sleep

              This does not occur when I do not put my computer to sleep.

               

              Thanks for the reply!

              • 4. Re: Losing internet connection when My desktop goes to sleep

                @Andrewr:

                 

                Exactly!

                It's a "SLEEP" issue with Vista and W7 (I don't remember ever having this issue with XP, using the same router, etc).

                 

                There are many "bugs" with power/sleep/ReadyBoot/etc with both versions of the Windows OS.

                Just visit the many forums to see.

                Having dealt with this for nearly 2 years, I've found that there's no 1 single fix that works on every system.

                 

                Setting a power plan that never puts the computer (HDD) to sleep has been the easiest, most successful solution for me.

                 

                Well, that's the limit of my limited expertise and my humble suggestion from the "been there, experienced that" school!

                 

                MM