1 2 Previous Next 16 Replies Latest reply on Apr 16, 2010 1:39 AM by serc09

    Create msi-package for MA & VSE

    serc09

      Hey,

       

      we are using epo 4.5 (patch1) and i need to create a msi-package which includes MA (4.0.0.1494) and VSE (8.7.0.570.Wrk).

       

      How can i create such a msi-package? I've never done this before.

       

      Hope someone can help me.

       

      THX

       

      Regards

       

      serc09

        • 1. Re: Create msi-package for MA & VSE
          JoeBidgood

          I doubt this will be possible... both the VSE and MA installers are MSI packages, and the installer won't let you run two packages at once (which is why you can't embed an agent package in a VSE install using the installation designer.)

           

          Sorry

           

          Regards -

           

          Joe

          • 2. Re: Create msi-package for MA & VSE
            serc09

            OK, and where do i find those 2 msi packages?

             

            Regards,

             

            serc09

            • 3. Re: Create msi-package for MA & VSE
              Sailendra Pamidi

              Once you download the zip files for MA & VSE from the McAfee downloads page, you can extract them to get the MSI packages.

              • 4. Re: Create msi-package for MA & VSE
                serc09

                Hah, that sounds way too easy to be true - i'll check that in office tomorrow...  

                 

                THX

                 

                serc09

                • 5. Re: Create msi-package for MA & VSE
                  serc09

                  Hey,

                   

                  there are msi files in the zip-packages, but i can't just take these msi files and install them on a client - see the error messages attached.

                   

                  Then i tried something:

                   

                  I connected to "\\<eposerver>\McAfee\ePolicy Orchestrator\DB\Software\Current\EPOAGENT3000\Install\0409" and doubleclicked the msi there - worked all fine.

                  But if i just take out the msi from that folder, i again get the error msg attached.

                   

                  ------------

                   

                  Let me explain you the reason why i need the msi packages:

                   

                  Our company perhaps want's to have a new AV-Solution (Avira) and i have do the tests....

                  Avira-Support told me thay they can provide us mit automatic de-installation-scripts for our actuall AV-Solution, but therefore they need to have the msi packages.

                   

                  Hope you can now help me better/more if you understand what i want to do.

                   

                  regards

                   

                  serc09

                  • 6. Re: Create msi-package for MA & VSE
                    serc09

                    serc09 schrieb:

                     

                    ....

                    I connected to "\\<eposerver>\McAfee\ePolicy Orchestrator\DB\Software\Current\EPOAGENT3000\Install\0409" and doubleclicked the msi there - worked all fine.

                    .....

                     

                    Well, i'm not longer quite sure if it worked all fine.

                     

                    I don't get to see the McAfee tray icon - i rebooted the client several times - no tray icon.

                     

                    Under "processes" in the taskmanage i see "McTray.exe" and the "FrameworkService.exe" running.

                     

                    How can i make the tray icon show up, or the client reporting back to the epo-Server?!

                     

                    The client is a vmware virtual machine with XP (just for tests like this) - i login on the machive by RDP ( "<client> /admin" for the adminsession).

                    • 7. Re: Create msi-package for MA & VSE
                      Sailendra Pamidi

                      Hi,

                      Check if you can open the agent status monitor from Program Files\McAfee\Common Framework\cmdagent.exe /s

                       

                      If you can open it, click on Collect and Send properties to initiate communication to ePO.

                       

                      Check if the agent policy is set to display the agent tray icon.

                       

                      HTH,
                      Sailendra

                      • 8. Re: Create msi-package for MA & VSE
                        serc09

                        I could open the agent status monitor but it fails to collect properties or to send - see attached file.

                         

                        serc09

                        • 9. Re: Create msi-package for MA & VSE
                          Sailendra Pamidi

                          Its most likely that the agent does not have the proper info to communicate with the ePO server. This is usually gathered from the SPIPE site entry in Sitelist.xml.

                           

                          You can attempt installing the agent by using the Framepkg.exe from the DB\Software\Current\EPOAGENT3000\Install\0409 folder on to the target system using a command line like:

                          Framepkg.exe /install=agent

                           

                          Check the Agent_<machine>.log in the Agent Data folder (Documents and Settings\All Users\Application Data\McAfee\Common Framework) to see if things are working fine after the install.

                          1 2 Previous Next