1 2 Previous Next 10 Replies Latest reply on Apr 1, 2010 7:37 PM by zhangcr

    webwasher 1100B Application upgrade issues

           I use the web management interface to upgrade the application version, than the upgrade is completed.However, can not use the web login again.I Scan the open port that use the port scanning tool, found that only  22,25,110 three ports were open, how to resolve this issues ?

        • 1. Re: webwasher 1100B Application upgrade issues

          It would also help if I answered the question you posed. It sounds to me like the service isn't enabled. Login via SSH as root and check the for the service:

           

          [root@mwg68-m ~]# lsof -i +M
          COMMAND   PID    USER   FD   TYPE  DEVICE SIZE NODE NAME
          sshd     1201    root    4u  IPv4    1941       TCP mwg68-m:ssh (LISTEN)
          ntpd     1228    ntpd    3u  IPv4  599772       UDP mwg68-m:50407->ntp1.housing.berkeley.edu:ntp
          ntpd     1228    ntpd    5u  IPv4 1192424       UDP mwg68-m:36970->bindcat.fhsu.edu:ntp
          ntpd     1228    ntpd    6u  IPv4 1203989       UDP mwg68-m:50775->time.nist.gov:ntp
          ntpd     1228    ntpd    7u  IPv4  899580       UDP mwg68-m:40191->ntp1.rescomp.berkeley.edu:ntp
          wwcsm    2912 wwasher  125u  IPv4    5510       TCP mwg68-m:9090 (LISTEN)
          wwcsm    2912 wwasher  126u  IPv4    5511       TCP mwg68-m:webcache (LISTEN)
          wwcsm    2912 wwasher  127u  IPv4    5515       TCP mwg68-m:9093 (LISTEN)

           

          or

           

          [root@mwg68-m ~]# ps ax | grep wwasher | grep -v grep
          2917 ?        Ss     0:00 /usr/bin/ruby /opt/webwasher-csm/bin/wwfbd -u wwasher
          2918 ?        S      0:00 /usr/bin/ruby /opt/webwasher-csm/bin/wwfbd -u wwasher

           

          If the service isn't running you will need to start it:

          [root@mwg68-m ~]# service webwasher-csm start | stop | restart

           

          The info below may not be what you need but I will keep it here for general knowledge.

           

          I am guessing you have Web Gateway dual homed? If so you can change the daemons from listening on the outside interface:

           

          1) For TCP/22 (SSH) you need to login as root on the appliance and manually vi a file.

           

          Force to listen only on internal interface.

          Login in as root over SSH or direct console

          vi /etc/ssh/sshd_config

          find the line:

          #ListenAddress 0.0.0.0

           

          And change it to:

          ListenAddress 192.168.254.14

           

          Where 192.168.254.14 is my internal IP address and the IP I use to manage my Web Gateway.

          Disable SSHv1

          Find the line:

          #Protocol 2,1

          and change it to:

          Protocol 2

          Save the file and close it

           

          The other two ports are mail ports and carryovers from the time when WebWasher supported email. You likely do not want them or need them so disable email alltogether.

           

          First, make sure email related settings are enabled in the GUI. This will allow you to enable them, then disable the service, then disable the related settings again so you don't see them in the GUI.

           

          To temorarily enable email seettings go to Home --> Preferences and enable "View mail related settings"

           

          3-30-2010 6-30-09 AM.png

           

          Next browse to Proxies --> Email Gateway and uncheck the email gateway checkbox which disables any email functions globally.

           

          3-30-2010 6-34-55 AM.png

           

          Finally go back to Home --> Preferences and disable the "View mail related settings" if you don't want them to appear in the GUI.

           

           

           

          Message was edited by: Jay Gregg on 3/30/10 6:46:18 AM CDT
          • 2. Re: webwasher 1100B Application upgrade issues

            Thank you for your support,Your information is very important to me. But I need to login the system first, and i don't know the default password of root.I have tried to use the MAC address 8-bit login, but failed,Please tell me the password,THX.

            • 3. Re: webwasher 1100B Application upgrade issues
              asabban

              Hi,

               

              if the box has been freshly installed the root password is the last 8 digits of the MAC address of eth0, all in capital, no colons or dashes.

              If you are installing on VMWare you may try to use "00000000" (without the quotes).

               

              Please note that SSH login may be disabled by default, which means only a local console access with Monitor/Keyboard or serial line may be possible, bevore SSH is configured correctly.

               

              If all of the above fail then I don't think that the password can be recovered. In this case it must be reset, by either re-imaging the box or filing a ticket with support.

               

              Best,

              Andre

              • 4. Re: webwasher 1100B Application upgrade issues

                I have tried using the following command to start the service, but this error occurred, is not applied to upgrade fails, resulting in the database inconsistency? What should I do?

                 

                _______________________________________________________________________

                 

                [root@wwapp ~]# service webwasher-csm start

                Starting feedback daemon: done.

                Starting memdefrag daemon: done.

                Starting McAfee Web Gateway:

                Preparing persistent data...

                Datebase inconsistent.Start fresh database... . failed.

                [root@wwapp ~]#

                • 5. Re: webwasher 1100B Application upgrade issues

                  Why did the China have not support the service? I am so disappointed

                  • 6. Re: webwasher 1100B Application upgrade issues
                    asabban

                    Hello,

                     

                    this looks like there are some problems with the Cache database. I would try to re-create the Cache Database:

                     

                    - Stop MWG with /etc/init.d/webwasher-csm stop

                     

                    - Modify global.conf file:

                     

                      - Find the Parameter "CacheSize="

                      - Set "CacheSize=" to "-1"

                      - Result: "CacheSize=-1"

                     

                    - Start MWG with /etc/init.d/webwasher-csm start

                    • 7. Re: webwasher 1100B Application upgrade issues

                      Tomorrow I will try your method , And I hope the problem could  be solved.  It is now 23:45  Beijing Time Zone.thank you very much!

                      • 8. Re: webwasher 1100B Application upgrade issues

                             Help me,please!

                             I have tried to do as described above, but the problem still exists!  Do you have any other alternatives? Reset the system and application programs can solve the problem?

                        • 9. Re: webwasher 1100B Application upgrade issues
                          Jon Scholten

                          Hello zhangcr,

                           

                          If you are having many troubles, I would suggest opening a support case, this can be done at https://mysupport.mcafee.com/Eservice/Default.aspx, you must create an account to do so.

                           

                          ~Jon

                          1 2 Previous Next