1 2 Previous Next 14 Replies Latest reply on Aug 27, 2010 9:59 AM by peter_eepc

    EEPC v6 Killed Windows XP

      Hi,

       

      I've been trialing McAfee Endpoint Encryption for the past few days. After having some initial trouble installing ePO v4.5, and getting hold of McAfee Agent v4.5, I've finally been able to deploy EEPC v6 to a client machine. I followed http://community.mcafee.com/blogs/danlarson/2009/11/30/unofficial-quickstart-gui de-for-mcafee-eepc-v6 and the deployment seemed to go OK. I setup the policies, then deployed Endpoint Encryption Agent for Windows 1.x followed by Endpoint Encryption for PC 6.x. The deployment happened, and the agent asked to reboot. Once rebooted, I logged back into Windows, and the Endpoint Encryption status showed as inactive, watching the McAfee Agent status I watched it pull down the policy settings, and the Endpoint Encryption status switched to active, and encryption began. So, to test every scenario, and knowing users would do this, I decided to reboot again, part way through the drive encryption - something EEPC should support, as it had no problem with this when it was SafeBoot. After rebooting, I got the pre-boot McAfee screen, asking me to login, which I did, and was then asked to set my 3 recovery questions, which I did. Windows then began to load, I had the Windows XP boot screen, with the little loading bar, then it flicked away just as it does before presenting the Window GUI screen, but that never loaded, instead I just have a blank screen, nothing is happening. I've rebooted, and can boot into Windows Safe Mode, which seems to work OK. However, when I reboot again, and try to load Windows proper, I just get this blank screen.

       

      Anyone have any idea whats happened?

       

      I'm running Windows XP, SP3 on an IBM Thinkpad T42, 2gb RAM, 120gb hard drive.

      Any help would be much appreciated!

       

      Ben

        • 1. Re: EEPC v6 Killed Windows XP

          Is your disk partitioning any special, any recovery partitions present?

          Did you check if your hard disk was healthy (full surface scan) prior to encryption? No, then verify it now. Boot from WinPE CD and use some utilities to perform full disk surface scan.

          • 2. Re: EEPC v6 Killed Windows XP

            Hi Peter,

             

            Thanks for the reply again.

             

            I ran a full chkdsk (the one where it reboots and checks before starting Windows) before installing EEPC and every thing seemed OK, no errors returned.

             

            These IBM laptops do have a 4gb FAT32 partition at the end of the drive, where they hold IBM service tools (diagnostic programs & a Windows image for reinstalling). Could it be this partition thats causing the problem? I didn't think EEPC had any issues with multiple partitions!

             

            Ben

            • 3. Re: EEPC v6 Killed Windows XP

              IBM Rapid Recovery or Pre-Desktop might be very likely to be incompatible with EEPC.

              • 4. Can't Get EEPC to Encrypt

                Hi,

                 

                I formatted the laptop, and redeployed EEPC, but now it just won't encrypt the drive. I've gone through the unofficial blog on how to deploy line by line, added users to the system, everything, but EEPC just sits in an inactive state, saying 'no volume information'. I've clicked 'check new policies', 'enforce policies', 'collect and send props'. The McAfee agent says the ASCI event has started, but nothing happens.

                 

                Any ideas?

                 

                THanks

                 

                Ben

                • 5. Re: Can't Get EEPC to Encrypt

                  Enable EEPC agent log and use it for troubleshooting.

                  • 6. Re: Can't Get EEPC to Encrypt

                    Hi Peter,

                     

                    Have enabled, and attached the log. I can't see any error messages in the log, but its very difficult to make sense of! Could you have a look through and see if you can see any problems?

                     

                    Many thanks

                     

                    Ben

                    • 7. Re: Can't Get EEPC to Encrypt

                      This sample is too small. Please go through whole ASCI and Policy updates process while log is on.

                       

                      You can use Simon's log reader to at least make reading easier.

                      http://simonhunt.wordpress.com/2010/02/17/epe-log-reader-for-mcafee-endpoint-enc ryption-v6/

                       

                       

                      Message was edited by: peter_eepc on 3/4/10 11:12:38 AM EST
                      • 8. Re: Can't Get EEPC to Encrypt

                        Im having same trouble with IBM Thinkpads T60p, i think there is something on the boot partition..

                        • 9. Re: Can't Get EEPC to Encrypt

                          Peter,

                           

                          I finally got EEPC to begin encrypting, seemed to just start working not long after I posted the log file. Again, I rebooted, and Windows would not load. This was a clean Windows install, with no other software, after performing a full disk scan.

                           

                          Again, I have wiped the drive, this time also removing the 4gb IBM partition, started the Windows install, and used the entire vloume, formatted as NTFS, and installed WinXP SP3. Once it was installed, I pushed out the McAfee agent, and EEPC agents, this time with out issue. The agents asked to reboot, after which encryption began within a few minutes. However, after encryption had reached 3 bars, I decided to perform a test reboot, and once again, I login to EEPC pre-boot, Windows tried to load, with the XP logo, and status bar, then it flicks away as if to bring up the XP GUI, but nothing happens, its just a completely blank screen! Again, I can login to Safe mode OK, so it seems to be normal Windows mode that fails. I have also tried 'last known good configuration' which fails with the blank screen.

                           

                          So, I don't think its a hard disk issue, having done a full disk scan. I also don't think its an IBM partition issue, as this has now been wiped, and the drive partitioned into 1 NTFS volume.

                           

                          As Windows boots fine with the McAfee & EEPC agents installed, but before the encryption has begun, I can only assume that something in the encryption process is stopping Windows from loading correctly!

                           

                          Not sure how to diagnose this issue further! Any help/suggestions would be appreciated!

                           

                          Ben

                           

                           

                          on 04/03/10 12:25:34 CST
                          1 2 Previous Next