8 Replies Latest reply on Feb 3, 2010 4:48 AM by JoeBidgood

    McAfee EPO services problems

      Hi all,

       

      Since a few days, i have some issues with the event parser service and server service.

      When i reboot the server, the services won't start.

      I added a screenshot with the error messages when trying to start the services.

      Does anyone know how to solve this problem?

       

      Thx a lot!

        • 1. Re: McAfee EPO services problems
          JoeBidgood

          This would imply that the ePO server (which is apache) is not able to start... check the system and application event logs. At a guess, I'd say a possible port conflict - it's one of the most common causes of apache failing to start.

           

          Regards -

           

          Joe

          • 2. Re: McAfee EPO services problems

            Joe,

             

            In the eventlog i have this errors:

             

            Event ID 3299:

            The Apache service named  reported the following error:
            >>> [Mon Feb 01 16:11:28 2010] [notice] Disabled use of AcceptEx() WinSock2 API     .


            -----------------

             

            The Apache service named  reported the following error:
            >>> (OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted.  : make_sock: could not bind to address 0.0.0.0:443     .
            -------------

             

            The Apache service named  reported the following error:
            >>> no listening sockets available, shutting down  


            ----------------

            The Apache service named  reported the following error:
            >>> Unable to open logs     .

            • 3. Re: McAfee EPO services problems
              JoeBidgood

              Yep, that's it. Something else on the server is listening on port 443, so Apache is unable to - and so cannot start.

               

              You will need to either identify the other software that is listening on 443 and either disable it, or change the port it listens on, or stop apache from trying to listen on 443 which means disabling the use of the agent-to-server secure port. If you want to use the last option let me know and I can provide instructions.

               

              Regards -

               

              Joe

              • 4. Re: McAfee EPO services problems

                Hi Joe,

                 

                Thanks for your answer.

                But how can I find which application is using this port? (Im very new to this)

                Are there any tools for?

                 

                Thanks

                • 5. Re: McAfee EPO services problems
                  JoeBidgood

                  The easiest way is probably to make sure that all three ePO services are stopped, then run

                   

                  netstat -abn

                   

                  in a command window: that will tell you which app is listening on which port(s).

                   

                  Regards -

                   

                  Joe

                  • 6. Re: McAfee EPO services problems

                    Joe,

                     

                    I have nothing that is listening on port 443.

                     

                    I see only this on with 443 in it:
                      TCP    10.100.1.102:1973      10.100.4.5:443         ESTABLISHED     1620
                      [mxdomainmgr.exe]

                    • 7. Re: McAfee EPO services problems

                      Joe,

                       

                      I've found something on the net about IIS.

                      I stopped all the IIS sites and know I was able to start the 2 epo services.

                      The only problem now is that I cant start the IIS sites anymore

                      • 8. Re: McAfee EPO services problems
                        JoeBidgood

                        That would make sense - you can only have one thing listening to a port at any one time - so it's either ePO or IIS, but not both.

                         

                        I think the easiest option for you would be to stop ePO from listening on 443, which means turning off the agent-to-server secure port (or changing it to a new value) in the Ports page of the Server Configuration section.

                         

                        Regards -

                         

                        Joe