1 2 Previous Next 14 Replies Latest reply on Feb 2, 2010 5:50 AM by earthcadet

    ePo 4.0 Updating Master Repository

    earthcadet

      Hi Guys,

       

      I am having a bit of a problem with updating the master repository. I have been trying to sort this problem out for a while now and tried several things such as changing source sites and protocols but nothing has worked so far.

       

      The Problem:

       

      On the dash, ePo reports that my current DAT version is 5686.0000 and the latest version is 5878.0000. Each time I try to update the master repository either through HTTP or FTP I receive a failed notification with an error that says :

       

      Started: Pulling content from McAfeeHttp to Current branch 
      Pull from site McAfeeHttp complete, 0 warnings, 1 errors 
      Checking in package Current\VSCANDAT1000\5878.0000\DAT\0000 
      Checking in package Current\VSCANDAT1000\5878.0000\DAT\0000 failed 
      Failed: Update Master Repository (Failed to delete file) 

       

      My Source site address for HTTP is :

       

      http://update.nai.com/products/commonupdater

       

      Any help or pointing into the rigth direction would be most helpful.

       

      Thank you.

       

      EarthCadet

        • 1. Re: ePo 4.0 Updating Master Repository
          JoeBidgood

          Do another pull task, and then check the epoapsrv.log on the ePO server - this is where information about pull tasks is located. If you like, zip the log and post it here and we can have a look.

           

          Regards -

           

          Joe

          1 of 1 people found this helpful
          • 2. Re: ePo 4.0 Updating Master Repository
            earthcadet

            Hi Joe,

             

            Thank you for your reply. I have attached the log file for you to have a look. I have noticed today also that it manages to successfully update at random, so it reports in the Task Log, but the version of the DAT file still remains the same.

             

            I have had a look at the log file and it could be relating to this perhaps?

             

            RemovePkgThreadProc: Delete file datdet.mcs from site ePO_XXX-AV-01::Current\VSCANDAT1000 failed, hr=

             

            The datdet.mcs does not exist for some reason although it does for the engine file.

             

            Thank you for any help you can provide me.

             

            EarthCadet

            • 3. Re: ePo 4.0 Updating Master Repository
              JoeBidgood

              It certainly could be related to this, yes. It looks like it's failing because a couple of files that it's expecting are missing.

               

              Try this:

               

              1) Go into the master repo window in ePO

              2) Delete any DAT and engine packages

              3) Assuming this completes without error, try the pull task again

               

              Regards -

               

              Joe

              • 4. Re: ePo 4.0 Updating Master Repository
                earthcadet

                I have managed to delete the Engine package but when I try to delete the DAT package nothing happens. It simply refreshes the window and it stays there. I had a look in all the reporting windows and logs but there are no errors that I could give you.

                 

                Thanks.

                 

                EarthCadet

                • 5. Re: ePo 4.0 Updating Master Repository
                  JoeBidgood

                  Hm. Annoying

                   

                  After trying to delete the dat package, do you get any errors in the epoapsrv.log? Possibly the same "unable to delete" ones as before?

                   

                  Thanks -

                   

                  Joe

                  • 6. Re: ePo 4.0 Updating Master Repository
                    earthcadet

                    Ah yes, there is. I must have ignored it last time I checked. It looks like this is the error that comes with it.

                     

                    20100201160735    I    #336    SiteMgr    RemovePkgThreadProc: Remove package thread started
                    20100201160735    I    #336    SiteMgr    SetSiteStatus: m_bstrSiteCatalogVersion is empty(2)
                    20100201160735    I    #336    SiteMgr    RemovePkgThreadProc: Downloading file catalog.z from site ePO_XXX-AV-01
                    20100201160735    I    #336    SiteMgr    DecryptAndExtractCatalogCabFile: Verified signature of catalog file C:\WINDOWS\TEMP\nai990.tmp\00000000\catalog.z
                    20100201160735    e    #336    SiteMgr    Error copying file C:/PROGRA~1/McAfee/EPOLIC~1/DB\Software\Current\VSCANDAT1000\DAT\0000\PkgCatalo g.z to C:\WINDOWS\TEMP\nai990.tmp\00000000\PkgCatalog.z, system error 3
                    20100201160735    I    #336    SiteMgr    SetSiteStatus: Setting catalog version to 20100201155106
                    20100201160735    I    #336    SiteMgr    Sending catalog version change notification to ePO server...
                    20100201160736    I    #336    SiteMgr    RemovePkgThreadProc: Remove package thread ended
                    20100201160736    x    #336    SiteMgr    SiteMgr main control final release...

                     

                    Thanks.

                     

                    EarthCadet

                    • 7. Re: ePo 4.0 Updating Master Repository
                      JoeBidgood

                      Okay... are there any problems with the c:\windows\temp folder? Anything in the event logs that would indicate a problem (like a lack of disk space)? Any software or settings that would prevent writes to this folder?

                      Can you clear the contents of the temp folder and try it again?

                       

                      Regards -

                       

                      Joe

                      • 8. Re: ePo 4.0 Updating Master Repository
                        earthcadet

                        I managed to delete the files in the temp folder except two files which were in use. Don't think they were related to McAfee. Also changed the permissions to full control to everyone, to rule out this being an issue.

                         

                        What I have noticed is that in the log file it says that it is trying to copy C:/PROGRA~1/McAfee/EPOLIC~1/DB\Software\Current\VSCANDAT1000\DAT\0000\PkgCatalog .z but when I look in the directory, 0000 directory doesn't exist so it seems that it can't find the PkgCatalog.z file.

                         

                        Thanks.

                         

                        EarthCadet

                        • 9. Re: ePo 4.0 Updating Master Repository
                          JoeBidgood

                          Ah, OK - so the entire 0000 folder is missing?

                          Exactly which ePO version are you using?

                           

                          Joe

                          1 2 Previous Next