1 Reply Latest reply on Jan 30, 2010 9:54 PM by rugby

    PPTP Server setup with all traffic routed through it?

      We've got a situation where a client needs to use PPTP VPN and have their remote users funnel all traffic through it using OS X 10.5.  I've got the PPTP server setup on an SG560U and everybody can connect just fine, and we checked the box under Advanced in the Network System Prefs to have all traffic routed through the tunnel, but no traffic goes.  I've set this up a long time ago with v3.X on the firmware but cannot figure out what I'm missing to let all traffic through the PPTP tunnel, they have an FTP connection for one of their clients that needs to come from their office IP address.

       

      Here's the log output from the SG560U when I try and tunnel through it:

       

      Jan 30 22:48:57 dnsmasq[849]: reading /etc/config/resolv.dnsmasq 
      Jan 30 22:48:57 dnsmasq[849]: using nameserver X.X.X.X#53 
      Jan 30 22:48:57 firewall[24468]: executing firewall rules 
      Jan 30 22:49:02 dnsmasq[849]: reading /etc/config/resolv.dnsmasq 
      Jan 30 22:49:02 dnsmasq[849]: using nameserver X.X.X.X#53 
      Jan 30 22:49:03 firewall[24469]: executing firewall rules 
      Jan 30 22:49:14 pppd[24458]: LCP terminated by peer (MPPE disabled) 
      Jan 30 22:49:14 pppd[24458]: Connect time 0.4 minutes. 
      Jan 30 22:49:14 pppd[24458]: Sent 0 bytes, received 13812 bytes. 
      Jan 30 22:49:14 pptpd[24457]: CTRL: EOF or bad error reading ctrl packet length. 
      Jan 30 22:49:14 pptpd[24457]: CTRL: couldn't read packet header (exit) 
      Jan 30 22:49:14 pptpd[24457]: CTRL: CTRL read failed 
      Jan 30 22:49:14 kernel: freeing kernel compressor 
      Jan 30 22:49:14 last message repeated 1 time(s) 
      Jan 30 22:49:14 pptpd[24457]: CTRL: Reaping child PPP[24458] 
      Jan 30 22:49:14 pppd[24458]: Modem hangup 
      Jan 30 22:49:14 pppd[24458]: Connection terminated. 
      Jan 30 22:49:17 dnsmasq[849]: reading /etc/config/resolv.dnsmasq 
      Jan 30 22:49:17 dnsmasq[849]: using nameserver X.X.X.X#53 
      Jan 30 22:49:17 firewall[24583]: executing firewall rules 
      Jan 30 22:49:20 pppd[24458]: Exit. 
      Jan 30 22:49:20 pptpd[24457]: CTRL: Client X.X.X.X control connection finished 
      Jan 30 22:49:20 pptpd[24457]: CTRL: Couldn't write packet to client. 

       

       

      We can connect into their LAN just fine and see everything there, it's just when we try and route out the WAN port that things don't work.

       

       

      Message was edited by: rugby on 1/30/10 9:49:58 PM CST