5 Replies Latest reply: Jan 7, 2012 8:36 AM by Ex_Brit RSS

    Firewall Range not working. Must specify allowed address

      I've been trying to share a folder on my Win7 computer to a Vista computer. Been going through all sorts of hoops and it can't even see the folder. Finally tried shutting off McAfee firewall and there it is!

       

      So I dug deeper and the Firewall Network setting shows IP range 192.168.1.0 to 192.168.1.255 as Trusted. Great! The machine trying to access my folder is 192.168.1.100.

       

      So I specifically put in 192.168.1.100 and it works fine!!!

       

      My concern is that I use dynamic IPs so what happens when this machine gets assigned a new address? My specific assignment is going to be useless and access will be gone.


      Why isn't the range working? Last time I checked 100 was between 0 and 255

        • 1. Re: Firewall Range not working. Must specify allowed address

          I was having the same problem as you were, with the range. I was going to try single IP but when I took a closer look I noticed that I had mistyped a number in the range. fixed the typo and it started working fine.

           

          Make sure your  IP addresses are correct

          • 2. Re: Firewall Range not working. Must specify allowed address
            Ex_Brit

            I believe those addresses are assigned by your router which I assume you are using.

             

            According to a Google search...

             

            "Assuming the subnet mask is 255.255.255.0 then...

             

            You range of total addresses is from 192.168.1.0 - 192.168.1.255 However, the first and last IP addresses cannot be assigned to hosts since they are reserved for internal usage.

             

            The first address, 192.168.1.0, is the subnet address.

             

            The last address, 192.168.1.255, is the broadcast address.

             

            Thus, the host range is from 192.168.1.1 - 192.168.1.254"

             

            If you are worried by "a computer at IP blah blah has tried to invade" in your Inbound Events, that is normal and those are all failed attempts anyway.

             

            Strange that IP that you wanted should already be OK as it is in that range.

             

            I think Technical Support Chat may be able to explain better than anyone here.

             

             

            Message was edited by: Ex_Brit on 28/01/10 8:24:56 EST AM
            • 3. Re: Firewall Range not working. Must specify allowed address

              Thanks Ex_Brit.

               

              Interestingly enough, I tried setting a range from 192.168.1.0 to 192.168.1.254 and it seems to have worked. Maybe something about either the broadcast address is a problem or the pre-defined entry put in by McAfee is somehow not right. Don't know but it appears to be working now.

               

              BTW: I tried chat but every time I tried it it bounced me back to McAfee.com and never loaded. Same with email. So I couldn't email to tell anyone that I couldn't get chat working. Maybe a Firefox problem? Whatever,.. I was totally stuck.

              • 4. Re: Firewall Range not working. Must specify allowed address
                greg28818

                I know this is old but this is still a problem.  Why does the rule get created if it does not work.  After not being able to see any other computers on the network, I've created the exact same rule(192.168.1.0 - 192.168.1.255,) myself.   Leaving the original rule in place and as soon as I do that  you can see the other computers on my network.  Mcafee should just not create the rule in the first place, its just ridiculous.

                • 5. Re: Firewall Range not working. Must specify allowed address
                  Ex_Brit

                  The firewall sets the IP range automatically and that shouldn't be altered but you may wish to add others depending on your network use.  As this is an old thread as you said and the subject is a bit technical I think Technical Support could explain it better than I can.

                   

                  I don't have a network so am a bit rusty in that regard.

                   

                  They are free to phone or use online chat, linked under Useful Links at the top of this page.