7 Replies Latest reply on Feb 9, 2010 5:41 AM by JoeBidgood

    Cannot Deploy Agent 4.5.0 or VSE 8.7i from ePO 4.5.0

      I have at last upgraded Protection Pilot 1.5.0 to ePO 4.5.0. I have Checked in McAfee Agent 4.5.0 and VirusScan Enterprise v8.7i

       

      I cannot seem to get the McAfee Agent onto the client PCs. When I choose the "Update Now" option, ePO states "These systems do not support update now:" and it shows the same number of PCs that I tried to update.

       

      If I try to deply the client, the server log shows Failed after 5 minutes of trying....

       

      Am I missing something out?

        • 1. Re: Cannot Deploy Agent 4.5.0 or VSE 8.7i from ePO 4.5.0
          JoeBidgood

          Do the machines already have an agent on them? If so, which version?

          I'm guessing that it is not version 4.5, which is why you can't do an Update Now - only 4.5 agents are capable of doing this. However if you simply schedule a normal deployment task configured to deploy the 4.5 agent, then this should work fine.

           

          Regards -

           

          Joe

          • 2. Re: Cannot Deploy Agent 4.5.0 or VSE 8.7i from ePO 4.5.0

            The machines have Agent version 4.0 on them. I did as you suggested, and scheduled a normal deployment task yesterday. I have checked this morning, and nothing has changed - no roll outs of the new agent OR the new VSE.

            • 3. Re: Cannot Deploy Agent 4.5.0 or VSE 8.7i from ePO 4.5.0
              JoeBidgood

              Check the agent_machinename.log on the client machine - have they received the task, and are they trying to run it at the correct time? For troubleshooting purposes you might find it easier to create a new task set to run a few minutes in the future and wake the machine up to make sure it receives it.

               

              If it does run at the correct time, are any errors reported?

               

              Regards -

               

              Joe

              • 4. Re: Cannot Deploy Agent 4.5.0 or VSE 8.7i from ePO 4.5.0

                Sorry for the delay in replying. I've logged on to one of the client machines, and have removed the existing VSE and forced the uninstall of the Agent.

                 

                I then attempted to re-deploy the agent from ePo. This apparently worked. The Agent is on the machine, and is the correct version - however, the VSE is still not installing.

                 

                Here is a portion of the log - I hope it makes some sense to you, because I really don't have a clue what I'm looking for...

                 

                2010-02-09 10:51:14 i #584 Agent Agent Started Enforcing policies
                2010-02-09 10:51:14 I #584 Agent Thread time-out occurred
                2010-02-09 10:51:14 I #584 Manage Enforcing policies
                2010-02-09 10:51:14 i #584 Manage Enforcing Policies for EPOAGENT3000META
                2010-02-09 10:51:14 i #584 Manage Enforcing Policies for EPOAGENT3000
                2010-02-09 10:51:14 i #584 Manage Enforcing Policies for McAfee Agent
                2010-02-09 10:51:14 I #584 Agent CePOAgent::EnforcePolicy priority=-2
                2010-02-09 10:51:14 I #584 Agent Enforcing policies
                2010-02-09 10:51:14 I #584 LstnSvr Enforcing Policies
                2010-02-09 10:51:14 I #584 Logging Enforcing policies
                2010-02-09 10:51:14 I #584 Manage Enforcing policies
                2010-02-09 10:51:14 I #584 UsrSpCt Enforcing policies
                2010-02-09 10:51:14 I #584 UsrSpCt Token not found. Will try to get it from shell
                2010-02-09 10:51:14 I #584 UsrSpCt Found shell token
                2010-02-09 10:51:14 I #584 FrmSvc User SID is S-1-5-21-2551917562-960526672-2440291535-500 and SessionID is 0
                2010-02-09 10:51:14 I #584 UsrSpCt Try to Launch UdaterUI Again
                2010-02-09 10:51:14 I #584 UsrSpCt UpdaterUI won't be launched for Terminal Services client session (sessionID=1)
                2010-02-09 10:51:14 I #584 Sched >>--CSchedule::EnforcePolicy
                2010-02-09 10:51:14 I #584 Sched >>--CSchedule::ModifyTask
                2010-02-09 10:51:14 I #584 Sched <<--CSchedule::ModifyTask
                2010-02-09 10:51:14 I #584 Sched Deployment - Agent - Last run time(local) is Tue Feb 09 10:46:14 2010
                2010-02-09 10:51:14 I #584 Sched
                2010-02-09 10:51:14 I #584 Sched 0 fields of the task 204 are updated successfully
                2010-02-09 10:51:14 I #5340 Sched Deployment - Agent - Last run time is : not run yet
                2010-02-09 10:51:14 i #5340 Sched Added a new task Deployment - Agent to Scheduler's task list
                2010-02-09 10:51:14 I #584 Sched >>--CSchedule::ModifyTask
                2010-02-09 10:51:14 I #584 Sched <<--CSchedule::ModifyTask
                2010-02-09 10:51:14 I #584 Sched Deployment - Client - Last run time(local) is Tue Feb 09 10:46:15 2010
                2010-02-09 10:51:14 I #584 Sched
                2010-02-09 10:51:14 I #584 Sched 0 fields of the task 206 are updated successfully
                2010-02-09 10:51:15 I #5340 Sched Deployment - Client - Last run time is : not run yet
                2010-02-09 10:51:15 i #5340 Sched Added a new task Deployment - Client to Scheduler's task list
                2010-02-09 10:51:15 i #2556 Sched Scheduler: Invoking task [Deployment - Agent]...
                2010-02-09 10:51:15 I #584 Sched >>--CSchedule::ModifyTask
                2010-02-09 10:51:15 I #584 Sched <<--CSchedule::ModifyTask
                2010-02-09 10:51:15 I #1576 Sched >>--RunTask
                2010-02-09 10:51:15 I #1576 Manage Running task SoftwareID:EPOAGENT3000, TaskID:204
                2010-02-09 10:51:15 I #584 Sched Update - Last run time is : not run yet
                2010-02-09 10:51:15 I #584 Sched 0 fields of the task 7 are updated successfully
                2010-02-09 10:51:15 I #584 Sched RunAtEnforcementEnabled not found in the task settings
                2010-02-09 10:51:15 I #584 Sched >>--CSchedule::GetTask
                2010-02-09 10:51:15 I #584 Sched <<--CSchedule::GetTask
                2010-02-09 10:51:15 I #584 Sched >>--CSchedule::GetTask
                2010-02-09 10:51:15 I #584 Sched <<--CSchedule::GetTask
                2010-02-09 10:51:15 I #584 Sched >>--CSchedule::GetTask
                2010-02-09 10:51:15 I #584 Sched <<--CSchedule::GetTask
                2010-02-09 10:51:15 I #584 Sched <<--CSchedule::EnforcePolicy
                2010-02-09 10:51:15 i #584 Agent Agent finished Enforcing policies
                2010-02-09 10:51:15 i #584 Agent Next policy enforcement in 5 minutes
                2010-02-09 10:51:15 I #4148 FrmSvc User SID is S-1-5-18 and SessionID is 0
                2010-02-09 10:51:15 I #2784 UpdEvents Initializing Event Interface
                2010-02-09 10:51:15 I #2784 UpdEvents EpoEventInf Interface: Initialization succeeded.
                2010-02-09 10:51:15 I #3884 Uec Waiting for ipc thread to initialize
                2010-02-09 10:51:15 I #2740 ipcchannel Initializing IPC server
                2010-02-09 10:51:15 I #2740 Uec Initialized ipc channel successfully
                2010-02-09 10:51:15 I #3884 Uec Ipc thread initialized successfully
                2010-02-09 10:51:15 I #3884 Uec Invoking Mue with "C:\Program Files\McAfee\Common Framework\McScript_InUse.exe"  -script "C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\InstallMain.McS" -id 27837 -localeid 0809 -parent FRAMEWORK -logfile "C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\DB\McScript" -initiator 4 -ipcid "\\.\pipe\upda03884" -installdir "C:\Program Files\McAfee\Common Framework"
                2010-02-09 10:51:15 I #2784 deploy Deployment session started.
                2010-02-09 10:51:15 I #1576 Sched <<--RunTask
                2010-02-09 10:51:15 I #2556 Sched Deployment - Agent - Last run time(local) is Tue Feb 09 10:51:15 2010
                2010-02-09 10:51:15 I #2556 Sched
                2010-02-09 10:51:15 I #2556 Sched End of invoking the task
                2010-02-09 10:51:15 I #2740 Uec Received ipc data from mue
                2010-02-09 10:51:15 I #2740 Uec Processing progress information
                2010-02-09 10:51:15 i #2740 Updater Unable to find a valid repository.
                2010-02-09 10:51:15 I #2740 Uec Done processing progress information
                2010-02-09 10:51:15 I #2740 Uec Received ipc data from mue
                2010-02-09 10:51:15 I #2740 Uec Processing event information
                2010-02-09 10:51:15 I #2740 UpdEvents Generating update event:EventId=2412:Severity=0:ProductId=EPOAGENT3000:Locale=0809:UpdateType=N/A :UpdateError=26:NewVersion=N/A:DateTime=N/A
                2010-02-09 10:51:15 I #2740 UpdEvents EpoEventInf Interface: Event element created.
                2010-02-09 10:51:15 I #2740 muemsg Calling HandlePostpone with TaskID:  UpdateState: 4
                2010-02-09 10:51:15 I #2740 muemsg Calling m_pUpdateInfoCallback->HandlePostpone
                2010-02-09 10:51:15 I #2740 Updater CMcAfeeUpdate::HandlePostpone() Entered taskid: 204
                2010-02-09 10:51:15 I #2740 Updater Finished calling GetPostponeMins
                2010-02-09 10:51:15 I #2740 Updater CMcAfeeUpdate::HandlePostpone() Exit
                2010-02-09 10:51:15 I #2740 muemsg Finished Calling m_pUpdateInfoCallback->HandlePostpone
                2010-02-09 10:51:15 I #2740 muemsg Finished Calling HandlePostpone
                2010-02-09 10:51:15 I #2740 UpdEvents EpoEventInf Interface: Update event created.
                2010-02-09 10:51:15 I #2740 UpdEvents DeInitializing Event Interface
                2010-02-09 10:51:15 I #2740 UpdEvents EpoEventInf Interface: Deinitialization succeeded.
                2010-02-09 10:51:15 I #2740 muemsg Updater session finish state value =4
                2010-02-09 10:51:15 I #2740 Uec Done processing event  information
                2010-02-09 10:51:15 I #2740 Uec Received ipc data from mue
                2010-02-09 10:51:15 I #2740 Uec Processing progress information
                2010-02-09 10:51:15 i #2740 Updater Update process failed.
                2010-02-09 10:51:15 I #2740 Uec Done processing progress information
                2010-02-09 10:51:15 I #2740 Uec Terminating thread
                2010-02-09 10:51:15 I #3884 Uec Terminating ipc channel
                2010-02-09 10:51:15 I #3884 ipcchannel Aborting IPC object connection
                2010-02-09 10:51:15 I #3884 ipcchannel Closing IPC connection
                2010-02-09 10:51:15 I #2784 FrmSvc User SID is S-1-5-18 and SessionID is 0
                2010-02-09 10:51:15 I #5340 Sched The task  Deployment - Agent has failed
                2010-02-09 10:51:15 I #5340 Sched The task  Deployment - Agent has failed
                2010-02-09 10:51:15 I #5340 Sched >>--ReleaseTask
                2010-02-09 10:51:15 I #5340 Manage Releasing Task Cookie=18879512
                2010-02-09 10:51:15 I #5340 Sched <<--ReleaseTask
                2010-02-09 10:51:16 i #2556 Sched Scheduler: Invoking task [Deployment - Client]...
                2010-02-09 10:51:16 I #1152 Sched >>--RunTask
                2010-02-09 10:51:16 I #1152 Manage Running task SoftwareID:EPOAGENT3000, TaskID:206
                2010-02-09 10:51:16 I #4552 FrmSvc User SID is S-1-5-18 and SessionID is 0
                2010-02-09 10:51:16 I #4148 UpdEvents Initializing Event Interface
                2010-02-09 10:51:16 I #4148 UpdEvents EpoEventInf Interface: Initialization succeeded.
                2010-02-09 10:51:16 I #5912 Uec Waiting for ipc thread to initialize
                2010-02-09 10:51:16 I #1732 ipcchannel Initializing IPC server
                2010-02-09 10:51:16 I #1732 Uec Initialized ipc channel successfully
                2010-02-09 10:51:16 I #5912 Uec Ipc thread initialized successfully
                2010-02-09 10:51:16 I #5912 Uec Invoking Mue with "C:\Program Files\McAfee\Common Framework\McScript_InUse.exe"  -script "C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\InstallMain.McS" -id 27840 -localeid 0809 -parent FRAMEWORK -logfile "C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\DB\McScript" -initiator 4 -ipcid "\\.\pipe\upda05912" -installdir "C:\Program Files\McAfee\Common Framework"
                2010-02-09 10:51:16 I #4148 deploy Deployment session started.
                2010-02-09 10:51:16 I #1152 Sched <<--RunTask
                2010-02-09 10:51:16 I #2556 Sched Deployment - Client - Last run time(local) is Tue Feb 09 10:51:16 2010
                2010-02-09 10:51:16 I #2556 Sched
                2010-02-09 10:51:16 I #2556 Sched End of invoking the task
                2010-02-09 10:51:16 I #1732 Uec Received ipc data from mue
                2010-02-09 10:51:16 I #1732 Uec Processing progress information
                2010-02-09 10:51:16 i #1732 Updater Unable to find a valid repository.
                2010-02-09 10:51:16 I #1732 Uec Done processing progress information
                2010-02-09 10:51:16 I #1732 Uec Received ipc data from mue
                2010-02-09 10:51:16 I #1732 Uec Processing event information
                2010-02-09 10:51:16 I #1732 UpdEvents Generating update event:EventId=2412:Severity=0:ProductId=EPOAGENT3000:Locale=0809:UpdateType=N/A :UpdateError=26:NewVersion=N/A:DateTime=N/A
                2010-02-09 10:51:16 I #1732 UpdEvents EpoEventInf Interface: Event element created.
                2010-02-09 10:51:16 I #1732 muemsg Calling HandlePostpone with TaskID:  UpdateState: 4
                2010-02-09 10:51:16 I #1732 muemsg Calling m_pUpdateInfoCallback->HandlePostpone
                2010-02-09 10:51:16 I #1732 Updater CMcAfeeUpdate::HandlePostpone() Entered taskid: 206
                2010-02-09 10:51:16 I #1732 Updater Finished calling GetPostponeMins
                2010-02-09 10:51:16 I #1732 Updater CMcAfeeUpdate::HandlePostpone() Exit
                2010-02-09 10:51:16 I #1732 muemsg Finished Calling m_pUpdateInfoCallback->HandlePostpone
                2010-02-09 10:51:16 I #1732 muemsg Finished Calling HandlePostpone
                2010-02-09 10:51:16 I #1732 UpdEvents EpoEventInf Interface: Update event created.
                2010-02-09 10:51:16 I #1732 UpdEvents DeInitializing Event Interface
                2010-02-09 10:51:16 I #1732 UpdEvents EpoEventInf Interface: Deinitialization succeeded.
                2010-02-09 10:51:16 I #1732 muemsg Updater session finish state value =4
                2010-02-09 10:51:16 I #1732 Uec Done processing event  information
                2010-02-09 10:51:16 I #1732 Uec Received ipc data from mue
                2010-02-09 10:51:16 I #1732 Uec Processing progress information
                2010-02-09 10:51:16 i #1732 Updater Update process failed.
                2010-02-09 10:51:16 I #1732 Uec Done processing progress information
                2010-02-09 10:51:16 I #1732 Uec Terminating thread
                2010-02-09 10:51:16 I #5912 Uec Terminating ipc channel
                2010-02-09 10:51:16 I #5912 ipcchannel Aborting IPC object connection
                2010-02-09 10:51:16 I #5912 ipcchannel Closing IPC connection
                2010-02-09 10:51:16 I #4148 FrmSvc User SID is S-1-5-18 and SessionID is 0
                2010-02-09 10:51:16 I #5340 Sched The task  Deployment - Client has failed
                2010-02-09 10:51:16 I #5340 Sched The task  Deployment - Client has failed
                2010-02-09 10:51:16 I #5340 Sched >>--ReleaseTask
                2010-02-09 10:51:16 I #5340 Manage Releasing Task Cookie=18879512
                2010-02-09 10:51:16 I #5340 Sched <<--ReleaseTask

                • 5. Re: Cannot Deploy Agent 4.5.0 or VSE 8.7i from ePO 4.5.0
                  JoeBidgood

                  Okay, this is the important bit:

                   

                  2010-02-09 10:51:15 i #2740 Updater Unable to find a valid repository.

                   

                  Check that the repository that the machine is trying to update from is up to date (i.e. you have replicated to it.) There's more info in the mcscript.log about the deployment / update tasks, so have a look in there - it should tell you which repo the machine is trying to use.

                   

                  Regards -

                   

                  Joe

                  • 6. Re: Cannot Deploy Agent 4.5.0 or VSE 8.7i from ePO 4.5.0

                    Hi Joe,

                     

                    Here is the initial portion of the McScript.log file. Correct me if I am wrong, but it looks like it's trying to get the updates direct from McAfee rather than a local server? If that IS the case, where do I need to alter this settings?

                     

                    2010-02-09 10:56:15 E #6132 RcFile  [LoadLibrary,0809/MueRes_InUse.dll]->
                    2010-02-09 10:56:15 E #6132 RcFile   error 126: The specified module could not be found.
                    2010-02-09 10:56:15 I #6132 persite Cache file location = C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\sitecache.bin
                    2010-02-09 10:56:15 I #6132 persite Cabundle file location = C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\cabundle.cer
                    2010-02-09 10:56:15 I #6132 creposi Checking for a valid license.
                    2010-02-09 10:56:15 I #6132 naInetLic License Communications Session initialized
                    2010-02-09 10:56:15 I #6132 naInet Trying to find an usable proxy using IE settings
                    2010-02-09 10:56:15 I #6132 naInetLic License Communications Session closed
                    2010-02-09 10:56:15 E #6132 creposi Error trace:
                    2010-02-09 10:56:15 E #6132 Thread  [Main thread]->
                    2010-02-09 10:56:15 E #6132 SessMgr  [initializeScript]->
                    2010-02-09 10:56:15 E #6132 creposi  [setNextRepositoryToUse]->
                    2010-02-09 10:56:15 E #6132 creposi  [Candidate NAIHttp: testing]->
                    2010-02-09 10:56:15 E #6132 creposi   Download is allowed from the McAfee repositories but error condition found. Error code:-2. Error message:
                    2010-02-09 10:56:15 I #6132 naInet HTTP Session initialized
                    2010-02-09 10:56:15 I #6132 imsite  Download to: C:\WINDOWS\TEMP\SiteStat.xml
                    2010-02-09 10:56:15 I #6132 imsite  Download from: (NAIHttp) SiteStat.xml
                    2010-02-09 10:56:15 I #6132 naInet Trying to find an usable proxy using IE settings
                    2010-02-09 10:56:15 I #6132 naInet Open URL: http://update.nai.com:80/Products/CommonUpdater/SiteStat.xml
                    2010-02-09 10:56:15 I #6132 naInet Trying to find an usable proxy using IE settings
                    2010-02-09 10:56:16 I #6132 SessMgr Using repository NAIHttp for script

                    • 7. Re: Cannot Deploy Agent 4.5.0 or VSE 8.7i from ePO 4.5.0
                      JoeBidgood

                      That's certainly possible.

                      Setting up and configuring repositories is quite a large area - I'd recommend having a look at the "Creating Repositories" and "Deploying Software and Updates" sections of the ePO 4.5 product guide, which should get you started.

                       

                      Regards -

                       

                      Joe