5 Replies Latest reply on Nov 17, 2010 4:06 PM by WWingert

    McAfee AutoUpdate failing on Windows 7 x64

      Hello everyone,

       

      I recently upgraded from Windows 7 x86 to Windows 7 x64. The installation worked, the application appears to be operable, but anytime I try to run the update, I get the following error:

      "Failed to initialize Common Updater subsystem. Make sure the McAfee Framework Service is running. McAfee Common Framework returned error 80040154 @ 1."

       

      I have the following McAfee services installed and running:

      - McAfee Engine Service

      - McAfee McShield

      - McAfee Task Manager

      - McAfee Validation Trust Protection Service

       

      I checked my colleagues machine who is running Windows 7 x86 and he only has McAfee Framework service ... none of the above, and his is working just fine.

       

      So at this point, what do I do? What other information can I provide to seek help? We are currently running 8.7 and I'm not sure if there is a different install for x64 or not, as I beileve I may be the first adopter of x64 around here.

       

      Any help is most appreciated.

       

      Thank you

        • 2. Re: McAfee AutoUpdate failing on Windows 7 x64

          Thanks Attila,

           

          I tried:

          - KB57715 - Regsvr32.exe %Windir%\System32\Ole32.dll

          - KB54520 - I do not have the login information to login and download the agent

          - KB57766 - Regsvr32.exe c:\Program Files\McAfee\Common Framework\ScriptSubSys.dll - "Specified module not found" - Tried changing to Program FIles (x86) as well

          - KB57767 - Regsvr32.exe c:\Program Files\McAfee\Common Framework\UpdateSubSys.dll - Same as above

           

          I'm not sure if these will fix the problem at hand due to the x64 problem. This is a brand new install that I just recently did on two x86 machines without problem. Introducing x64 appears to be the problem. Don't I need the frame work service?

           

          I'll continue to try some of the others, but I'm not sure if this is the right direction.

           

          Thanks

          • 3. Re: McAfee AutoUpdate failing on Windows 7 x64

            Interesting, not entirely sure what it was, but one of my IT guys gave me a batch file to fix the framework and it installed the framework, and now I can update and all is well.

            • 4. Re: McAfee AutoUpdate failing on Windows 7 x64
              Attila Polinger

              Most probably, I'd say, the script simply reinstalled the framework with agent functionality from a central location of yours. From that several of your tries were unsuccessfull, because the files were missing upong trying to reregister them, it seems that the entire framework installation has failed originally.

               

              I am using my windows 7 x64 with VirusScan 8.7 Patch 2 and I had no problem upon instalation with the framework. Update works fine.

               

              the other guy that you said having only the framework service apparently does not have VirusScan the version you have, or does not have it at all. the services you listed belong to VirusScan 8.7 (see KB59389). Maybe a quick look at his computer would be worth, checking if virusscan proper version is installed.

              • 5. Re: McAfee AutoUpdate failing on Windows 7 x64

                I realize this is an old post, but I'm seeing this a lot with my laptops that have Windows 7 x64 installed. I'm finding that if I uninstall/reinstall the agent and set the Framework service to "Automatic (delayed start)" the problems go away. Unfortunately I haven't yet figured out how to get it to install that way and am having to manually change these.

                 

                Anyone else seeing this issue?