7 Replies Latest reply on Jan 22, 2010 9:33 AM by sdelvecchio

    Installing ePO management 4.5 to a windows server

      I am looking for some help with installing McAfee ePO 4.5 to an Windows 2003 SP2 server.

       

      The server previously had McAfee ePO 3.6.1, but the installation corrupted and was removed due to the database corrupting.

       

      I am now however having issues with installing 4.5 to this server. I cannot get the installer to create a database for it to store it's data. I have taken the extreme of even installing a new instance of SQL server express 2005 to the server and trying to get it to install to this. This fails each time.

       

      Am I missing something in my installation?

      I must also warn you that I am a complete newbie with McAfee. This is with a client we have inherited with this AV product and I am completely out my depth with it.

       

      Any help would be much appreciated.

        • 1. Re: Installing ePO management 4.5 to a windows server
          sdelvecchio

          What is the failure message you are getting?

          • 2. Re: Installing ePO management 4.5 to a windows server

            c

            the error I get is

             

            ---------------------------
            McAfee ePolicy Orchestrator 4.5.0
            ---------------------------
            Setup is unable to access the SQL UDP port 1434 on the specified SQL server. Setup requires such access to retrieve the TCP port assignment information from the SQL server.

             

            If you must leave this port blocked, enter the TCP port assignment manually in the “SQL server TCP port” field in Setup.
            ---------------------------
            OK  
            ---------------------------

             

            After manually trying what is suggested it still fails to install and I get this error

             

            ---------------------------
            McAfee ePolicy Orchestrator 4.5.0
            ---------------------------
            Unable to make a connection to the database server using the information you provided.

             

            Check that the following is correct before trying again:

             

              · Make sure that the Server name is correct.
              · Make sure that the Instance name is correct.
              · Make sure that TCP is enabled and working on the selected database server.
            ---------------------------
            OK  
            ---------------------------

            DB engine installed is SQL 2005 express

             

             

            Message was edited by: notgraham on 1/20/10 1:29:34 PM CST
            • 3. Re: Installing ePO management 4.5 to a windows server

              Data from the EOP450-CommonSetup.log

               

              20100120192323
              20100120192323 ********************************************************************
              20100120192323 *                          Start Logging                           *
              20100120192323 ********************************************************************
              20100120192323 Entered GetListOfDomains function.
              20100120192323 szListOfDomains = [TRMSRV2]
              20100120192323 Call to NetServerEnum function successful.
              20100120192323 szListOfDomains = [TRMSRV2,MSHOME,BLAHBLAHDOMAINNAME,WORKGROUP]
              20100120192323 Entered GetListOfSQLServers function.
              20100120192323 Entered SQL::getServerList function.
              20100120192325 SQLBrowseConnect returned a code of 99. Results: [SERVER:Server={ARCHIVE,DESKTOPTIMEMAN,NL-DC,NL-ERP1,NL-EXCH1,TRMSRV2\ACT7};UID :Login ID=?;PWD:Password=?;*APP:AppName=?;*WSID:WorkStation ID=?] - Size: 142
              20100120192325 Setup found [6] SQL servers.
              20100120192326 Checking for VirusScan 8.0i and Patch 11 or higher.
              20100120192326 reg open: 0x80000002\SOFTWARE\Network Associates\TVD\VirusScan Enterprise\CurrentVersion
              20100120192326 VirusScan Enterprise not detected.
              20100120192326 Entered IsCMARebootPending function.
              20100120192326 CMA reboot pending NOT detected.
              20100120192326 Entered IsNotEnoughRAMDetected function.
              20100120192326 RAM detected: [2047]
              20100120192326 Entered IsDisplayResolutionNoEnough function.
              20100120192326 Resolution detected: [1024x768]
              20100120192439 Entered CanNTUserLogon function to validate the following user: [BLAHBLAHDOMAINNAME\administrator]
              20100120192439 Entered AccountcanLogon function.
              20100120192439 validating account BLAHBLAHDOMAINNAME\administrator
              20100120192440  success, token = 2568
              20100120192440 Entered ValidateNTInGroup function.
              20100120192440 Group [ePO User Group] does not exists.
              20100120192440 Local group [ePO User Group] created successfully.
              20100120192440 Comments successfully set for group [ePO User Group].
              20100120192440 User [BLAHBLAHDOMAINNAME\administrator] successfully added to local group [ePO User Group].
              20100120192440 User [BLAHBLAHDOMAINNAME\administrator] successfully removed from local group [ePO User Group].
              20100120192440 Local group [ePO User Group] removed successfully.
              20100120192440 Entered ConnectAndGetDatabaseInformation function.
              20100120192440 Trying to connect to: 192.168.1.15:1434
              20100120192440 Address resolved to name: TRMSRV2
              20100120192440 Bytes Sent: 2
              20100120192440 Bytes Recv: 284
              20100120192440 OutputFromSQLServerQuery = ServerName:TRMSRV2,InstanceName:ACT7,IsClustered:No,Version:9.00.4035.00,tcp:32 59,np:\\TRMSRV2\pipe\MSSQL$ACT7\sql\query;ServerName:TRMSRV2,InstanceName:SQLEXP RESS,IsClustered:No,Version:9.00.1399.06;ServerName:TRMSRV2,InstanceName:EPOSERV ER,IsClustered:No,Version:9.00.1399.06;
              20100120192440 SQL Server information could not be found in return value: ServerName:TRMSRV2,InstanceName:ACT7,IsClustered:No,Version:9.00.4035.00,tcp:32 59,np:\\TRMSRV2\pipe\MSSQL$ACT7\sql\query;ServerName:TRMSRV2,InstanceName:SQLEXP RESS,IsClustered:No,Version:9.00.1399.06;ServerName:TRMSRV2,InstanceName:EPOSERV ER,IsClustered:No,Version:9.00.1399.06;
              20100120192440 Entered CanConnectToHostAndPort function.
              20100120192441 Connection to server TRMSRV2 on port 1433 failed.
              20100120192705 Entered CanNTUserLogon function to validate the following user: [BLAHBLAHDOMAINNAME\administrator]
              20100120192705 Entered AccountcanLogon function.
              20100120192705 validating account BLAHBLAHDOMAINNAME\administrator
              20100120192706  success, token = 2600
              20100120192706 Entered ValidateNTInGroup function.
              20100120192706 Group [ePO User Group] does not exists.
              20100120192706 Local group [ePO User Group] created successfully.
              20100120192706 Comments successfully set for group [ePO User Group].
              20100120192706 User [BLAHBLAHDOMAINNAME\administrator] successfully added to local group [ePO User Group].
              20100120192706 User [BLAHBLAHDOMAINNAME\administrator] successfully removed from local group [ePO User Group].
              20100120192706 Local group [ePO User Group] removed successfully.
              20100120192706 Entered CanConnectToHostAndPort function.
              20100120192707 Connection to server TRMSRV2 on port 1434 failed.
              20100120192859
              20100120192859 ********************************************************************
              20100120192859 *                          Start Logging                           *
              20100120192859 ********************************************************************
              20100120192900 Entered GetListOfDomains function.
              20100120192900 szListOfDomains = [TRMSRV2]
              20100120192900 Call to NetServerEnum function successful.
              20100120192900 szListOfDomains = [TRMSRV2,MSHOME,BLAHBLAHDOMAINNAME,WORKGROUP]
              20100120192900 Entered GetListOfSQLServers function.
              20100120192900 Entered SQL::getServerList function.
              20100120192902 SQLBrowseConnect returned a code of 99. Results: [SERVER:Server={ARCHIVE,DESKTOPTIMEMAN,NL-DC,NL-ERP1,NL-EXCH1,TRMSRV2\ACT7};UID :Login ID=?;PWD:Password=?;*APP:AppName=?;*WSID:WorkStation ID=?] - Size: 142
              20100120192902 Setup found [6] SQL servers.
              20100120192903 Checking for VirusScan 8.0i and Patch 11 or higher.
              20100120192903 reg open: 0x80000002\SOFTWARE\Network Associates\TVD\VirusScan Enterprise\CurrentVersion
              20100120192903 VirusScan Enterprise not detected.
              20100120192903 Entered IsCMARebootPending function.
              20100120192903 CMA reboot pending NOT detected.
              20100120192903 Entered IsNotEnoughRAMDetected function.
              20100120192903 RAM detected: [2047]
              20100120192903 Entered IsDisplayResolutionNoEnough function.
              20100120192903 Resolution detected: [1024x768]
              20100120193025 Entered CanNTUserLogon function to validate the following user: [BLAHBLAHDOMAINNAME\administrator]
              20100120193025 Entered AccountcanLogon function.
              20100120193025 validating account BLAHBLAHDOMAINNAME\administrator
              20100120193025  success, token = 2560
              20100120193025 Entered ValidateNTInGroup function.
              20100120193025 Group [ePO User Group] does not exists.
              20100120193026 Local group [ePO User Group] created successfully.
              20100120193026 Comments successfully set for group [ePO User Group].
              20100120193026 User [BLAHBLAHDOMAINNAME\administrator] successfully added to local group [ePO User Group].
              20100120193026 User [BLAHBLAHDOMAINNAME\administrator] successfully removed from local group [ePO User Group].
              20100120193026 Local group [ePO User Group] removed successfully.
              20100120193026 Entered ConnectAndGetDatabaseInformation function.
              20100120193026 Trying to connect to: 192.168.1.15:1434
              20100120193026 Address resolved to name: TRMSRV2
              20100120193026 Bytes Sent: 2
              20100120193026 Bytes Recv: 284
              20100120193026 OutputFromSQLServerQuery = ServerName:TRMSRV2,InstanceName:ACT7,IsClustered:No,Version:9.00.4035.00,tcp:32 59,np:\\TRMSRV2\pipe\MSSQL$ACT7\sql\query;ServerName:TRMSRV2,InstanceName:SQLEXP RESS,IsClustered:No,Version:9.00.1399.06;ServerName:TRMSRV2,InstanceName:EPOSERV ER,IsClustered:No,Version:9.00.1399.06;
              20100120193026 Information returned from SQL Server [TRMSRV2] for instance name [SQLEXPRESS]: ServerName:TRMSRV2,InstanceName:SQLEXPRESS,IsClustered:No,Version:9.00.1399.06;
              20100120193026 TCP (tcp:) was not detected for SQL server [TRMSRV2] with instance name [SQLEXPRESS].
              20100120193026 Entered CanConnectToHostAndPort function.
              20100120193027 Connection to server TRMSRV2 on port 1433 failed.
              20100120193035 Entered CanNTUserLogon function to validate the following user: [BLAHBLAHDOMAINNAME\administrator]
              20100120193035 Entered AccountcanLogon function.
              20100120193035 validating account BLAHBLAHDOMAINNAME\administrator
              20100120193035  success, token = 2688
              20100120193035 Entered ValidateNTInGroup function.
              20100120193035 Group [ePO User Group] does not exists.
              20100120193036 Local group [ePO User Group] created successfully.
              20100120193036 Comments successfully set for group [ePO User Group].
              20100120193036 User [BLAHBLAHDOMAINNAME\administrator] successfully added to local group [ePO User Group].
              20100120193036 User [BLAHBLAHDOMAINNAME\administrator] successfully removed from local group [ePO User Group].
              20100120193036 Local group [ePO User Group] removed successfully.
              20100120193036 Entered CanConnectToHostAndPort function.
              20100120193037 Connection to server TRMSRV2 on port 1434 failed.

              • 4. Re: Installing ePO management 4.5 to a windows server
                sdelvecchio

                Is 1433 or 1434 the port being used for the SQL connection and does it match what you are specifying during the install? When I had this problem I had to pick a random port for use with SQL because both of these ports were used by another application.

                 

                I see both in your log, so it looks like it may be a port mismatch.

                 

                 

                Message was edited by: sdelvecchio on 1/20/10 4:24:36 PM CST
                1 of 1 people found this helpful
                • 5. Re: Installing ePO management 4.5 to a windows server
                  smalldog

                  I think this problem because you can not connect to database of sql server. See image attachment to try edit settings and make sure sql services is running

                  1 of 1 people found this helpful
                  • 6. Re: Installing ePO management 4.5 to a windows server

                    Thank you for all your help.

                    Enabling my SQL database and assigning it a port allowed ePO to install.

                    It is all installed now

                     

                    I just need to work out how to get all the machines to now check into this new server - any quick start guides for ePO 4.5 that anyone can recommend?

                    • 7. Re: Installing ePO management 4.5 to a windows server
                      sdelvecchio

                      Here is a link to the ePO 4.5 Product Guide, there is a quick start in there

                      https://kc.mcafee.com/resources/sites/MCAFEE/content/live/PRODUCT_DOCUMENTATION/ 22000/PD22236/en_US/ma_450_product_guide_en-us.pdf

                       

                      This is a master support list for ePO 4.5

                      https://kc.mcafee.com/corporate/index?page=content&id=KB65897&actp=search&search id=1264174228151

                       

                      and

                       

                      This is the link to the knowledgebase, which will be your best friend when first starting out

                      https://mysupport.mcafee.com/Eservice/templatepage.aspx?sURL=3&pl=0