1 2 Previous Next 13 Replies Latest reply on Dec 16, 2010 9:27 AM by kink80

    'Run Missed Task' not working

      Hi

       

      I am using EPO 4 and have a client task called "Update VSE Engine, DAT, Patches" which does as its title suggests. It is scheduled to run every day at 00:25 am with a 30 minute randomization time. Within the task, I have the 'run missed task' selected.

       

      Clients (using epo agent 4.0.0.1444) which are permanently connected to the network run this task as expected at the specified time. However, some clients only occasionally connect to the network. For these clients, I would expect them to 'run missed task' soon after connection, but instead, they seem to check the time and just schedule the update task for the next 00:25am + 30 minutes randomization time. This is causing problems as the clients are usually removed from the network before the task has had time ro run. If this scenario is repeated, the clinets can be many days out of date with DAT files etc.

       

      Can anyone give me an idea of where my problem is?

       

      Thanks in advance

       

      Martin

        • 1. Re: 'Run Missed Task' not working
          JoeBidgood

          Hi...

           

          I've just done a quick test, and I believe the agent will miss the first missed task after it receives the task for the first time (if you see what I mean) - but it should then correctly execute it the next time round. However what it writes in the log may be more confusing

           

          For simplicity, imagine your task is not randomised. You've got a new machine which connects to ePO for the first time at 12 noon on a Monday. It downloads the task that you have configured, and sets the next run time to be  00:25 on Tuesday - but it will not run the missed task at this point.

          Now the machine is switched off, and back on again on Tuesday at 12 noon. In the agent log it will show something like this:

           

          Update VSE Engine, DAT, Patches - last run time is: not run yet

          Next time (local) of task Update VSE Engine, DAT, Patches - Wednesday, 00:25

           

          So it *looks* like it's not going to do anything. But in actual fact the task will run - if you have set a missed task delay of one minute, for example, the task will run at 12:01 on Tuesday.

           

          Sorry for the long-winded reply - does what I've describled match what you're seeing?

           

          Regards -

           

          Joe

          1 of 1 people found this helpful
          • 2. Re: 'Run Missed Task' not working

            Hi Joe

             

            Thanks for your quick response.

             

            Yes, what you describe is what I am seeing in the agent log. (I also have the missed task delay set to 1 minute as you descirbed from my own previous testing). However, the task still does not run 1 minute after connecting to the network. This is verified by the agent log and by right clicking on the McAfee Shield in the system tray and selecting 'about'. The DAT is still days out of date.

             

            Regards

             

            Martin

            • 3. Re: 'Run Missed Task' not working
              JoeBidgood

              Hmm... a bit strange then

               

              I note you say "1 minute after connecting to the nextwork."  In reality the agent is going to try to run the task one minute after the framework service starts - is the network likely to be available at this point? If not, what happens if you extend the delay to say 5 minutes?

               

              Alternatively, you could configure an additional task for these machines configured to run at logon - you can configure it to only run once a day if required, and again you can configure a startup delay if required. Maybe that would be more successful at catching these elusive machines

               

              Regards -

               

              Joe

              1 of 1 people found this helpful
              • 4. Re: 'Run Missed Task' not working

                Hi Joe

                 

                I tried setting the delay to 5 minutes and still no success. Perhaps 'connecting to the network' was misleading. I should have said 'after startup / login / restart'.

                 

                I used the alternative method and created a new task to perform the updates. I tried the run 'at logon' and this worked.

                 

                If only the 'run missed task' option did what it was supposed to, it would be a much neater solution.

                 

                Thanks for your help with this problem Joe.

                 

                Regards

                 

                Martin.

                • 5. Re: 'Run Missed Task' not working
                  JoeBidgood

                  Hmm... I'm not sure what's happening there: the run missed task option certainly *should* work (albeit the slight weirdness I mentioned before).

                  If you want to pursue it, I'd open a case with Support-  we'll need to see the logs and so on in more detail. At least we have a functioning workaround at this point.

                   

                  Regards -

                   

                  Joe

                  1 of 1 people found this helpful
                  • 6. Re: 'Run Missed Task' not working

                    Hi Joe

                     

                    I would like to know why the 'run missed task' isn't working, even though we have found a workaround.

                     

                    How do I open a case with Support and can you tell me exactly what the support team would need in terms of information and log files?

                     

                    Regards

                     

                    Martin

                    • 7. Re: 'Run Missed Task' not working
                      JoeBidgood

                      The easiest method (I believe - someone else may correct me )  would be to log on at mysupport.mcafee.com  and open a service request there. I would imagine that you'll be sent the infamous MER (Minimum Escalation Requirement) tool, which will collect the necessary files and package them up for upload.

                       

                      Regards -

                       

                      Joe

                      • 8. Re: 'Run Missed Task' not working
                        nbaumann

                        Hi, Martin

                        Did you ever got a reason for this to happen?

                         

                        I'm currently testing ePO 4.5 + VSE8.7 and have the same issue.

                         

                        In my case the Agent Logfile has the following entries :

                         

                        2010-09-29 09:46:39              i              #2020    Sched      Next time(local) of task Signature Update:
                                                                                        Mittwoch,29. September 2010 19:06:00

                        <...>

                        2010-09-29 09:46:40              i              #1356    Sched      Scheduler: Missed task: [Signature Update]
                        2010-09-29 09:46:40              i              #1356    Sched      Next time(local) of task Signature Update:
                                                                                        Mittwoch, 29. September 2010 09:56:40

                         

                        It looks like the scheduler recognizes that he had missed a task which he should repeat but the update does not take place at the mentioned time.

                        The computer was powered on during that time.

                         

                        2010-09-29 09:54:42              i              #1392    Agent      Next policy enforcement in 5 minutes
                        2010-09-29 09:59:38              I              #1380    Agent      Sending the next batch of immediate events

                         

                        Even worse, after a reboot, the scheduler does not detect the missed update again and continues to schedule it to the upcoming evening (19:00).

                        I'm wondering what happens tomorrow morning when I power off the machine before 19:00 so the update cannot happen.

                         

                        Further settings I made:

                         

                        ASCI interval: 60min

                        Policy enforcement interval: 5min

                         

                        Default AutoUpdate Task is disabled

                        Client Task "signature update":

                        - Schedule daily

                        - Stop if runs for 1h

                        - Randomize 30min

                        - Run missed task delayed 10min

                        - Repeat between 7:00 AM and 6:00 AM every 12 hour(s).

                        - Every 1 day

                         

                        Any ideas, anyone?

                        • 9. Re: 'Run Missed Task' not working

                          Hi nbaumann

                           

                          Unfortunately, I didn't find a resolution to the original problem. I created another task which ran at logon, so whenever clients restarted / logged on / connected to the network, they would get the update task.

                           

                          Martin.

                          1 2 Previous Next