1 Reply Latest reply on Jan 6, 2010 2:32 PM by GWIRT

    Change SQL settings in 4.5

      Hi,

       

      There were some changes done to the SQL server and I need to change the settings of ePO 4.5. The problema is that as ePO 4.5 fails to connect to the database it is nagging me about failing to load the license data. Which makes it impossible to login to correct the SQL connection information because the login and password fields are greyed out in https://localhost:8443/core/config. Even by putting the licence key again it will not allow me to go through because it can't update the database. In the application log it is saying that is can't connect to the database which is what I am trying to fix.

       

      Any other way to change the SQL connection information? Or to insert the licence locally so it doesn't search the database?

       

      This issue is already described in KB66166 but the presented solution doesn't actually help me in any way. Because I know I need to update the SQL connection.

       

      https://kc.mcafee.com/corporate/index?page=content&id=KB66166

       

      Seems a case of cyclical dependencies...

        • 1. Re: Change SQL settings in 4.5
          GWIRT

          You can edit the file "C:\Program Files\McAfee\ePolicy Orchestrator\Server\conf\orion\db.properties"

           

          You can set the values manually:

           

          db.database.name= <- DB mane

          ...
          db.instance.name= <- SQL Server instance name
          db.user.passwd= <- Remove ".encrypted" and you can put the password in in cleartext. You can the use core/config to re-enter the info.

          db.user.domain= <- for NT authentication
          db.user.name= <- Username
          ...
          db.server.name= <- SQL server name