8 Replies Latest reply on Apr 26, 2010 4:18 PM by jstanley

    SA repository replication failed

      Hi,

       

      I am running ePO 4.0 with patch 5 and 100+ Super Agnet repositories configured.

      This was running perfect from last 1year, know I am faing major issue that 80% of our repository replication update failed to updated from master server.

       

      I have communicated with mcafee support and found temporary solution that running mirror task on each repository.

      I configured the same on 2-3 repository server for testing perpose. repository servers are updating from this but after coying the contets of mirror task folder to

      the repository folder all our local clients are updating from master server / http intead of local repository server.

       

      Please provide me any alternate soltions for this since manual update task also failed to update my systems it very big issue.

       

      Need solution to update repository servers and its clients systems without communicating to master ePO server.

       

      advanced thanks for your help.

       

      Regards,

      Mohan

        • 1. Re: SA repository replication failed
          jstanley

          Repository replications can fail for many reasons so its hard to give a good suggestion with the information provided. We would need to review the error in the epoapsvr.log as a starting point. Try this:

          1. Start a replication to just 1 of the SA repositories that is failing and wait for it to fail
          2. Immediately after the failure grab a copy of the epoapsvr.logwhich should be located here: <install directory of EPO>\DB\Logs\
          3. Review the log and if it is not providing you any guidance then post a copy of the log on this thread. Be sure to include the name of the distributed repository so we know what to look for in the log.

           

          Thanks!

          • 2. Re: SA repository replication failed

            Hi Thanks for your help.

             

            yes we are suspecting network bandwidth issue, but I need some solution atleast SA repositories should take update directly from NAIhttp.

            So I am running mirror task, after completion it changes sitestat.xml entry to disable state all clients failed to update.

             

            If I replace the sitesta.xml from master server clients are successfully updating from local repository server.

             

            Any way that we should prevent mirror task changing sitestat.xml, otherwise each time we need to copy only updates to repository or replace sitestat.xml file.

             

            Thanks & Regards,

            Mohan

            • 3. Re: SA repository replication failed
              jstanley

              The functionality you are describing is exactly what the VSE Mirror task is designed to accomplish.

               

              The solution here if I understand your problem correctly is setup VSE mirrored repositories and add these mirrored sites to the agent policy. To add locally defined repositories (so repositories no directly controlled by EPO) to the agent policy do this:

              1. Logon to the EPO console
              2. Edit your agent policy
              3. Select the Repositories tab
              4. Click Add
              5. Fill in the information to connect to the locally defined policy (typically a VSE mirror would setup a UNC share)
              6. Click OK
              7. Assign the priority if you are using a user defined list and save the agent policy.

               

              As for the replication problem if bandwidth is the issue you can try the following:

              • Switch to the V2 DAT site which cuts in half the amount of data replicated for a DAT. This should work fine so long as you are not using any legacy products (such as VSE 8.0i)
              • Modify your repository pull task so you are only pulling information you need. For example if you are not using HIPS you do not need to pull HIPS content.
              • Chain your repository replication task off your repository pull task and schedule your repository pull task to occur after hours (when hopefully bandwidth will not be such a concern)
              • Further break your repository replication task up (ie add more tasks to the chain) so that each task in the chain is only replicating to a few repositories. Since one task in the chain will not run until the last task is complete this will reduce the amount of data that EPO is replicating at any one time. If you do this I'd suggest putting your slowest distributed repositories in the last task in the chain.

               

              I hope that helps!

              1 of 1 people found this helpful
              • 4. Re: SA repository replication failed

                Hi,

                 

                hope this will resolve our repository udpate issue

                thank you soo much, but if you let me know how to configure to udpate V2 dat i will do this in test environment & udpate.

                 

                Advaced Thanks

                 

                Regards,

                Mohan

                • 5. Re: SA repository replication failed
                  hem

                  You can create a source repository specifying the V2 details (Http site:update.nai.com/products/commonupdater2, 2- FTP site:ftp.nai.com/commonupdater2), pull only V2 Dats then as Jeremy suggested continue with the replication.

                  • 6. Re: SA repository replication failed

                    Hi Jeremy I need your Help.

                     

                    I came across your blog and I tried everything without sucesfully

                     

                    I have 13 SA Repository and the problem is with 4 of them.  The Super Agent Repository Replication Task failed every day at the same point (after Copy VSE870.msi) almost 45% after 1 hour 45minutes, I created a new task (testing) using just one SA Repository and the result is the same "Failure".

                     

                    I let you know all the changes tried and the Mcafee Ambient Configuration:

                     

                    * EPO 4.5 Patch 1

                    * SA Repository Agent 4.0 Patch 3

                    * Enterprise 8.7

                    * I Create a new task replicating just one SA repository in a diferent schedule of the master task that replicate all the right SA repository without failure, and choosed the necesary packages (Engine, Dat, Agent) and clear the check Replicate legacy DATs

                    * Reinstall the Agent in the SA repository (now it is using 4.0 patch 3)

                    * Every Day the replication failed at the same point (after Copy VSE870.msi),

                    * I am using advace Logging in the EPO Server

                    * It´s not a DNS or NTFS Permission Problem

                     

                    Please Help me,

                    I´ll send you part of the EPOAPSRV Log file:

                     

                    20100421042134 I #5284 naInet   ------------------------------------------------------------
                    20100421042134 I #5284 SIM_InetMgr Session 1 ended, result=1
                    20100421042134 I #5284 SiteMgr  GeneralInetRequestThreadProc: GeneralInetRequest thread ended
                    20100421042134 x #5284 SiteMgr  SiteMgr main control final release...
                    20100421043343 I #3084 naInet   HTTP Server returned success, HTTP return code: HTTP/1.0 200 OK

                    20100421043343 I #3084 SIM_InetMgr Uploaded file VSE870.msi successfully in session 1
                    20100421043343 I #1544 naInet   HTTP Session closed
                    20100421043343 I #1544 naInet   ------------------------------------------------------------
                    20100421043343 I #1544 SIM_InetMgr Session 1 ended, result=1
                    20100421043343 e #1544 SiteMgr  ReplicationThreadProc: Upload data to site ePOSA_NASAMCBO failed
                    20100421043343 e #2724 SiteMgr  ReplicationThreadProc: Replication finished with partial failure
                    20100421043343 x #2724 SiteMgr  SiteMgr main control final release...

                     

                    Thank you in advance

                    • 7. Re: SA repository replication failed
                      jstanley

                      This probably belongs on a new thread.

                       

                      If your successfully replicating to 9 repositories and you have 4 that are failing then the problem most likely does not reside in EPO. Especially if its only one specfic file your having problems replicating. First I'd try removing all the contents of those repositories and re-replicating (one at a time) during off-peak hours on your WAN. Simply locate the folder on the HDD hosting the repository and delete all the contents. If the problem was related to file corruption on the repository itself this should fix it.

                       

                      If that doesn't work then start a new thread and post the entire epoapsvr.log. Please grab the log immediatly after failing the replication and state the name of the repositroy that failed to replicate in the thread (as it will make it easier to find the errors in the log).

                      • 8. Re: SA repository replication failed

                        Hi Jeremy thank you for your answer. I created a separated post : http://community.mcafee.com/thread/24071?tstart=0

                         

                        In fact i did your recomendations before, I mean delete all the files, created a new task replicating just one distributed repositories in off peak hours and the result is the same "task failed"

                         

                        I tried copying all the files using windows file copy and after that run the replication task and now the error is present copying a different file (.dat) The Site Name is nasamcbo, please check the add file (eposrvlog.zip)

                         

                        thank you for your help